Ir al contenido

Utilizamos cookies propias y de terceros para mejorar nuestros servicios y mostrarte publicidad relacionada. Si continuas navegando, consideramos que aceptas su uso. Puedes obtener más información aquí. Cerrar
  • Entrar con Facebook Entrar con Twitter Entrar con Google      Entrar   
  • Crear Cuenta

Foto

Pequeño lio


  • Este tema esta bloqueado Este tema esta bloqueado
15 respuestas en este tema

#1 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 30 enero 2006 - 14:04

Hola, cuando instale suse en el pc tenia dos discos duros formateados en NTFS, puse suse en el segundo, ahora he formateado la particion NTFS del segundo en FAT32 para poder escribir en ella, se que tengo que editar el archivo /etc/fstab y cambiar ntfs por vfat (si no es vfat corregidme por favor) y donde pone ro cambiarlo por rw, hasta ahi la teoria pero cuando me dispongo a ello entro en la consola como root y escribo: "kwrite /etc/fstab" y me dice kwritre command not found, he intentado con KWrite, Kwrite, KWRITE y en todos casos me dice lo mismo., como abro el archivo en cuestion para despues editarlo, con ubuntu hago gedit /etc/fstab y se abria el editor y modificaba lo que necesitaba pero con suse no se como. Seguramente sera tan obvio que no se verlo. Gracias

  • 0

#2 cuqui

cuqui

    Master

  • +Miembro
  • 1.161 mensajes
0
Neutro

Escrito 30 enero 2006 - 15:44

intenta con mcedit /etc/fstab

  • 0

#3 mced

mced

    Super Moderador

  • +Miembro
  • 13.669 mensajes
0
Neutro
  • Santander

Escrito 30 enero 2006 - 16:06

Hay montones de editores: quizá el vi resulte un tanto complicado, pero también tienes nano desde la consola. Y en las X, kedit, gedit...

Y sí, es vfat la opción.

  • 0

#4 ErNi_

ErNi_

    Experto

  • +Miembro
  • 478 mensajes
0
Neutro
  • Asturias

Escrito 30 enero 2006 - 17:02

El problema no tiene nada que ver con el sistema de archivos de la partición/particiones, la cosa tiene que ver con que si el usuario que lanza las X es el mismo que lanza la aplicación que hace uso de las X, estas lanzando las X como usuario y estas intentando lanzar una aplicación que hace uso de las X con otro usuario (como root), para editar como root te vale cualquier editor de consola, con "su" o "su -" cambia de usuario a root, lo editas, sales guardando los cambios y "exit", como root hay que estar solo lo indispensable (es complicado que un usuario pueda cargarse el sistema en cambio con el root es muy facil).

Para que todo el mundo pueda leer y escribir sin que de problemas la linea del /etc/fstab para una partición FAT32 podria ser algo como:
/dev/hda5       /mnt/windows_d      vfat     defaults,user,umask=000      0  0
Las "chapuzillas" (desde mi punto de vista) que hace ubuntu/kubuntu de no tener la cuenta la cuenta root activada parece que hacen a la distribución mas "segura", pero cualquiera puede ejecutar "sudo rm -rf /" (NO HAGAIS LA PRUEBA) y cualquiera se puede cargar el sistema.

  • 0

#5 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 30 enero 2006 - 22:38

Bueno pues la he dejado asi (se supone que de esta manera podria leer pero no escribir)
dev/hdb2            /                    reiserfs   acl,user_xattr        1 1
/dev/hda1            /windows/C           ntfs       ro,users,gid=users,umask=0002,nls=utf8 0 0
/dev/hdb5            swap                 swap       pri=42                0 0
devpts               /dev/pts             devpts     mode=0620,gid=5       0 0
proc                 /proc                proc       defaults              0 0
usbfs                /proc/bus/usb        usbfs      noauto                0 0
sysfs                /sys                 sysfs      noauto                0 0
/dev/dvd             /media/dvd           subfs      fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/dvdrecorder     /media/dvdrecorder   subfs      fs=cdfss,ro,procuid,nosuid,nodev,exec,iocharset=utf8 0 0
/dev/fd0             /media/floppy        subfs      fs=floppyfss,procuid,nodev,nosuid,sync 0 0
/dev/hdb1            /windows/D           vfat       ro,users,gid=users,umask=0002,nls=utf8 0 0
pero no puedo leer

  • 0

#6 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 30 enero 2006 - 22:44

En cuanto a lo que tu dices de ubuntu/kubuntu, la verdad es que yo no soy un experto sino todo lo contrario, yo no tengo la impresion de que la hagan mas segura o insegura, lo que si la hacen es mas comoda de usar (bajo mi punto de vista y sin animo de polemizar), me explico yo abria la consola>sudo gedit /etc/fstab y se abria una ventana donde podia hacer los cambios que quisiera a continuacion salia guardando los cambios y listo, ahora hago:
FML:/home/xiquets # kedit /etc/fstab
bash: kedit: command not found
FML:/home/xiquets #
con mcedit si abre el archivo /etc/fstab pero (burrete que es uno) ¿como guardo los cambios?
Por cierto, he conseguido cambiar ntfs por vfat con la opcion reparar del cd de instalacion
Edito: ya se como se guardan los cambios, con F2, yo pulsaba 2 y no conseguia nada, pero despues de cambiar ro por rw sigo sin leer en la particion de marras

  • 0

#7 miquelsi

miquelsi

    Constante

  • +Miembro
  • 84 mensajes
0
Neutro
  • L'Alacantí

Escrito 30 enero 2006 - 23:46

Creo que la linea que deberias poner en el /etc/fstab es la siguiente:

/dev/hdb1       /windows/D  vfat    iocharset=utf8,umask=000   0       0

Tras editarla, haz "mount -a", para que remonte todos los sistemas de ficheros.
Tienes estas instrucciones aqui, aunque lo ponga para ubuntu, te sirve igual.
Un saludo.

  • 0

#8 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 31 enero 2006 - 20:27

Pues me pasa esto:
FML:/home/manolo # mount -a
mount: tipo de sistema de ficheros incorrecto, opción incorrecta, superbloque incorrecto en /dev/hdb1,
o número de sistemas de ficheros montados excesivo
Creo que va siendo hora de probar suse 10 o kubuntu en el pc de sobremesa

  • 0

#9 Nacx

Nacx

    Master

  • +Miembro
  • 1.138 mensajes
0
Neutro
  • /home/nacx

Escrito 31 enero 2006 - 21:18

Despues de que te de el error, mira la salida de dmesg | tail para ver si da maś información de lo que está mal.

  • 0
Hay una delicada línea entre pescar y hacer el imbécil a la orilla de un río.

Posted Image

#10 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 01 febrero 2006 - 13:14

Gracias Nacx, esto es lo que obtengo:
FML:/home/manolo # dmesg | tail
usbcore: registered new driver usbserial
drivers/usb/serial/usb-serial.c: USB Serial Driver core v2.0
Linux video capture interface: v1.00
bttv: driver version 0.9.15 loaded
bttv: using 8 buffers with 2080k (520 pages) each for capture
Non-volatile memory driver v1.2
end_request: I/O error, dev fd0, sector 0
end_request: I/O error, dev fd0, sector 0
bootsplash: status on console 0 changed to on
FAT: Unrecognized mount option "nls=utf8" or missing value
Saludos

  • 0

#11 miquelsi

miquelsi

    Constante

  • +Miembro
  • 84 mensajes
0
Neutro
  • L'Alacantí

Escrito 01 febrero 2006 - 13:50

Que mania de tan catastrofista de reinstalar cada vez que hay algun error... El mensaje que has pegado muestra claramente cual es el problema: la opcion "nls=utf8" no la reconoce. Prueba a poner "iocharset=utf8", como te puse un par de posts más arriba. A ver que tal.

Saludos

  • 0

#12 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 01 febrero 2006 - 14:10

Lo de reinstalar no es por este error, ya lo tenia en mente antes, el motivo de reinstalar es este
http://www.adslayuda...ic-t-60437.html
solo me pasa con mi cuenta de usuario, en las otras cuentas de usuario no pasa. De todas formas provare eso que me recomiendas. Gracias

  • 0

#13 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 01 febrero 2006 - 14:16

Pues no se donde esta el error pero me pasa esto despues de cambiar lo que me aconsejas
FML:/home/manolo # dmesg | tail
subfs: unsuccessful attempt to mount media (256)
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
FAT: utf8 is not a recommended IO charset for FAT filesystems, filesystem will be case sensitive!
usb 4-3: USB disconnect, address 3
SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.1.34 DST=208.179.41.30 LEN=52 TOS=0x08 PREC=0x00 TTL=64 ID=13023 DF PROTO=TCP SPT=1138 DPT=80 WINDOW=8300 RES=0x00 ACK FIN URGP=0 OPT (0101080A002AE4E900F386FB)
SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.1.34 DST=208.179.41.30 LEN=52 TOS=0x08 PREC=0x00 TTL=64 ID=13024 DF PROTO=TCP SPT=1138 DPT=80 WINDOW=8300 RES=0x00 ACK FIN URGP=0 OPT (0101080A002BFEE900F386FB)
SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.1.34 DST=66.102.11.104 LEN=40 TOS=0x08 PREC=0x00 TTL=64 ID=9434 DF PROTO=TCP SPT=1120 DPT=80 WINDOW=8576 RES=0x00 ACK FIN URGP=0
SFW2-OUT-ERROR IN= OUT=eth0 SRC=192.168.1.34 DST=66.102.11.99 LEN=40 TOS=0x08 PREC=0x00 TTL=64 ID=1654 DF PROTO=TCP SPT=1125 DPT=80 WINDOW=32767 RES=0x00 ACK FIN URGP=0
Saludos

  • 0

#14 miquelsi

miquelsi

    Constante

  • +Miembro
  • 84 mensajes
0
Neutro
  • L'Alacantí

Escrito 01 febrero 2006 - 15:11

¿Y no puedes acceder a la particion? Yo lo tengo asi, tambien me da el error ese "filesystem will be case sensitive", pero no es nada grave, puedo usarla perfectamente.
Los mensajes de más abajo son paquetes TCP que envia la tarjeta de red para conectarse, no le hagas caso.

  • 0

#15 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 01 febrero 2006 - 16:42

Con la cuenta de mi hija si, pero con la mia no, al igual que me pasa con el error de Kioexec... que postee en el foro anteriormente, por eso me planteaba cambiarme a suse o kubuntu y al añadirse ahora este problema ya me hizo plantearmelo mas seriamente. Gracias, lo pensare

  • 0

#16 MANOLOMP

MANOLOMP

    Master

  • +Miembro
  • 865 mensajes
0
Neutro
  • La Plana Alta

Escrito 01 febrero 2006 - 19:20

Solucionad, en parte, ya todos pueden leer y escribir, aunque cuando pincho en el icono de my computer sigue saliendome ese error, por lo demas todo ok. Gracies.

  • 0