Ir al contenido

cable RS232 siemens c25-c45 para actualizar Firmware 660HW??


piolinsa
 Share

Publicaciones recomendadas

Gracias a todos por las respuestas.Me habeis ayudado mucho,gracias. :wink:

Cuando tenga un rato libre me liare a confeccionar el cable y si puedo me lo currare y haré una especie de Brico,es decir,explicando paso a paso de como lo he hecho incluidas fotos.Y o publicaré en este foro,para que otros usuarios lo tengan mas fácil a la hora de descapar su router.

Saludos. :roll:

Enlace al comentario
Compartir en otros sitios web

  • Respuestas 199
  • Created
  • Last Reply

Top Posters In This Topic

lo siento no me esplique bien aveces me lio esplicando cosas que no vienen a cuento.

si es un usb emulando un puerto serie, lo cierto es que probe con este cable porque sabia que la comunicacion con el c60 se hacia con Tx,Rx y gnd y en adslzone lei que el 3,3 no era necesario y pense lo peor que puede pasar es que no se conecte... pero funciono.

Enlace al comentario
Compartir en otros sitios web

lo siento no me esplique bien aveces me lio esplicando cosas que no vienen a cuento.

si es un usb emulando un puerto serie, lo cierto es que probe con este cable porque sabia que la comunicacion con el c60 se hacia con Tx,Rx y gnd y en adslzone lei que el 3,3 no era necesario y pense lo peor que puede pasar es que no se conecte... pero funciono.

Ok mbazan ya he actualizado el post con la info que nos has proporcionado, muchisimas gracias por tu aportación :wink: y por las de todos los que participan en este foro, sois COJONUDOS :wink:

Enlace al comentario
Compartir en otros sitios web

Hola a todos. Os queria hacer una pregunta, he visto en las fotos posteadas por Turbo5 que el conector negro que va enchufado en el conector macho interior del router, lleva 5 conexiones para pins y solo utiliza cuatro hilos para conectar al router, con lo cual queda uno libre. Yo he sacado de un pc viejo (pentium 2) el cable de audio que conecta la placa base con una unidad lectora de cd, pero solo tiene el conector 4 conexiones , con 3 cables. No se si me explico bien, me falta en el conector un cable. ¿como lo puedo obtener? ¿si no utilizo el wifi, me interesa actualizar a la version de firmware 10 original, o me quedo con la b.45 de telefonica?

Ya se que puedo utilizar uno de los conectores que llevan las cajas para conectar el interruptor de encendido, el reset, o el altavoz para hacer el 4 hilo que me falta para conectarlo al router, solo era por si se podia conseguir un conector entero con 4 conexiones con hilo y una libre entre la 1ª de la derecha y la 3ª conexion a la placa base del router.

Muchas gracias.

Enlace al comentario
Compartir en otros sitios web

Hola a todos. Os queria hacer una pregunta, he visto en las fotos posteadas por Turbo5 que el conector negro que va enchufado en el conector macho interior del router, lleva 5 conexiones para pins y solo utiliza cuatro hilos para conectar al router, con lo cual queda uno libre. Yo he sacado de un pc viejo (pentium 2) el cable de audio que conecta la placa base con una unidad lectora de cd, pero solo tiene el conector 4 conexiones , con 3 cables. No se si me explico bien, me falta en el conector un cable. ¿como lo puedo obtener?

Ya se que puedo utilizar uno de los conectores que llevan las cajas para conectar el interruptor de encendido, el reset, o el altavoz para hacer el 4 hilo que me falta para conectarlo al router, solo era por si se podia conseguir un conector entero con 4 conexiones con hilo y una libre entre la 1ª de la derecha y la 3ª conexion a la placa base del router.

Muchas gracias.

Hola, en lo referente al cable de 4 pines, puedes utilizar uno de los de audio que se utilizan en las unidades de CD´s para conectarlas a la tarjeta de sonido o hacer lo que dice nuestro amigo Razorblade que también va de PM :wink:

¿si no utilizo el wifi, me interesa actualizar a la version de firmware 10 original, o me quedo con la b.45 de telefonica?
La verdad es que se ha hablado tanto del tema....lo cierto es que los ultimos firm oficiales Zyxel tienen firewall integrado y soporte wireless g+ (125mb/s, pero para el que tenga un adaptador wi-fi compatible con esa tecnología) por no hablar de la tabla nat que tiene el PE10 (5000) lo hace que el e-mule lo agradezca, lo que pasa es que el Pe10 a algunos (entre los que me incluyo) les ha resultado bastante inestable por Wi-fi y a otros también por cable (también me incluyo :oops: debido a que se colapsa el bichejo) :evil: , pero por provar a metele el Pe10 a ver que tal no pasa nada, si te resulta inestable pues le metes la pe9 que aún teniendo la nat a 1024 tienes las ventajas que te he dicho antes...y alguna más..., cosa que los de telefónica no huelen ni en pintura :evil:

P.D: Por cierto, los firms de Timo yo no puedo ni verlos (nada mas pensar en el capamiento a los que lo someten me pongo.....:twisted: )

Enlace al comentario
Compartir en otros sitios web

Gracias a ambos por responder. Estoy en proceso de hacer el cable para poder actualizar el firmware al Pe10.He seguido todos vuestros posts , pero aun tengo dudas sobre los firmwares Pe(oficiales). Si sois tan amables, aver si me podeir decir que ventajas tienen respecto a los de timo.

Aunque el Pe 9 solo tiene 1024 conexiones,¿ con este firmware el router va mejor que con los de timofonica?

¿Para actualizarlo al oficial, debo de poner primero el b.20 de telefonica y luego despues de seguir todo el proceso, puedo poner directamente el Pe.10 ó el Pe.9?

Un saludo.

Enlace al comentario
Compartir en otros sitios web

Para cambiar a un firmware oficial de ZyXEL, debes hacerlo desde el b.20 como bien dices. Si no no podrás cambiar los feature bits.

Para saber si el router va mejor o peor, no tienes más que mirar los .pdf que acompañan a los firmware, y verás las enormes listas de errores corregidos, y nuevas características. Por tanto se supone que un firmware más actual es mejor que uno más anticuado (aunque ello no quita que aparezcan nuevos errores, véase el PE.10). Y también se supone que un firmware "libre" es mejor que un firmware de una compañía (ej: telefónica).

Pero todo es relativo.....

Enlace al comentario
Compartir en otros sitios web

Gracias a ambos por responder. Estoy en proceso de hacer el cable para poder actualizar el firmware al Pe10.He seguido todos vuestros posts , pero aun tengo dudas sobre los firmwares Pe(oficiales). Si sois tan amables, aver si me podeir decir que ventajas tienen respecto a los de timo.

Aunque el Pe 9 solo tiene 1024 conexiones,¿ con este firmware el router va mejor que con los de timofonica?

Un saludo.

Yo a titulo personal puedo decir que he notado como con la pe9 oficial el e-mule y la navegación simultanea a mejorado con respecto a los de timo y he ganado en estabilidad wi-fi (en la pe9 ya que la pe10 me da problemas) , por no hablar de las diferencias básicas que te he comentado mas arriba, es decir los de telefónica no incorporan Firewall ni Wi-fi G+ (125mbps) ni Tablas NAT a 5000 (en el Pe10) , lo cual ya es motivo suficiente para meterle un firm Oficial :wink:

¿Para actualizarlo al oficial, debo de poner primero el b.20 de telefonica y luego despues de seguir todo el proceso, puedo poner directamente el Pe.10 ó el Pe.9?

Como bien dice Razorblade hay que meterle la b20 para que nos deje hacer la modificación del feature bits de 4E a 4B y despúes de eso si que le puedes meter directamente el pe10 o el Pe9

Enlace al comentario
Compartir en otros sitios web

Hola,quería preguntaros a ver si me podeis aclarar algunas dudas.Soy un poco novato de la electrónica.

Según este dibujo¿Que materiales debo comprar?

dibujo2jx.jpg

¿Puede ser?

1 resistencia de 1.5K 1/4W

1 resistencia de 4.7K 1/4W

1 resistencia de 22K 1/4W

1 resistencia de 3.9K 1/4W

2 transistores BC 337

Otra cosa.¿ ESTE para que sirve y donde se acopla?¿O esque falta una linea horizontal en el dibujo?

¿ESTE CONECTOR que sería el macho o hembra?

¿Y que significan estos símbolos?¿Es algo de los colores de los cables?

RX TX DTR GND

Gracias a todos de antemano. :wink:

Enlace al comentario
Compartir en otros sitios web

Muchas gracias por responder Razorblade. :wink:

Lo que aun me ha quedado una duda,por eso preguntaba lo de Tx y demás.El caso es que tengo un cable de un mouse,y pelando en cable salen 4 cablecitos de cada color.Negro,rojo,marrón y naranja.¿Como se cual es el que va a cada pin del conector?

He visto que en el conector pone unos números del 1 al 9.

Otra duda que tampoco me he acabado de aclarar.Este conector de la foto que sería macho o hembra? No me he acabado de aclarar con el esquema.

cable20zyxel2025qp.jpg

Y la última duda.¿Las resisténcias tienen polaridad?¿Y lo transistores?

Los transistores que he comprado tienen las 3 patillas iguales y no se en que sentido se montan.

Muchas gracias a todos.Saudos. :roll:

P.D: ¿Sirve cable de audio para montar el circuito?

Enlace al comentario
Compartir en otros sitios web

Hola chicos.Ya he montado el cable,pero tengo un problema.Cuando esntro al TeraTerm no me deja escribir.¿Hay que poner COM1?Porque he probado COM1 COM2 COM3 y COM4 y en el 1 y el 2 aparece el piloto para escribir,pero le doy al teclado y nada.Y en el 3 y 4 me dice que no se puede abrir la conexión.¿Habré montado algo mal?

He comprobado con el tester todas las conexiones y parece que etán bien ¿Exactamente donde he de darle?

En un post he leido que hay que dejar apretada una tecla,pero ni aun así me funciona.

Exactamente me sale esto:

29rf.jpg

¿Y aquí que he de poner?

17lv.jpg

Saludos y gracias. :wink:

Enlace al comentario
Compartir en otros sitios web

Seleccionas abajo, Serial y seleccionas el puerto COM de la lista...

Luego, apagas el router y lo vuelves a encender, y en la pantalla van a salir varios puntos "..........." ahí y luego el mensaje "Press any key to enter debug mode". Ahí presionas una tecla y entrarás al modo debug...

Enlace al comentario
Compartir en otros sitios web

Bueno, aunque ya has montado el cable, en respuesta a las preguntas de antes:

Las resistencias no tienen polaridad, y los transistores sí. Los pines del transistor se llaman: Emisor, Base y Colector. Tienes que buscar la hoja de características del transistor en cuestión en el Google por ejemplo, para saber qué pin corresponde a cada cosa. Y luego por supuesto, tienes que saber en el esquema de un transistor, qué parte del símbolo representa cada pin.

Como dices que tienes un tester, supongo que habrás comprobado qué cable corresponde a cada pin del puerto serie con él, ¿no?

Cuando puedas nos cuentas qué tal te ha ido al final poniendo lo del puerto COM que te ha dicho TonyCool.

Enlace al comentario
Compartir en otros sitios web

  • 2 weeks later...

Hola buenas.

Piolinso me gustaria saber varias cosas sobre el tema, puesto que quiero hacer un cable a partir del cable del movil que tu has usado el c25 (comprar el cable encuentro que es la opcion mas sencilla para mi, que no tengo ni idea de electronica).

De cuantos cablecitos esta compuesto el cable en cuestion del conector siemens c25? Son de diferentes colores? Es facil abrir el conector que va al movil para asi ver que cablecito va a cada pin y poder empalmar chapuceramente al cable de audio para no tener que hacer uso de soldador ni tester??

Gracias y perdón por mi ignorancia electrónica :D

Enlace al comentario
Compartir en otros sitios web

De cuantos cablecitos esta compuesto el cable en cuestion del conector siemens c25? Son de diferentes colores?

Ante todo Bienvenido Boceto :wink: ....

Pues en mi caso usando el cable original del siemens tengo 5 cables de los cuales sólo necesitamos

Negro=GND

ROSA (o mas o menos rosaceo,JEJEEJ)=RX

ROJO=TX

Y aquí te pongo el pinout

pinoutsiemensc25451es.jpg

Eso sí, si es otro cable no original los colores pueden cambiar aunque el pinout sigue siendo el mismo

Es facil abrir el conector que va al movil para asi ver que cablecito va a cada pin y poder empalmar chapuceramente al cable de audio para no tener que hacer uso de soldador ni tester?

No es difícil abrir el conector si utlizas un destornillador plano, o un cutter (con cuidado) o cualquier herramienta que te permita abrirlo..

:wink:

Enlace al comentario
Compartir en otros sitios web

Buenass, acabo de comprobar si funcionaba con el del nokia 3310, pero por ahora nada, lo cierto es que tambien soy nuevo y disponia de las piezas para hacerlo al viejo estilo, pero por vagancia y miedo preferi dejarlo, y ahora viendo el post pues me anime pero sin tener resultado.

E soldado las patillas como se indica menos el MBUS- que no se ni que es buscando por google e encontrado como fabricarse uno mismo el cable del 3310 pero nada explikando en cristiano.

Imagino que no obtengo resultado por que no alimento esos 3,3v al router y quisiera saber de donde cojo dicho voltaje o desde donde lo meto.

Muchas graciassssss

edito: me arriesgo am MBUS haber,puede que no me volvais a ver por aki xD jeje. pero si pasa eso volvere a deciros que no lo intenteis :P

vuelto a editar: ni se inmuta :´(.

Enlace al comentario
Compartir en otros sitios web

Hola buenas.

Piolinso me gustaria saber varias cosas sobre el tema, puesto que quiero hacer un cable a partir del cable del movil que tu has usado el c25 (comprar el cable encuentro que es la opcion mas sencilla para mi, que no tengo ni idea de electronica).

De cuantos cablecitos esta compuesto el cable en cuestion del conector siemens c25? Son de diferentes colores? Es facil abrir el conector que va al movil para asi ver que cablecito va a cada pin y poder empalmar chapuceramente al cable de audio para no tener que hacer uso de soldador ni tester??

Gracias y perdón por mi ignorancia electrónica :D

Yo compre el cable en es.ucables.com el del cs25 por puerto serie(cuesta 9.95 € + 6 de gatos de envio, entre semana llega de un dia para otro) no es un cable original, sino que lo han hecho ellos. Tiene 4 cables Gnd(negro), Tx(verde), Rx(Amarillo) el rojo no hace falta-creo que eran asi los colores, lo estoy diciendo de memoria-. De todas formas el negro es el pin 1 y luego vas conando uno de arriba uno de abajo asi hasta llegar el verde y amarillo.

Abres el conector que va al telefono y unes los cables mencionados a un cable de la tarjeta de sonido para conectarlo al router tal y como esta explicado. Es muy sencillo. Yo no tengo experiencia en electronica y fue muy sencillo.

Espero que te sirva de algo.

Salu2

Enlace al comentario
Compartir en otros sitios web

Buenass, acabo de comprobar si funcionaba con el del nokia 3310, pero por ahora nada....E soldado las patillas como se indica menos el MBUS- que no se ni que es buscando por google e encontrado como fabricarse uno mismo el cable del 3310 pero nada explikando en cristiano.

Imagino que no obtengo resultado por que no alimento esos 3,3v al router y quisiera saber de donde cojo dicho voltaje o desde donde lo meto.

Muchas graciassssss

edito: me arriesgo am MBUS haber,puede que no me volvais a ver por aki xD jeje. pero si pasa eso volvere a deciros que no lo intenteis :P

vuelto a editar: ni se inmuta :´(.

KbzA, si ya has provado a conectar el MBUS al +3,3V del Router, has seguido los pasos del tutorial de actualización (sobretodo seleccionando el puerto com que te pertenezca...) y el teraterm no muestra nada, mucho me temo que ese cable no es compatible con nuestro zyxel :( , la lista de pinouts del principio del post muestra lo que sería ideal (que funcionaran todos) pero la realidad es que los hay que no funcionan ni a tiros!!!! (parece que los nokia no lo hacen de ninguna manera... :evil: ) por lo que añadire debajo de los pinouts que hay serias dudas de que los cables para Nokia funcionen OK

Llegados a este punto tienes 2 opciones para descapar tu router:

1. Hacerte tu mismo el circuitillo de comunicación con el router, pero el sencillo de verdad, hay un esquema que sale bastante mas barato y es algo mas fácil de llevar a cabo, sin necesidad del max232 ni el max3232 ni siquiera condensadores, simplemente con 4 resistencias y 2 transistores , es este: ttltors2320kf.jpg ,

y puedo asegurar que funciona OK, y encima sin necesidad de conectarle el +3,3V :wink:

2. Comprarte un cable rs232 de móvil (pero de los que ya han sido testeados ehhh...) eso sí te saldrá algo mas cara esta solución...

P.D.: Los +3,3v los envia el router para alimentar el circuito de comunicación con el, si es que el susodicho circuito necesita alimentación para funcionar, ya que muchos cables de móviles se autoalimentan del puerto de serie, por lo que no necesitan esos +3,3v

Enlace al comentario
Compartir en otros sitios web

hola muy buenas, es mi primer post en este foro. estoy intentando hacerme el cable con el Serie de un Siemens s55. Sé que es nuevo jeje, pero esta jodío. El caso es que he encontrado el pinout en esta web: http://pinouts.ru/data/siemens_c55_pinout.shtml

Siguiendo ese esquema, escribo los colores:

1. rojo

2. negro

3. naranja

4. blanco

5. azul

6. verde

7. amarillo

(este es el orden en el que estaban pinchaos en el enganche pa meterlo en el teléfono. Por asociación, yo saco que GND = negro, TX = naranja, RX = blanco. Lo monto, tal y cual, pero cuando lo enchufo en el router, no pasa absolutamente nada... :S bueno si, que la pantalla se queda en blanco vamos... he comprobado la velocidad del puerto en el router 9600 y en el programita que recomendais tambien 9600. He probado con hyperterminal pero lo unico que me queda por pensar es que ese pinout no es correcto para este cable.

PD: es el cable original.

Saludos y muchas gracias.

Enlace al comentario
Compartir en otros sitios web

hola muy buenas, es mi primer post en este foro. estoy intentando hacerme el cable con el Serie de un Siemens s55. Sé que es nuevo jeje, pero esta jodío. El caso es que he encontrado el pinout en esta web: http://pinouts.ru/data/siemens_c55_pinout.shtml

Siguiendo ese esquema, escribo los colores:

1. rojo

2. negro

3. naranja

4. blanco

5. azul

6. verde

7. amarillo

(este es el orden en el que estaban pinchaos en el enganche pa meterlo en el teléfono. Por asociación, yo saco que GND = negro, TX = naranja, RX = blanco. Lo monto, tal y cual, pero cuando lo enchufo en el router, no pasa absolutamente nada... :S bueno si, que la pantalla se queda en blanco vamos... he comprobado la velocidad del puerto en el router 9600 y en el programita que recomendais tambien 9600. He probado con hyperterminal pero lo unico que me queda por pensar es que ese pinout no es correcto para este cable.

PD: es el cable original.

Saludos y muchas gracias.

Hola, ¿has habilitado el puerto serie COM1 en el teraterm?

Segun el pinout esta bien conectado, de todos modos a ver si te puede echar una mano, el amigo Piolinso, que fue el propulsor de este sistema.

Saludos y bienvenido al foro.

Enlace al comentario
Compartir en otros sitios web

Gracias por responder encoder2. Sí, al conectar con el Tera Term seleccionaba el puerto COM1 en lugar de telnet claro. La cosa está en que lo he probado con HyperTerminal y tampoco funciona... no sale nada en la pantalla.

Se me olvidó decir, que aunque solo hay 7 pines con cable, hay otro cable que viene suelto y que es simplemente cable trenzado sin color ninguno. bueno, se puede considerar plateado. Pero como no estaba conectado a ningun pin en el conector al movil supongo que no tendrá utilidad aunque he pensado que a lo mejor es voltaje...

Perdonad mi ignorancia pero Electrónica Digital la aprobé de rebote el curso pasado :P Aún así de algo me entero... pero no lo suficiente como para hacerme un circuito de resistencias y tal...

Por eso quiero intentarlo con este cable, y si no pudiera compraré el que venden en ucables.com por 9,95 + Gastos... pero primero quero probar este.

Muchas gracias :)

Enlace al comentario
Compartir en otros sitios web

Bienvenido robermad1986 :wink: , pues en lo referente al pinout parece que si que se corresponde con el del siemens s55 a parte de estos otros Siemens A52, A55, A56, A60, C55, C56, C60, C65, CF62, CT56, M55, MC60, MT55, S55, S56, S57, S65, SL5C, SL55, SL56, 2218, SX1 cell con lo cual vas bien encaminado con la correspondencia de pines :P

2 Gnd (que según tu cable es negro)

3 Tx (que según tu cable naranja)

4 Rx (que según tu cable blanco)

Se me olvidó decir, que aunque solo hay 7 pines con cable, hay otro cable que viene suelto y que es simplemente cable trenzado sin color ninguno. bueno, se puede considerar plateado. Pero como no estaba conectado a ningun pin en el conector al movil supongo que no tendrá utilidad aunque he pensado que a lo mejor es voltaje...

Ese cable trenzado plateado generalmente también debería de corresponder con el GND con lo que no estaría mal utilizarlo como GND empalmado al Pin 2 del cable del móvil siemens s55 y estos a su vez conectados al MASA del Router (para descartar problemillas.....)

si los has conectado correctamente al conector del router que muestro a continuación 2.jpg

Solo te quedaría comprovar que se comunica correctamente con el router a través del teraterm asegurandote de lo siguiente:

1. que el router lo tienes desconectado del interruptor

2. que lo conectas correctamente en referencia a su pinout

3. que en el teraterm seleccionas el puerto serie COM correcto de tu ordenador al que hayas conectado el cable (esto es muy importante)

4.que la velocidad inicial de comunicación con el router sea de 9600Bps

Una vez seguidos estos pasos arrancas el router del interruptor y debería de aparecerte an la ventana del teraterm el chekeo de memoria que hace inicialmente el router y seguidamente algo así como Press any key to enter to debug mode ............... en ese momento clickas la barra espaciadora o el enter y ya estarías comunicandote correctamente con él......pero claro ese cable nadie lo ha podido testear por ahora y a lo mejor no se autoalimenta del puerto de serie lo cual significa que necesita recibir los +3,3v del router.

Lo único que te quedaría por provar si todo falla sería conectar el Pin 1 del Cable del Siemens (que según tu cable es rojo) al +3,3v del router a ver si en este caso si te funciona Ok, eso sí puede ser que ni con esas te puedas comunicar con tu Zyxel lo cual significaria que es incompatible para esos menesteres y tendrías que buscar algún metodo alternativo para meterle mano a tu router como sería el cable de los 2 transistores y 4 resistencias o si no quieres complicarte demasiado hacerte con un cable de móvil de los que ya han demostrado ser compatibles con tu router como bien dices :wink: (esa lista de cables compatibles la encontrarás al principio de este mismo post debajo de los pinouts)

P.D.1: Espero no haberme equivovado en nada, ya que hoy tengo lo que se dice un RESACÓN del 15!!!!! :oops::twisted:

P.D.2: Gracias a todos los que estaís por ahí ayudandome a echar un cablecillo a la gente :wink:

Salu2 y Feliz 2006 a Tod@s!!!!!!!!!!!!!!!!!! :lol:

Enlace al comentario
Compartir en otros sitios web

Invitado
Este tema está cerrado a nuevas respuestas.
 Share

×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.