Ir al contenido

cable RS232 siemens c25-c45 para actualizar Firmware 660HW??


Publicaciones recomendadas

  • Respuestas 199
  • Created
  • Last Reply

Top Posters In This Topic

OK, así sabremos si estos cables también funcionan sobre adaptadores de USB a Serie, aunque si no funciona de ninguna forma, te recomendaría buscar un PC con puerto serie para descartar el que el cable en sí funcione o no correctamente con el zyxel...

Un salu2 :wink:

Si. si. Es lo que voy a hacer.

Ya tengo localizado un ordenador con puerto serie con el que puedo enredar, y es este ordenador con el que voy a hacer las primeras pruebas para ver si el cable funciona y tengo comunicacion, o descartarlo definitivamente.

Evidentemente si no funciona, es una tonteria probar con el adaptador USB/SERIE.

Enlace al mensaje
Compartir en otros sitios web

Buenas de nuevo.

Bueno, comentar que el cable del Ericsson T28, funciona perfectamente :D

Pero hay que añadir... que no es autoalimentado, por lo que necesita la alimentacion de 3,3V que proporciona el router.

Si no le meto tension de 3,3V, no hay comunicacion con el router.

Este cable de datos, que por cierto... es el original, tiene el siguiente pineado por colores:

Naranja----> Al positivo de 3,3V del router

Negro------> Negativo

Blanco-----> RX

Verde -----> TX

Comentar igualmente, que he probado este cable con un adaptador SERIE/USB (para PC´s modernos y portatiles que no dispongan de puerto serie) y tambien funciona perfectamente.

Aunque OJO!!!, al menos en mi caso, he tenido que reconfigurar los puertos del PC, ya que tenia los 4 primeros puertos ocupados (com1 com2 com3 y com4) y como el Tera-Term solo permite en su configuracion la utilizacion de esta numeracion concreta... pues eso.

Todo me ha ido perfecto. Ya tengo mi 660 HW D1 con el firmware oficial de Zyxel, y la verdad es que el cambio merece la pena.

Un saludo a todos y gracias

Enlace al mensaje
Compartir en otros sitios web

x epielmagnificus

Bueno pues confirmamos lo que pensábamos, necesita de los 3,3v para funcionar correctamente...respecto a los colores, es preferible que nadie los tome como referencia y siempre se fijen antes en la correspondencia de pines para luego una vez identificada la función de cada pin anotar el color que le corresponda...(por norma general cada fabricante usa su própio código de colores y a veces hasta uno mismo los cambia.. :? )

Por otro lado, comentar que ya he añadido el cable a la lista de compatibles y testados (revisando el post principal de este hilo me he dado cuenta que en su momento sí que se probó este cable pero en este caso genérico y también necesitaba de alimentación así que junto a este he puesto este original como compatible y no autoalimentado :) ), también he añadido un comentario sobre la posibilidad de utilizar adaptadores serie a usb para emplearlos sobre pc´s que no tengan de un puerto serie pero sí alguno usb.....

Un salu2 y enhorabuena de nuevo :wink:

Enlace al mensaje
Compartir en otros sitios web
  • 4 months later...

Quizás pregunte una tontería, pero no he visto nada al respecto en esta rama, pero el caso es que tengo varios cables de consola de viejos routers en cuyos extremos hay un conector DB-9 y en el otro un RJ-45.

Mi pregunta ahora es... ¿es probable que estos cables sirvan? Desconozco si el propio conector serie lleve integrado un circuito análogo al que se trata en esta rama, pero quizás pudiera valer.

Obviamente se trataría de quitar el RJ-45 y adaptar el extremo para pincharlo a los Tx, Rx y Neg del PCB del router.

Enlace al mensaje
Compartir en otros sitios web

x ajz

Me temo que esos cables que comentas no se pueden emplear para ese fin :cry: , y es que tienen muchas posibilidades de que en vez de tener ningún circuíto interior de los que se han comentado en este hilo simplemente tenga cablecillos (puentes) que comunican los pines del puerto serie con los pines del conector rj45.....

Un ejemplo de cable que no sirve es el que se usaba en los xavi 7768.....

P.D. Otra cosa sería en caso de sospechar de algún cable concreto o de no tener nada que perder xD, tratar de desmontar el conector del puerto de serie (con mucho cuidado) y mirar a ver si tiene algún circuíto intermedio con algún max232 o similar....

Un salu2 :wink:

Enlace al mensaje
Compartir en otros sitios web
  • 1 month later...

Hola Chicos. Soy un recien registrado en el foro pero llevo tiempo siguiendo muchos posts que me han ayudado mil veces :D y ahora me he puesto con el tema este y claro saco mi cable para el Sony Ericsson T610 que tenia viejo ( el cable pone for ERI T68 ) y me pongo a mirar el pinout y resulta que no se parece a nada que haya visto en otros cables de datos de las fotos de los Sony Ericsson... os comento mirando por detras como decis los pines son los siguientes:

1- Sin Cable

2- Blanco

3- Naranja

4- Marron

5- Sin Cable

6- Azul

7- Sin Cable

8- Sin Cable

9- Sin Cable

10- Negro

11- Rojo

Como podeis comprobar no se parece en nada a los cable que hay en la primera parte del post... solo los dos ultimos (10 y 11) que supongo que son Masa y el 3.3v y el resto? a alguien se le ocurre algo? os puedo asegurar que "creo" que en todo el post no he leido nada parecido y lo he leido entero.

Haber si me echais una mano y rebiento el firmware de esta cosa que me trae de cabeza jejeje

Saludos a todos en mi primer post!!!

Enlace al mensaje
Compartir en otros sitios web

Hola Tormenta no se si no has pasado por la primera pagina del post... pero comentan esto:

Esta es la lista de cables que se han probado y no van ni para Atrás:

Nokia 3310 y se presupone 3330, 5510 y 3410 (Original) (Probado por KbzA)

Asi que ya sabes... o se compra otro cable o toca realizar el sencillo diseño de nuestros amigos.

Un saludo!!

Me edito a mi mismo... esto es lo que dice un compañero...

Hola a todos,

Gracias a vosotros ya tengo mi Zyxel con la ultima version (PE11). Very Happy Very Happy Very Happy

Para ello he usado el cable de un NOKIA 3310. No necesita alimentacion del router, la coge directamente del puerto serie, y los tres cables que lleva son los siguientes:

GND negro al nº 2

Rx blanco al nº 3

Tx azul al nº 4

Asi que eso deberias de usar... error mio que en el post principal aun dice que esos cables no funcionan y me base en eso... Asi tormenta22 que ya sabes jejeje

Enlace al mensaje
Compartir en otros sitios web
  • 2 weeks later...

Em holas soy nuevo aca intente armar el circuito de 2 trans y 4 ress lo q paso es q probe de artas formas de armarlo... nose e armado ortas veces circuitos.. y me an resultado.. asi q lo unico q me qeda por comprender es q lo arme mal nomas por q probe de mushas formas y nada.... lei todo el hilo... y s usha si algen es tan amable de dar fotos detalladas del circito como la foto q salia por hay..donde no se notan para donde ban los ables y menos las resistencias no se nota bien, si algen es tan amable de poner algunas fotos... usha q les estaria agradecido... porfa fotitos como si fuera para niños .. explicadas con manzanitas... honda tal cable de color en tal parte.. el nombre de cada resistencia.. todo tdo... weno un poco cargante la peticion.pero bue no m qeda otra...

La cosa mas extraña es q lo probe de mushas formas y nada.... una pura vez nomas el teraterm me tiro unos caracteres locos era puro assci... pero huvo coneeccion.....

Porfa ojala me alluden-.... me tien chato esta cosa :D

Weno saludos...

Enlace al mensaje
Compartir en otros sitios web
  • 5 months later...

Pues sólo aportar mi granito de arena a este hilo y foro. Tengo un cable para móvil siemens C55, que modificado me ha servido para liberar mi zyxel P660HW-D1 del firm de timofonica, que siguiendo los tutoriales, guias y consejos de los miembros de este foro lo he conseguido. :lol::lol:

Añadir que la comunicación la he efectuado a través de un puerto USB con adaptador a puerto serie. :roll::roll:

Saludos a todos.

Enlace al mensaje
Compartir en otros sitios web
  • 8 months later...

Hola a todos.

He podido comunicarme con el modem Zyxel P660-HW v2 con un cable USB ordinario y el cable de sonido en el otro extremo.

Al enviar comandos (ATSE) me devuelve OK, pero no logro entrar al modo Debug, al reiniciar el modem no aparece nada.

Supongo que me hace falta el circuito o no? lamentablemente, no puedo hacer ese circuito en éste momento, ni conseguir un cable de datos de celular. Espero poder comunicarme con el modem con éste cable, que está transmitiendo y recibiendo datos, pero no logro entrar al modo Debug.

Agradezco cualquier respuesta.

Saludos.

Enlace al mensaje
Compartir en otros sitios web
  • 5 months later...

Pues al Final me he decido a probarlo :idea: (uffff al principio estaba temblando :? levemente ehh :P ) y estoy en disposición de decir que está comprobado que el único cable del que dispongo (es el de un Siemens C25-C45 que va a parar al puerto de serie RS-232 del PC) Se comunica sin problemas con puerto de serie interno del router con el teraterm... :D

Al parecer se pueden emplear diversos cables de móviles para ese fin, claro que para cada cable hay que saber el pinout y puede ser que haya cables que no funcionen de ninguna manera, pero por probar ese cable que a lo mejor tenéis en el fondo de un cajón/armario/....no se pierde nada :wink:

A continuación posteo varios pinouts de móviles para el que le pueda interesar: pinoutscopia9hdmodzg3.jpg

Y aquí posteo algunos mas (Enlace cedido por currin)

pinout1mod4yr.jpg

Pinout-2.jpg

Pinout-3.jpg

pinout4copia9kh.jpg

***Estos pinouts hacen referencia al conector que tiene el móvil mirándolo de frente, por lo que el cable habría que mirarlo desde atrás con los pines boca arriba para interpretarlo correctamente***

Solo sería cuestión de desmontar el conector que va a parar a cada móvil e identificar que función está asociada a cada pin y de que color es el pin (cada fabricante suele usar su propio código de colores)...para posteriormente conectar los cables (ya identificados) según el pinout del router que muestro a continuación:

2.jpg

Para conectarlo al router por norma general se usa un cable de esos de audio analógico que se conectan a la parte de atrás del cd/dvd y que va a la tarjeta de sonido (pueden tener 3 o 4 cablecillos)..también se suelen usar cables que llevan las carcasas en su interior y que van a parar a la placa base, por ejemplo los del interruptor del reset, power..el del altavoz...cualquier cosa que se os ocurra que tenga un conector parecido puede serviros perfectamente para ese fin...

A continuación se muestra una lista de los cables que hasta día de hoy podemos decir que son compatibles (vamos que ya han sido probados) en paréntesis pongo el compañero que lo ha testado (por cierto gracias a todos :wink: ) , además, también se indica si son genéricos u originales (si no se comenta alguno es que se desconoce...) y si necesitan el +3,3v del router o solo el RX, TX Y GND para funcionar correctamente:

Siemens C25 y se presupone A/C/S/M/SL 2x, 3x, 4x y 50 (Genéricos y Originales) (No, Solo RX, TX Y GND) Probado por (Servidor, Piolinso) :twisted:

***Hay una minoría de cables para siemens x25-x45 que sí que necesitan recibir alimentación de los +3,3v para funcionar correctamente, por lo que en caso de que el cable parezca no funcionar correctamente deberéis de conectar el +3,3v del router al cable que se corresponda con el pin 4 (battery) en el pinout/esquema*** (Comprobado por merlinxxx y jesus4736)

Siemens S55 y se presupone Siemens A52, A55, A56, A60, C55, C56, C60, C65, CF62, CT56, M55, MC60, MT55, S55, S56, S57, S65, SL5C, SL55, SL56, 2218, SX1

En caso de que se trate del cable Siemens Original: (Si necesita el +3,3v del router conectado al Pin 1 del cable a parte del RX, TX Y GND) Probado por (robermad1986)

En caso de que se trate de un cable genérico: (No, Solo RX, TX Y GND) Probado por (tobelen)

Ericsson T10 y se presupone 6xx y 7xx (Genéricos y Originales) (Si necesita el +3,3V del Router Conectado al Pin 12 de +5v del cable a parte del RX, TX Y GND) Probado por (ALBERJ)

Ericcson T2X y se presupone T3X, T6X, A26XX, RXXX, P800 (Genérico y Originales) (Si necesita el +3,3V del Router Conectado al Pin 11 de +3v del cable a parte del RX, TX Y GND) Probado por (kkakko y epielmagnificus)

Alcatel 50x / 51x y se presupone que B1-B5, DB, 30x, 50x y 70x (No, Solo RX, TX Y GND) Probado por (currin)

Nokia 3310, 3330, 5510 y 3410 (Genérico) (No, Solo RX, TX Y GND) Probado por (lora3000)

También funciona con cables USB!!! (con lo que contradigo lo que he escrito líneas mas abajo, ya que los post inferiores són mas antiguos que este que se actualiza cada vez que se descubre algo nuevo :wink:

Cable USB Siemens C60 (emulando un puerto RS232) (N, Tx, Rx y GND) mobile action modelo ma-8720p y los pines son pin 2 gnd, pin 3 Tx y pin 4 Rx Probado por (mbazan)

****En el caso de que vuestro PC no tenga un puerto serie pero sí alguno USB existe la posibilidad utilizar un cable destinado a un puerto de serie empleando un adaptador de puerto serie a USB con resultados totalmente satisfactorios Probado por (epielmagnificus)****

Esta es la lista de cables que se han probado y no van ni para Atrás: :cry:

Nokia 3310 y se presupone 3330, 5510 y 3410 (Original) (Probado por KbzA)

Nokia 9100 (Original) y Palm Vx (Probado por Belcebu2001)

Cable USB Motorola V600 y se presupone A630, A835,A845,A1000,i205,i305,i530,i830,i860,i710,i730,i733,i736,i836,i930, V120,V265,V262,V260,V276,V300,V400,V500,V505,V551,V525,V545,V547, V550,V620,v60t,V60,V60i,V60p,V60s,V66,V70,V710,V800,V80,V950,V980,V975,V1050) (Genérico) (Probado por jesus4736)

***Hay serias dudas de que parte de los cables para nokia sean compatibles con nuestro Zyxel 660HW, por lo que se recomienda utilizar cualquier tipo de cable que no sea para Nokia!!!!***

Si por lo que sea no disponéis de ningún cable de móvil a mano con el que trastear o vuestro cable no es compatible, existe un esquema bastante sencillo y barato de realizar (solamente tiene 4 resistencias y 2 transistores) y que funciona perfectamente, es el siguiente:

ttltors2320kf.jpg

Eso sí, son necesarios unos pocos conocimientos de electrónica para realizarlo...

Una vez conseguido comunicarse correctamente con el router llega el momento de actualizar su firmware a Oficial, para ello os recomiendo leer los siguientes hilos:

En caso de tener un Zyxel 660HW-61:

Al hilo de actualización del firmware del 660HW-61 foro-viewtopic-t-31454-postdays-0-postorder-asc-start-0.html

Y en caso de tener un Zyxel 660HW-D1:

Al hilo de Cambiar Firmware al Zyxel 660HW-D1 de Telefónica a OFICIAL index.php?name=PNphpBB2&file=viewtopic&t=75680&start=0&postdays=0&postorder=asc&highlight=

En esos lugares encontraréis todo tipo de información necesaria para realizar el proceso de actualización de forma satisfactoria, además de otros muchos aspectos que puedan involucrar a esos routers, como son configuraciones, manuales, test de firmwares...vamos de todo un poco...:wink:

Este hilo está pensado para tratar específicamente todo lo que tenga que ver con los cables de comunicación con el puerto de serie interno que llevan en su interior los zyxel 660hw, ya sean cables de móviles, de circuitos alternativos que nosotros nos podamos fabricar,etz...

Antes de manipular el router recomiendo encarecidamente leer y releer el hilo hasta comprender todos los pasos a seguir y si se tiene alguna duda que tenga que ver con este tema, no tengáis reparos en postearla aquí....

P.D. Si alguien realiza la prueba con algún otro cable distinto a los mencionados hasta ahora en este hilo se le agradecería que lo posteara diciendo de que cable se trata (para que modelo de móvil), si es original o genérico y si necesita alimentación de +3,3v del router para funcionar correctamente, de esta forma podremos ir actualizando este hilo sobre la marcha con vuestros aportes :wink:

Salu2 a tod@s! y que lo disfrutéis :wink:

Piolinso

Hola quiero cambiarle la firmware a mi zyxel 660HW-D1 , segun tu post http://www.adslayuda.com/foro/routers-adsl/zyxel-prestige-650-660-hw/cable-rs232-siemens-c25-c45-actualizar-firmware-660hw-t53480-0.htmlel cable que tu usastes lleva puerto serie al pc y funciona;

he encontrado esto http://buffalo.nas-central.org/wiki/Use_a_cheap_phone_sync_cable_with_the_serial_port#What_do_i_need.3F y el cable a comprar seria este pero es USB http://cgi.ebay.de/PolarLink-USB-Datenkabel-Siemens-C25_W0QQitemZ390037194609QQcmdZViewItemQQimsxZ20090314?IMSfp=TL0903141210003r21554

Tu crees que este funcionara? solo necesitare conectar el TX , Rx y la MASA verdad ?

gracias un saludo!

Enlace al mensaje
Compartir en otros sitios web
  • 4 weeks later...
  • 2 months later...
  • 2 months later...
  • 3 weeks later...

hola a todos

tengo un router de timofonica y lo quiero liberar, para esto estaba mirando por internet, y me decidi por el cable del nokia : Cable Nokia CA42 DKU5 original de nokia es un cable usb que emula al puerto de serie, al conectar el router con el ordenador salta el sonido de nuevo hardware del windows pero no aparece nada en teraterm.

los pines que he connectado son:

-negro :GND

-azul : TX

-blanco :RX

-rojo : +3,3v

Ayuda por favor

Enlace al mensaje
Compartir en otros sitios web
  • 4 months later...

Hola saludos, mi problemas es el siguente:

Despues de entrar en el teraterm y encender el router, este empieza a comunicar pero cuando salen los puntitos para entrar en el modo debug y pide q pulse una tecla no pasa nada, he probado con el teclado normal y con el virtual y nada, al terminar los puntitos sigue con el proceso hasta que pide presionar enter, cosa que dandole a la tecla no pasa tampoco. Si alguien me ayuda.

PD: Me pasa lo mismo con 2 routers iguales.

Enlace al mensaje
Compartir en otros sitios web

Hola saludos, mi problemas es el siguente:

Despues de entrar en el teraterm y encender el router, este empieza a comunicar pero cuando salen los puntitos para entrar en el modo debug y pide q pulse una tecla no pasa nada, he probado con el teclado normal y con el virtual y nada, al terminar los puntitos sigue con el proceso hasta que pide presionar enter, cosa que dandole a la tecla no pasa tampoco. Si alguien me ayuda.

PD: Me pasa lo mismo con 2 routers iguales.

Ampliacion de datos: Cable fabricado por mi segun esquemas y si pongo el cable en el com2 y hago lo mismo me salen simbolos raros y se para el proceso.

He cambiado la velovidad y nada.

Bootbase Version: V1.05 | 10/17/2005 11:08:11

RAM: Size = 16384 Kbytes

DRAM POST: Testing: 16384K

OK

FLASH: AMD 16M *1

ZyNOS Version: V3.40(AHF.0)b16 | 04/16/2009 11:10:22

Press any key to enter debug mode within 3 seconds.

............................................................ (NO FUNCIONA LAS TECLAS)

Copyright © 1994 - 2006 ZyXEL Communications Corp.

initialize ch = 0, ethernet address: xx:xx:xx:xx:xx:xx

initialize ch = 1, ethernet address: xx:xx:xx:xx:xx:xX

Wan Channel init ........ done

................................................................................

.................. done

Press ENTER to continuE...

Tampoco funciona el teclado

Muchas gracias.

Enlace al mensaje
Compartir en otros sitios web
  • 4 weeks later...

Quizás pregunte una tontería, pero no he visto nada al respecto en esta rama, pero el caso es que tengo varios cables de consola de viejos routers en cuyos extremos hay un conector DB-9 y en el otro un RJ-45.

Mi pregunta ahora es... ¿es probable que estos cables sirvan? Desconozco si el propio conector serie lleve integrado un circuito análogo al que se trata en esta rama, pero quizás pudiera valer.

Obviamente se trataría de quitar el RJ-45 y adaptar el extremo para pincharlo a los Tx, Rx y Neg del PCB del router.

Hola,¿puedes sacar la correspondencia de los hilos entre los dos estremos de ese cable de puerto serie que se coloca en la boca 1 del router para entrar con el hiperterminal al router?

yo tengo un xavi que peto cuando desconecte el cable de la roseta telefonica mientras estaba encendido y me seria de ayuda ya que ese cable no lo tengo.

Enlace al mensaje
Compartir en otros sitios web
Invitado
Este tema está cerrado a nuevas respuestas.
×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.