Ir al contenido

Serv-u ftp 6.1 y Comtrend 536+


marcelg
 Share

Publicaciones recomendadas

Hola, antes de tener el comtrend tenia el wag54g v2(no compatible adsl2+ de jazztel, al menos para mi) y el servidor ftp funcionaba bien con ya.com, pero con jazztel no he conseguido hacer funcionar el comtrend, seguro que es el router ya que la conexión no llega al serv-u, he probado varios puertos y con pasv, pero no hay manera de entrar al servidor, tengo IP dinámica y adsl2+.

Tampoco es ni el firewall del pc ni el del xp que los tengo deshabilitados para este menester.

Gracias

Enlace al comentario
Compartir en otros sitios web

Seguramente ese 21 sea la administración FTP del Comtrend; convendría que la cerraras más tarde.

Revisa antivirus y cortafuegos en Windows. Y haz un Inicio > Ejecutar > cmd y escribe:

netstat -na | find "2121"

para asegurarnos de que el servidor FTP está realmente escuchando por ese puerto.

P.D.: La anchura máxima de imagen admitida en el foro es de 635 pixels: tenlo en cuenta la próxima vez.

Y nunca subas nombres de archivos con espacios a un servidor web, porque a la hora de enlazarlos no te funcionará: las URLs nunca pueden contener espacios. Aunque si no tienes más remedio, sustituye cada espacio por un %20 (poniendo router%20ports.jpg sí que sale, como puedes ver).

Enlace al comentario
Compartir en otros sitios web

Como cierro el puerto 21 de la adminsitarcion del router?

netstat -na | find "2121" me pone:

TCP 0.0.0.0:2121 0.0.0.0:0 LISTENING

El Symantec corporate no lleva firewall y el sygate esta deshabilitado, aunque antes me funciona sin problemas con esta configuracion de antivirus y cortafuegos y el wag54g v2 en ya.com.

Gracias Mced

Perdona no recordaba lo de las medidas de las imagenes ni lo de los espacios .

Enlace al comentario
Compartir en otros sitios web

Parece ser que funciona, pero no veo los ficheros:

550 Passive mode not allowed on this server.

Attemping Active mode transfer...

PORT 192,168,31,2,63,91

200 PORT Command successful.

LIST

150 Opening ASCII mode data connection for /bin/ls.

426 Data connection closed, transfer aborted.

Error loading directory

Enlace al comentario
Compartir en otros sitios web

Claro, si lo pruebas desde casa no puedes usar la IP pública. Siempre que quieras verlo desde el mismo servidor, tienes que entrar por 127.0.0.1 o usar http://www.web2ftp.com (para verificar el acceso desde fuera).

Sí, lo de lo listar los ficheros tiene pinta de ser culpa de usar el modo activo. Prueba con el pasivo y ya verás como va bien.

Enlace al comentario
Compartir en otros sitios web

Hola, yo también estaba probando a montar un ftp con serv-u y tampoco podía acceder desde fuera. Ahora, desde la página que comenta mced, ya me deja. El log del servidor me ponia (desde fuera) user **** logged in, pero no era capaz de acceder a los ficheros.

El caso es que yo no lo tengo por el puerto 21, para que esté un poco más oculto lo tengo en uno por encima de los 1024 primeros. Para que sea visible desde fuera, tengo abierto el puerto x en tcp y el x-1 en udp (supongo que para que ftp en modo activo). Así me funciona sin problema, sin tocar nada más en el router ni en serv-u.

No se si el firm de jazztel estará capado, porque mi router es de telefónica. Si no te funciona ya, prueba a ponerlo así.

Enlace al comentario
Compartir en otros sitios web

No, el protocolo FTP no usa paquetes UDP. Así que si te funciona será por otra cosa.

Jeje, me parece que he sido demasiado rápido a la hora de postear. A mi también me extrañaba eso del udp, por eso en principio sólo abrí un puerto en tcp para que funcionara en modo pasivo.

He estado haciendo pruebas con un par de amigos:

--> A uno de ellos se le conecta desde la web pero no desde internet explorer.

--> A el otro no se le conecta ni desde web (se le desconecta antes de bajar nada) ni tampoco desde ie.

Cuando intentan conectar desde ie me dice user **** logged in y después conection close.

A mi se me conecta desde la web sin problema pero no desde ningún cliente ftp (con ip externa, con interna evidentemente si).

Si cambio la configuración y pongo los dos como tcp, no me funciona.

En fin, me estan dando ganas de desembalar mi antiguo xavi 11g y probar por curiosidad, pero de todas formas tendría que configurar el comtrend pq con el xavi pierdo la sincronia cada 2x3.

Gracias de todas formas.

Enlace al comentario
Compartir en otros sitios web

Bueno, tú desde dentro no puedes usar la IP externa, nada más que con web2ftp.

En cuanto a tus amigos, es de esperar que no puedan usar el modo activo por encontrarse detrás de un router o firewall. Por tanto, tendrán ellos que usar el modo pasivo y configurar el Serv-U para aceptar conexiones en modo pasivo. Y para ello, tendrás que abrir dos o tres puertos más. Mira en las opciones del Serv-U, porque cuando lo vi no era difícil de encontrar.

Para configurar el Internet Explorer en modo pasivo (sólo afecta al FTP; la navegación podrán seguir haciéndola normalmente) tienen que ir a Herramientas > Opciones de internet > Avanzadas. Por la mitad del listado tienen la casilla del modo pasivo.

Enlace al comentario
Compartir en otros sitios web

No hay manera, desde el trabajo me dice:

150 Opening ASCII mode data connection for /bin/ls.

426 Data connection closed, transfer aborted.

Attemping PASV mode transfer...

PASV

550 Passive mode not allowed on this server.

Error loading directory...

Pero el caso es que esta en pasv.

No lo entiendo.

Con web2ftp funciona.

Enlace al comentario
Compartir en otros sitios web

Ten cuidado con web2ftp, porque su cliente funciona tanto en pasivo como en activo. Puedes encontrarte con que web2ftp entre en activo, pero luego tus conocidos no puedan en pasivo (que es el modo que van a tener que usar el 99% de ellos)

Todavía no he logrado funcione del todo bien el ftp.

He hecho pruebas desde mi antiguo modem 56kb con mi antiguo isp (no 908), y efectivamente entra perfectamente en modo activo, pero no en pasivo (IE en xp sp2 entra por defecto en pasivo).

Repasando mi configuración:

- Puerto 6666 en serv-u, abiertos en el router para tcp 6665 y 6666 (para modo activo)

- Puertos 6667 a 6670 para modo pasivo en serv-u, también abiertos en el router para tcp/ip

- Pestaña permitir modo pasivo marcada con ip en blanco (pq dinámica)

- Firewall de router activado (por si tiene algo que ver).

Si miro en el log del serv-u me dice 6667 listening ... 6670 listening.

¿Cual puede ser el problema para que no se conecte en modo pasivo?

¿Hace falta cambiar algo más en el router / firewall?

Muchas gracias, por lo menos ya se conecta en modo activo, que no es poco.

Enlace al comentario
Compartir en otros sitios web

- Puerto 6666 en serv-u, abiertos en el router para tcp 6665 y 6666 (para modo activo)

No es que sea muy relevante para el problema, pero ¿para qué abres el 6665?

- Pestaña permitir modo pasivo marcada con ip en blanco (pq dinámica)

Escribe mejor 0.0.0.0 , que significa "permitir a todo el mundo".

Enlace al comentario
Compartir en otros sitios web

Invitado
Este tema está cerrado a nuevas respuestas.
 Share



×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.