Ir al contenido

cisco827


pulgares
 Share

Publicaciones recomendadas

Hola pulgares

Supongo que Terra tendrá una configuración semejante a la de Telefónica, te envío un ejemplo de configuración para Telefónica IP dinámica como ejemplo.

Los comandos pueden variar según la versión de IOS de tu 827 (alguno puede no aceptarlo o puede que necesite alguno mas.

Te la pego, cambia lo que sea necesario de Terra a Telefónica (usuario, passwords, etc) y prueba

Salu2

! Configuracion Cisco 827 IP dinamica Telefonica

!

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

!

!

interface Ethernet0

ip address 192.168.0.1 255.255.255.0

ip nat inside

no ip mroute-cache

hold-queue 100 out

no shutdown

exit

!

!

vpdn enable

no vpdn logging

!

!

vpdn-group pppoe

request-dialin

protocol pppoe

exit

!

!

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

pvc 8/32

pppoe-client dial-pool-number 1

no shutdown

exit

!

!

interface Dialer1

ip address negotiated

ip access-group 101 in

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer remote-name redback

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname adslppp@telefonicanetpa

ppp chap password adslppp

ppp pap sent-username adslppp@telefonicanetpa password adslppp

ppp ipcp dns request

ppp ipcp wins request

hold-queue 224 in

no shutdown

exit

!

!

ip nat inside source list 101 interface Dialer1 overload

!

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

no ip http server

ip classless

!

!

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

!

!

!

line con 0

exec-timeout 0 0

password XXXXXX

login

transport input none

stopbits 1

exit

!

!

line vty 0 4

password XXXXXX

login

exit

!

!

scheduler max-task-time 5000

!

!

exit

Enlace al comentario
Compartir en otros sitios web

Hola pulgares

¿Sabes como se configuran los Cisco? Si es que no, me temo que vas a tener problemas. Cuando arrancas te aparecerá el prompt Router>, una vez ahí tienes que entrar en modo enable, para lo que tienes que teclear en y darle intro, te pedirá la password de enable, se la das y te aparecerá el prompt Router#> una vez en modo enable tendras que entrar en modo configuración de terminal, esto lo haces tecleando conf t, y una vez ahí puedes pegar la configuración.

Una vez pegada te sales del modo configure terminal al modo enable con exit y para salvar la configuración tecleas copy run start

Suerte con el

Salu2

Enlace al comentario
Compartir en otros sitios web

muchas gracias de verdad fontan155 pero ya voy avanzando he consegido pegar todo lo que tu me as dicho cambiando el usuario y la contraseñay me dice lo siguiente:

00:07:19: %DIALER-6-UNBIND: Interface Vi1 unbound from profile Di1

00:07:19: %LINK-3-UPDOWN: Interface Virtual-Access1, changed state to down

00:07:26: %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

00:07:27: %LINEPROTO-5-UPDOWN: Line protocol on Interface Ethernet0, changed sta

te to down

00:07:37: %LINK-3-UPDOWN: Interface ATM0, changed state to down

00:07:38: %LINEPROTO-5-UPDOWN: Line protocol on Interface ATM0, changed state to

down

00:08:28: %PQUICC-1-LOSTCARR: Unit 0, lost carrier. Transceiver problem?

que estoy haciendo mal?

Enlace al comentario
Compartir en otros sitios web

Hola de nuevo,

¿Tienes conectado el router a la ADSL y a la LAN? Si no es así es lógico que ponga las interfaces en Down (que es lo que te pasa), creo que al menos la Ethernet no la debes de tener conectada (lleva un no shutdown en la configuración).

¿Has pegado la configuración tal y como te la mandé?. Ponte en modo enable y haz un sh run y pegalo aquí a ver si veo algo.

Haz tambien un sh flash y pegalo tambien.

Salu2

Enlace al comentario
Compartir en otros sitios web

hola de nuevo

el sh run me da esto:

Router#sh run

Building configuration...

Current configuration : 601 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

!

no aaa new-model

ip subnet-zero

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

interface Eth

no ip address

shutdown

hold-queue 100 out

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

ip classless

no ip http server

!

!

voice-port 1

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

!

line con 0

line vty 0 4

!

scheduler max-task-time 5000

!

end

y el sh flash me da esto:

System flash directory:

File Length Name/status

1 6922224 c820-v6y6-mz.123-2.XC2.bin

2 1792 autoconfig

[6924144 bytes used, 5658768 available, 12582912 total]

12288K bytes of processor board System flash (Read/Write)

muchas gracias por tu paciencia

gracias

Enlace al comentario
Compartir en otros sitios web

hola de nuevo

el sh run me da esto:

Router#sh run

Building configuration...

Current configuration : 601 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

!

no aaa new-model

ip subnet-zero

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

interface Eth

no ip address

shutdown

hold-queue 100 out

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

ip classless

no ip http server

!

!

voice-port 1

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

!

line con 0

line vty 0 4

!

scheduler max-task-time 5000

!

end

y el sh flash me da esto:

System flash directory:

File Length Name/status

1 6922224 c820-v6y6-mz.123-2.XC2.bin

2 1792 autoconfig

[6924144 bytes used, 5658768 available, 12582912 total]

12288K bytes of processor board System flash (Read/Write)

muchas gracias por tu paciencia

gracias

Enlace al comentario
Compartir en otros sitios web

muchas gracias de verdad

mira el sh run meda esto

Router#sh run

Building configuration...

Current configuration : 601 bytes

!

version 12.3

no service pad

service timestamps debug datetime msec

service timestamps log datetime msec

no service password-encryption

!

hostname Router

!

!

no aaa new-model

ip subnet-zero

!

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

interface Ethernet0

no ip address

shutdown

hold-queue 100 out

!

interface ATM0

no ip address

shutdown

no atm ilmi-keepalive

dsl operating-mode auto

!

ip classless

no ip http server

!

!

voice-port 1

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

!

line con 0

line vty 0 4

!

scheduler max-task-time 5000

!

end

y el sh flash me da esto:

Router#sh flash

System flash directory:

File Length Name/status

1 6922224 c820-v6y6-mz.123-2.XC2.bin

2 1792 autoconfig

[6924144 bytes used, 5658768 available, 12582912 total]

12288K bytes of processor board System flash (Read/Write)

muchas gracias de verdad

Enlace al comentario
Compartir en otros sitios web

Hola pulgares

Pues dado que el router está sin configurar es bastante lógico que te diga lo que te dice (es un desagradable :D ).

Te repito los pasos para configurarlo:

Entra en modo Enable (en) (prompt Router#>)

Entra en modo Configure Terminal (conf t + Intro) (prompt Router(config)#)

Pega ahí la configuración que te mandé (cambiando los datos a Terra)

Dale Exit hasta volver al modo Enable (prompt Router#>)

Haz un sh run y te tiene que salir la misma configuración que has pegado

Cuando lo tengas configurado haz un copy run start + Intro para guardar la configuración.

Salu2

Enlace al comentario
Compartir en otros sitios web

hola buenas tardes

ante todo gracias por la paciencia

esta es la configuracion que pongo sigiendo tus pasos:

Configuracion Cisco 827 IP dinamica Telefonica

!

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

!

!

interface Ethernet0

ip address 192.168.2.1 255.255.255.0

ip nat inside

no ip mroute-cache

hold-queue 100 out

no shutdown

exit

!

!

vpdn enable

no vpdn logging

!

!

vpdn-group pppoe

request-dialin

protocol pppoe

exit

!

!

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

pvc 8/32

pppoe-client dial-pool-number 1

no shutdown

exit

!

!

interface Dialer1

ip address negotiated

ip access-group 101 in

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer remote-name redback

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname miusuario@terradsl

ppp chap password mipass

ppp pap sent-username miusuario@terradsl password mipass

ppp ipcp dns request

ppp ipcp wins request

hold-queue 224 in

no shutdown

exit

!

!

ip nat inside source list 101 interface Dialer1 overload

!

!

ip route 0.0.0.0 0.0.0.0 Dialer1

!

!

no ip http server

ip classless

!

!

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

!

!

!

line con 0

exec-timeout 0 0

password XXXXXX

login

transport input none

stopbits 1

exit

!

!

line vty 0 4

password XXXXXX

login

exit

!

!

scheduler max-task-time 5000

!

!

exit

y luego hago el sh run

y me da esto

Router#sh runCreate a dial

Building configuration...

########################

Current configuration : 1444 bytes Provide DMDP service

!r

version 12.3

no service pad

service timestamps debug uptime Provide DNSIX servic

service timestamps log uptime

Use, duplication, or disclos

service password-encryption do

!

hostname Routerands in config

!d

!c

no aaa new-modelh in subparagrap

ip subnet-zero

!

!o

vpdn enabletible-confi

!

vpdn-group pppoeuration compatib

request-dialin

protocol pppoe

!i

!t

!c

!u

!

!

!R

!e

!

no voice hpi capture buffer software

no voice hpi capture destination Modify enable

!s

!o

!

!r

!e

!r

interface Ethernet0

ip address 192.168.2.1 255.255.255.0 Exit fr

ip nat insi

!s

interface ATM0

exit

no ip address Exit from c

no ip mroute-cache 95134-1706

no atm ilmi-keepalive

file

pvc 8/32 Adjus

pppoe-client dial-pool-number 1

IOS

!)

dsl operating-mode autor-map Flow sa

!l

interface Dialer1A

ip address negotiated

gatew

ip access-group 101 inatewayE (fc1)

ip mtu 1492ed to t

gw

ip nat outside Enabl

encapsulation pppunting.

Tech

dialer pool 1http://www.cis

dialer remote-name redback Des

dialer-group 1interactive hel

no cdp enableo Systems, Inc

ppp authentication pap chap callin

Com

hostname

ppp chap hostname miusuario@terradsl

Image text-base: 0x

ppp chap password 7 110D1C0B030004 HTTP Config

ppp pap sent-username miusuario@terradsl

ppp pap sent-username miusuario@terradsl

!

voice-port 1

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

!

line con 0

exec-timeout 0 0

password 7 033C63333E37190C

login

stopbits 1

line vty 0 4

password 7 063E371974763159

login

!

scheduler max-task-time 5000

!

end

alomejor pongo en otro sitio el nombre de usuario no?

Enlace al comentario
Compartir en otros sitios web

creo que esta todo bien a qui te mando un sh run

pero sigo sin poder conectar

osea que no tengo internet

Cisco827#sh runlog uptimea com

Building configuration...

Synched to tech

Current configuration : 2640 bytesice password-encryption

Tech

!c

version 12.3ttp://www.ci

no service padportDef

service timestamps debug uptime

no aaa

Copyright © 1986-20

service timestamps log uptime

Copyright (

service password-encryption-Mar-04 15:49 by ealyon

vp

!-

hostname Cisco827e range m

Ima

!

enable secret 5 $1$eH7a$GY/AoFLyBT7NHTmMCh2pj1oard

protocol p

!

clock timezone Madrid 1processor (revision 0x1

no aaa new-model1024K bytes of m

ip subnet-zerooice hpi captu

no ip domain lookupb parameters

!

!

vpdn enable.

Pro

!s

vpdn-group pppoe9205H2E (3961098

request-dialinre revision 000

protocol pppoe

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer5!

!

!

interfa

Bridging

interface Virtual-Template2K bytes of processor board

no ip address/Write)

!

interface ATM0

ip nat in

no ip addressþs

Press RE

no ip mroute-cache exit

no ip

no atm ilmi-keepalive02:26.243: %LINEPROTO-

pvc 8/32Line prot

pppoe-client dial-pool-number 1

no atm ilmi-keepal

!

pvc 8/35

encapsulation aal5mux ppp dialero up

pppoe-

*Mar 1

dialer pool-member 1PDOWN: Interface Ether

!0,

dsl operating-mode autoing-mode autor-map

!

interface Dialer0

ip address negotiated02:38.595: %LINEPROTO-

ip nat outsiderotocol on Inte

encapsulation ppp

dialer pool 1

dialer remote-name redback

*Mar 1 00:02:40.195

dialer-group 1I: Configured f

no cdp enableonsole

ppp authentication pap chap callin

ppp a

*Mar

ppp chap hostname PULGARES@terradslrface Ethernet0, changed state to ad

ppp chap password 7 1301121C1F1E0B6AES@terradsl

ppp pap sent-username PULGARES@terradsl password 7 070B24425A1B16LINK-5-CHANGED: Interface ATM0, changed state to administ

ppp ipcp dns request

ppp pa

ppp ipcp wins requestS@ter

ratively down

hold-queue 224 in00:02:42.259: %SYS

!-

ip nat inside source list 1 interface

!

line con 0

122

Technical Support: http://www.ci

ip classlessupport

ip route 0.0.0.0 0.0.0.0 Dialer033C63333E371

Copyright © 1986-

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http serverWed 03-Mar-04 15:

!

access-list 1 permit 192.0.0.0 0.255.255.255Re

*Mar 1 00:02:42.263: %SNMP-5-COLDSTART:

access-list 1 deny any is undergoing

access-list 23 permit 192.0.0.0 0.255.255.255

login

!

schedu

a cold startime 500

access-list 101 permit ip any anyPROTO-5-UPDOWN: Line protocol on

voice-port 3

!

voice-port 4

!

!

line con 0

exec-timeout 0 0

password 7 082549401D0B0A

login

stopbits 1

line vty 0 4

access-class 23 in

exec-timeout 120 0

password 7 1301121C1F1E0B

login

length 0

!

scheduler max-task-time 5000

scheduler process-watchdog terminate

sntp server 147.156.1.1

!

end

hay cosas que no entiendo

gracias de toas formas

Enlace al comentario
Compartir en otros sitios web

Hola pulgares

No entiendo nada de la configuración que te da el sh run, no se si es un problema a la hora de copiar y pegar o bien que estás conectado por hiperterminal y que se están mezclando la salida del sh run y los mensajes de consola.

Como imagino que al menos te funcionará a traves de LAN, prueba a conectarte por Telnet (para que no salgan los mensajes de consola) y mira a ver si ahí puedes sacar la configuración.

Salu2

Enlace al comentario
Compartir en otros sitios web

Hola de nuevo,

El 827 no se puede configurar por WEB, solo por telnet (que es igual a configurarlo por Hiperterminal pero sin que te salgan los mensajes de consola) puedes levantarle el servidor http (ip http server) pero no sirve para configurarlo.

Haz un Telnet a la IP del router saca la configuración y pegala (tomalo con calma que si no conoces IOS configurar un Cisco no es tan sencillo como otros routers)

Salu2

Enlace al comentario
Compartir en otros sitios web

te he dado las gracias ?

gracias de todos modos

mira esto es lo que me da es sh run:

pulgares#sh run

Building configuration...

Current configuration : 2774 bytes

!

version 12.3

no service pad

service timestamps debug uptime

service timestamps log uptime

service password-encryption

!

hostname pulgares

!

enable secret 5 $1$JM7I$1h0LUNnpcQjaOd4hO2WUf0

!

clock timezone Madrid 1

no aaa new-model

ip subnet-zero

no ip domain lookup

!

!

vpdn enable

!

vpdn-group pppoe

request-dialin

protocol pppoe

!

!

!

!

!

!

!

!

!

no voice hpi capture buffer

no voice hpi capture destination

!

!

!

!

!

!

interface Ethernet0

ip address 192.168.2.5 255.255.255.0

ip nat inside

no ip mroute-cache

no cdp enable

hold-queue 100 out

!

interface Virtual-Template2

no ip address

!

interface ATM0

no ip address

no ip mroute-cache

no atm ilmi-keepalive

pvc 8/32

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

pvc 8/35

encapsulation aal5mux ppp dialer

dialer pool-member 1

!

dsl operating-mode auto

!

interface Dialer0

ip address negotiated

ip nat outside

encapsulation ppp

dialer pool 1

dialer-group 1

no cdp enable

ppp chap hostname PULGARES@terradsl

ppp chap password 7 134D2307451C056938332C7D31275D30170D005256571A

!

interface Dialer1

ip address negotiated

ip access-group 101 in

ip mtu 1492

ip nat outside

encapsulation ppp

dialer pool 1

dialer remote-name redback

dialer-group 1

no cdp enable

ppp authentication pap chap callin

ppp chap hostname PULGARES@terradsl

ppp chap password 7 03005E0KI21D2E0C

ppp pap sent-username PULGARES@terradsl password 7 050SD301355E4149

ppp ipcp dns request

ppp ipcp wins request

hold-queue 224 in

!

ip nat inside source list 1 interface Dialer0 overload

ip nat inside source list 101 interface Dialer1 overload

ip nat inside source static tcp 192.168.2.9 4662 interface Dialer0 4662

ip nat inside source static udp 192.168.2.9 4672 interface Dialer0 4672

ip classless

ip route 0.0.0.0 0.0.0.0 Dialer0

ip route 0.0.0.0 0.0.0.0 Dialer1

no ip http server

!

access-list 1 permit 192.0.0.0 0.255.255.255

access-list 1 deny any

access-list 23 permit 192.0.0.0 0.255.255.255

access-list 101 permit ip any any

dialer-list 1 protocol ip permit

priority-list 1 protocol ip high tcp www

priority-list 1 protocol ip high udp domain

priority-list 1 protocol ip high tcp ftp

priority-list 1 protocol ip high tcp ftp-data

priority-list 1 protocol ip high tcp pop3

priority-list 1 protocol ip high tcp smtp

priority-list 1 protocol ip low tcp 4662

snmp-server community public RO

snmp-server enable traps tty

no cdp run

!

voice-port 1

!

voice-port 2

!

voice-port 3

!

voice-port 4

!

!

line con 0

exec-timeout 0 0

password 7 0825494ASD0B0A

login

stopbits 1

line vty 0 4

access-class 23 in

exec-timeout 120 0

password 7 06020A2GT85C06

login

length 0

!

scheduler max-task-time 5000

scheduler process-watchdog terminate

sntp server 147.156.1.1

sntp server 192.168.2.5

!

end

pulgares#

Enlace al comentario
Compartir en otros sitios web

Hola otra vez.

¿Te he dicho de nada? Pues de nada :D

Hay cosas que veo en la configuración que no están bien, los Dialer están mal (si solo tienes una interface ADSL deberías de tener solo 1 a no ser que te estén dando dos PVCS que no creo), no están definidas las listas de acceso para el Dialer0 y ademas tienes dos PVCS (el 8/32 y el 8/35), tambien tienes dos rutas por defecto con la misma métrica para cada uno de los Dialers, etc.

Vamos a dejar de momento lo dela confioguración, me interesaría que te conectases por hiperterminal y enciendas el router, una vez que llegues a Router> capturame todo lo que te salga y pegamelo (me interesa ver que dicen los Dialer al intentar conectarse).

¿Sabes como se le borra la configuración a los Cisco? Dimelo y si no sabes te mando un documento donde lo explica.

Seguimos hablando

Salu2

Enlace al comentario
Compartir en otros sitios web

bien espero no resultar pesado

estp es lo que me da al encenderlo:

System Bootstrap, Version 12.2(4r)XM3, RELEASE SOFTWARE (fc1)

TAC Support: http://www.cisco.com/tac

Copyright © 2002 by cisco Systems, Inc.

C800/SOHO series (Board ID: 8-62) platform with 49152 Kbytes of main memory

program load complete, entry point: 0x80013000, size: 0x699ed4

Self decompressing the image : #################################################

############################################################################# [O

K]

Restricted Rights Legend

Use, duplication, or disclosur

subject to restrictions as set forth in subparagraph

© of the Commercial Computer Software - Restricted

Rights clause at FAR sec. 52.227-19 and subparagraph

© (1) (ii) of the Rights in Technical Data and Computer

Software clause at DFARS sec. 252.227-7013.

cisco Systems, Inc.

170 West Tasman Drive

San Jose, California 95134-1706

Cisco Internetwork Operating System Software

IOS C820 Software (C820-V6Y6-M), Version 12.3(2)XC2, EARLY DEPLOYMENT RELEA

SE SOFTWARE (fc1)

Synched to technology version 12.3(1.6)T

Technical Support: http://www.cisco.com/techsupport

Copyright © 1986-2004 by cisco Systems, Inc.

Compiled Wed 03-Mar-04 15:49 by ealyon

Image text-base: 0x800131C0, data-base: 0x80CA3728

CISCO C827-4V (MPC855T) processor (revision 0x1101) with 48128K/1024K bytes of m

emory.

Processor board ID FOC09205H2E (396109830), with hardware revision 0000

CPU rev number 5

Bridging software.

4 POTS Ports

1 Ethernet/IEEE 802.3 interface(s)

1 ATM network interface(s)

128K bytes of non-volatile configuration memory.

12288K bytes of processor board System flash (Read/Write)

2048K bytes of processor board Web flash (Read/Write)

ê

ú

Press RETURN to get started!

User Access Verification

Password:

PULGARES>

y no se borrar la configuracion buscare algo por internet

vamos poco a poco pero bien

Enlace al comentario
Compartir en otros sitios web

Hola Pulgares

¿Que le has borrado?, te pego un procedimiento para arrancar desde Rommon siempre que no te hayas cargado el IOS, prueba con esto y si no te arranca te envío una IOS y te digo como cargarla.

Tranquilo que seguro que tiene solución.

Te pego eso:

Cisco 826, 827, 828, 831, 836, and 837 and SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide

ROM Monitor

Cisco 826, 827, 828, 831, 836, and 837 and SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide

Index

Preface

Concepts

Network Scenarios

Basic Router Configuration

Advanced Router Configuration

Troubleshooting

Cisco IOS Basic Skills

ROM Monitor

Common Port Assignments

Download this chapter

ROM Monitor

Download the complete book

PDF for Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide (PDF - 3 MB)

Table of Contents

ROM Monitor

Entering the ROM Monitor

ROM Monitor Commands

Command Descriptions

Disaster Recovery with TFTP Download

TFTP Download Command Variables

Required Variables

Optional Variables

Using the TFTP Download Command

Configuration Register

Changing the Configuration Register Manually

Changing the Configuration Register Using Prompts

Console Download

Command Description

Error Reporting

Debug Commands

Exiting the ROM Monitor

ROM Monitor

--------------------------------------------------------------------------------

This appendix describes the ROM monitor (also called the bootstrap program). The ROM monitor firmware runs when the router is powered up or reset. The firmware helps to initialize the processor hardware and boot the operating system software. You can use the ROM monitor to perform certain configuration tasks, such as recovering a lost password or downloading software over the console port. If there is no Cisco IOS software image loaded on the router, the ROM monitor runs the router.

This appendix contains the following sections:

Entering the ROM Monitor

ROM Monitor Commands

Command Descriptions

Disaster Recovery with TFTP Download

Configuration Register

Console Download

Debug Commands

Exiting the ROM Monitor

Entering the ROM Monitor

To use the ROM monitor, you must be using a terminal or PC that is connected to the router over the console port. Refer to documentation listed in the Obtaining Documentation section of this guide for information on connecting your router to a PC or terminal.

Perform these steps to configure the router to boot up in ROM monitor mode the next time it is rebooted.

Command Purpose

Step 1 enable

If an enable password is configured, enters the enable command and the enable password to enter privileged EXEC mode.

Step 2 configure terminal

Enters global configuration mode.

Step 3 config-reg 0x0

Resets the configuration register.

Step 4 exit

Exits global configuration mode.

Step 5 reload

Reboots the router with the new configuration register value. The router remains in ROM monitor and does not boot the Cisco IOS software.

As long as the configuration value is 0x0, you must manually boot the operating system from the console. See the boot command in the "Command Descriptions" section in this appendix.

After the router reboots, it is in ROM monitor mode. The number in the prompt increments with each new line.

--------------------------------------------------------------------------------

TimeSaver Break (system interrupt) is always enabled for 60 seconds after the router reboots, regardless of whether it is set to on or off in the configuration register. During this 60-second window, you can break to the ROM monitor prompt by pressing the Break key.

--------------------------------------------------------------------------------

ROM Monitor Commands

Enter ? or help at the ROM monitor prompt to display a list of available commands and options, as follows:

rommon 1 > ?

alias set and display aliases command

boot boot up an external process

break set/show/clear the breakpoint

confreg configuration register utility

cont continue executing a downloaded image

context display the context of a loaded image

cookie display contents of cookie PROM in hex

dev list the device table

dir list files in file system

dis display instruction stream

dnld serial download a program module

frame print out a selected stack frame

help monitor builtin command help

history monitor command history

meminfo main memory information

repeat repeat a monitor command

reset system reset

set display the monitor variables

stack produce a stack trace

sync write monitor environment to NVRAM

sysret print out info from last system return

tftpdnld tftp image download

unalias unset an alias

unset unset a monitor variable

xmodem x/ymodem image download

Commands are case sensitive. You can halt any command by pressing the Break key on a terminal. If you are using a PC, most terminal emulation programs halt a command when you press the Ctrl and the Break keys at the same time. If you are using another type of terminal emulator or terminal emulation software, refer to the documentation for that product for information on how to send a Break command.

Command Descriptions

Table B-1 describes the most commonly used ROM monitor commands.

Table B-1 Most Commonly Used ROM Monitor Commands

Command Description

help or ?

Displays a summary of all available ROM monitor commands.

-?

Displays information about command syntax; for example:

rommon 16 > dis -?

usage : dis [addr] [length]

The output for this command is slightly different for the xmodem download command:

rommon 11 > xmodem -?

xmodem: illegal option -- ?

usage: xmodem [-cyrxu]

-c CRC-16

-y ymodem-batch protocol

-r copy image to dram for launch

-x do not launch on download completion

-u upgrade ROMMON, System will reboot after upgrade

reset or i

Resets and initializes the router, similar to a power up.

dev

Lists boot device identifications on the router; for example:

rommon 10> dev

Devices in device table:

id name

flash: flash

dir device:

Lists the files on the named device; for example, Flash files:

rommon 4 > dir flash:

File size Checksum File name

2835276 bytes (0x2b434c) 0x2073 c806-oy6-mz

boot commands For more information about the ROM monitor boot commands, refer to the Cisco IOS Configuration Guide and the Cisco IOS Command Reference.

b

Boots the first image in Flash memory.

b flash: [filename]

Attempts to boot the image directly from the first partition of Flash memory. If you do not enter a filename, this command will boot this first image in Flash.

Disaster Recovery with TFTP Download

The standard way to load new software on your router is using the copy tftp flash privileged EXEC command from the Cisco IOS software command-line interface (CLI). However, if the router is unable to boot the Cisco IOS software, you can load new software while in ROM monitor mode.

This section describes how to load a Cisco IOS software image from a remote TFTP server to the router Flash memory. Use the tftpdnld command only for disaster recovery because it erases all existing data in Flash memory before downloading a new software image to the router.

TFTP Download Command Variables

This section describes the system variables that can be set in ROM monitor mode and that are used during the TFTP download process. There are both required variables and optional variables.

--------------------------------------------------------------------------------

Note The commands described in this section are case sensitive and must be entered exactly as shown.

--------------------------------------------------------------------------------

Required Variables

These variables must be set with these commands before using the tftpdnld command:

Variable Command

IP address of the router.

IP_ADDRESS= ip_address

Subnet mask of the router.

IP_SUBNET_MASK= ip_address

IP address of the default gateway of the router.

DEFAULT_GATEWAY= ip_address

Variable Command

IP address of the TFTP server from which the software will be downloaded.

TFTP_SERVER= ip_address

The name of the file that will be downloaded to the router.

TFTP_FILE= filename

Optional Variables

These variables can be set with these commands before using the tftpdnld command:

Variable Command

Configures how the router displays file download progress.

0—No progress is displayed.

1—Exclamation points (!!!) are displayed to indicate file download progress. This is the default setting.

2—Detailed progress is displayed during the file download process; for example:

Initializing interface.

Interface link state up.

ARPing for 1.4.0.1

ARP reply for 1.4.0.1 received. MAC address 00:00:0c:07:ac:01

TFTP_VERBOSE= setting

Number of times the router attempts ARP and TFTP download. The default is 7.

TFTP_RETRY_COUNT= retry_times

Amount of time, in seconds, before the download process times out. The default is

2,400 seconds (40 minutes).

TFTP_TIMEOUT= time

Whether or not the router performs a checksum test on the downloaded image:

1—Checksum test is performed.

0—No checksum test is performed.

TFTP_CHECKSUM=setting

Using the TFTP Download Command

The steps described in this section should be performed while in ROM monitor mode.

--------------------------------------------------------------------------------

Step 1 Use the appropriate commands to enter all the required variables and any optional variables described earlier in this section.

Step 2 Enter the tftpdnld command as follows:

rommon 1 > tftpdnld -r

--------------------------------------------------------------------------------

Note The -r variable is optional. Entering this variable downloads and boots the new software but does not save the software to Flash memory. You can then use the image that is in Flash memory the next time you enter the reload command.

--------------------------------------------------------------------------------

You will see output similar to the following:

IP_ADDRESS: 1.3.6.7

IP_SUBNET_MASK: 255.255.0.0

DEFAULT_GATEWAY: 1.3.0.1

TFTP_SERVER: 223.255.254.254

TFTP_FILE: c806-sy-mz

Invoke this command for disaster recovery only.

WARNING: all existing data in all partitions on flash will be lost!

Do you wish to continue? y/n: [n]:

Step 3 If you are sure that you want to continue, enter y in response to the question in the output:

Do you wish to continue? y/n: [n]:y

The router begins to download the new file.

Enter Ctrl-C or Break to stop the transfer before the Flash memory is erased.

--------------------------------------------------------------------------------

Configuration Register

The virtual configuration register is in nonvolatile RAM (NVRAM) and has the same functionality as other Cisco routers. You can view or modify the virtual configuration register from either the ROM monitor or the operating system software. Within ROM monitor, you can change the configuration register by entering the register value in hexadecimal format, or by allowing the ROM monitor to prompt you for the setting of each bit.

Changing the Configuration Register Manually

To change the virtual configuration register from the ROM monitor manually, enter the command confreg followed by the new value of the register in hexadecimal, as shown in the following example:

rommon 1 > confreg 0x2101

You must reset or power cycle for new config to take effect

rommon 2 >

The value is always interpreted as hexadecimal. The new virtual configuration register value is written into NVRAM but does not take effect until you reset or reboot the router.

Changing the Configuration Register Using Prompts

Entering confreg without an argument displays the contents of the virtual configuration register and a prompt to alter the contents by describing the meaning of each bit.

In either case, the new virtual configuration register value is written into NVRAM but does not take effect until you reset or reboot the router.

The following display shows an example of entering the confreg command:

rommon 7> confreg

Configuration Summary

enabled are:

console baud: 9600

boot: the ROM Monitor

do you wish to change the configuration? y/n [n]: y

enable "diagnostic mode"? y/n [n]: y

enable "use net in IP bcast address"? y/n [n]:

enable "load rom after netboot fails"? y/n [n]:

enable "use all zero broadcast"? y/n [n]:

enable "break/abort has effect"? y/n [n]:

enable "ignore system config info"? y/n [n]:

change console baud rate? y/n [n]: y

enter rate: 0 = 9600, 1 = 4800, 2 = 1200, 3 = 2400 [0]: 0

change the boot characteristics? y/n [n]: y

enter to boot:

0 = ROM Monitor

1 = the boot helper image

2-15 = boot system

[0]: 0

Configuration Summary

enabled are:

diagnostic mode

console baud: 9600

boot: the ROM Monitor

do you wish to change the configuration? y/n [n]:

You must reset or power cycle for new config to take effect

Console Download

You can use console download, a ROM monitor function, to download over the router console port either a software image or a configuration file. After download, the file is either saved to the mini-Flash memory module or to main memory for execution (image files only).

Use console download when you do not have access to a Trivial File Transfer Protocol (TFTP) server.

--------------------------------------------------------------------------------

Note If you want to download a software image or a configuration file to the router over the console port, you must use the ROM monitor command.

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

Note If you are using a PC to download a Cisco IOS image over the router console port at 115,200 bps, ensure that the PC serial port is using a 16550 universal asynchronous transmitter/receiver (UART). If the PC serial port is not using a 16550 UART, we recommend using a speed of 38,400 or less when downloading a Cisco IOS image over the console port.

--------------------------------------------------------------------------------

Command Description

The following are the syntax and descriptions for the xmodem console download command:

xmodem [-cyrx] destination_file_name

c

Optional. Performs the download using 16-bit cyclic redundancy check (CRC-16) error checking to validate packets. Default is 8-bit CRC.

y

Optional. Sets the router to perform the download using Ymodem protocol. Default is Xmodem protocol. The protocols differ as follows:

Xmodem supports a 128-block transfer size. Ymodem supports a 1024-block transfer size.

Ymodem uses (CRC)-16 error checking to validate each packet. Depending on the device that the software is being downloaded from, this function might not be supported by Xmodem.

r

Optional. Image is loaded into DRAM for execution. Default is to load the image into Flash memory.

x

Optional. Image is loaded into DRAM without being executed.

destination_file_name

The name of the system image file or the system configuration file. In order for the router to recognize it, the name of the configuration file must be router_confg.

Follow these steps to run Xmodem:

--------------------------------------------------------------------------------

Step 1 Move the image file to the local drive where the Xmodem will execute.

Step 2 Enter the xmodem command.

--------------------------------------------------------------------------------

Error Reporting

Because the ROM monitor console download uses the console to perform the data transfer, error messages are only displayed on the console when the data transfer is terminated.

If an error does occur during a data transfer, the transfer is terminated, and an error message is displayed. If you have changed the baud rate from the default rate, the error message is followed by a message telling you to restore the terminal to the baud rate specified in the configuration register.

Debug Commands

Most ROM monitor debugging commands are functional only when Cisco IOS software has crashed or is halted. If you enter a debugging command and Cisco IOS crash information is not available, you see the following error message:

"xxx: kernel context state is invalid, can not proceed."

The following are ROM monitor debugging commands:

stack or k—produces a stack trace; for example:

rommon 6> stack

Stack trace:

PC = 0x801111b0

Frame 00: FP = 0x80005ea8 PC = 0x801111b0

Frame 01: FP = 0x80005eb4 PC = 0x80113694

Frame 02: FP = 0x80005f74 PC = 0x8010eb44

Frame 03: FP = 0x80005f9c PC = 0x80008118

Frame 04: FP = 0x80005fac PC = 0x80008064

Frame 05: FP = 0x80005fc4 PC = 0xfff03d70

context—displays processor context; for example:

rommon 7> context

CPU context of the most recent exception:

PC = 0x801111b0 MSR = 0x00009032 CR = 0x53000035 LR = 0x80113694

CTR = 0x801065e4 XER = 0xa0006d36 DAR = 0xffffffff DSISR = 0xffffffff

DEC = 0xffffffff TBU = 0xffffffff TBL = 0xffffffff IMMR = 0xffffffff

R0 = 0x00000000 R1 = 0x80005ea8 R2 = 0xffffffff R3 = 0x00000000

R4 = 0x8fab0d76 R5 = 0x80657d00 R6 = 0x80570000 R7 = 0x80570000

R8 = 0x00000000 R9 = 0x80570000 R10 = 0x0000954c R11 = 0x00000000

R12 = 0x00000080 R13 = 0xffffffff R14 = 0xffffffff R15 = 0xffffffff

R16 = 0xffffffff R17 = 0xffffffff R18 = 0xffffffff R19 = 0xffffffff

R20 = 0xffffffff R21 = 0xffffffff R22 = 0xffffffff R23 = 0xffffffff

R24 = 0xffffffff R25 = 0xffffffff R26 = 0xffffffff R27 = 0xffffffff

R28 = 0xffffffff R29 = 0xffffffff R30 = 0xffffffff R31 = 0xffffffff

frame—displays an individual stack frame.

sysret—displays return information from the last booted system image. This information includes the reason for terminating the image, a stack dump of up to eight frames, and, if an exception is involved, the address where the exception occurred; for example:

rommon 8> sysret

System Return Info:

count: 19, reason: user break

pc:0x801111b0, error address: 0x801111b0

Stack Trace:

FP: 0x80005ea8, PC: 0x801111b0

FP: 0x80005eb4, PC: 0x80113694

FP: 0x80005f74, PC: 0x8010eb44

FP: 0x80005f9c, PC: 0x80008118

FP: 0x80005fac, PC: 0x80008064

FP: 0x80005fc4, PC: 0xfff03d70

FP: 0x80005ffc, PC: 0x00000000

FP: 0x00000000, PC: 0x00000000

meminfo—displays size in bytes, starting address, available range of main memory, the starting point and size of packet memory, and size of NVRAM; for example:

rommon 9> meminfo

Main memory size: 40 MB.

Available main memory starts at 0x10000, size 40896KB

IO (packet) memory size: 5 percent of main memory.

NVRAM size: 32KB

Exiting the ROM Monitor

You must set the configuration register to a value from 0x2 to 0xF for the router to boot a Cisco IOS image from Flash memory upon startup or reloading.

The following example shows how to reset the configuration register and cause the router to boot a Cisco IOS image stored in Flash memory:

rommon 1 > confreg 0x2101

You must reset or power cycle for new config to take effect

rommon 2 >boot

The router will boot the Cisco IOS image in Flash memory. The configuration register will change to 0x2101 the next time the router is reset or power cycled.

© 1992-2005 Cisco Systems, Inc. All rights reserved. Terms and Conditions, Privacy Statement, Cookie Policy and Trademarks of Cisco Systems, Inc.

Leetelo y despues vamos viendo donde te quedas.

Salu2

Enlace al comentario
Compartir en otros sitios web

Hola Pulgares

¿Que le has borrado?, te pego un procedimiento para arrancar desde Rommon siempre que no te hayas cargado el IOS, prueba con esto y si no te arranca te envío una IOS y te digo como cargarla.

Tranquilo que seguro que tiene solución.

Te pego eso:

Cisco 826, 827, 828, 831, 836, and 837 and SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide

ROM Monitor

Cisco 826, 827, 828, 831, 836, and 837 and SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide

Index

Preface

Concepts

Network Scenarios

Basic Router Configuration

Advanced Router Configuration

Troubleshooting

Cisco IOS Basic Skills

ROM Monitor

Common Port Assignments

Download this chapter

ROM Monitor

Download the complete book

PDF for Cisco 826, 827, 828, 831, 836, and 837 and Cisco SOHO 76, 77, 78, 91, 96, and 97 Routers Software Configuration Guide (PDF - 3 MB)

Table of Contents

ROM Monitor

Entering the ROM Monitor

ROM Monitor Commands

Command Descriptions

Disaster Recovery with TFTP Download

TFTP Download Command Variables

Required Variables

Optional Variables

Using the TFTP Download Command

Configuration Register

Changing the Configuration Register Manually

Changing the Configuration Register Using Prompts

Console Download

Command Description

Error Reporting

Debug Commands

Exiting the ROM Monitor

ROM Monitor

--------------------------------------------------------------------------------

This appendix describes the ROM monitor (also called the bootstrap program). The ROM monitor firmware runs when the router is powered up or reset. The firmware helps to initialize the processor hardware and boot the operating system software. You can use the ROM monitor to perform certain configuration tasks, such as recovering a lost password or downloading software over the console port. If there is no Cisco IOS software image loaded on the router, the ROM monitor runs the router.

This appendix contains the following sections:

Entering the ROM Monitor

ROM Monitor Commands

Command Descriptions

Disaster Recovery with TFTP Download

Configuration Register

Console Download

Debug Commands

Exiting the ROM Monitor

Entering the ROM Monitor

To use the ROM monitor, you must be using a terminal or PC that is connected to the router over the console port. Refer to documentation listed in the Obtaining Documentation section of this guide for information on connecting your router to a PC or terminal.

Perform these steps to configure the router to boot up in ROM monitor mode the next time it is rebooted.

Command Purpose

Step 1 enable

If an enable password is configured, enters the enable command and the enable password to enter privileged EXEC mode.

Step 2 configure terminal

Enters global configuration mode.

Step 3 config-reg 0x0

Resets the configuration register.

Step 4 exit

Exits global configuration mode.

Step 5 reload

Reboots the router with the new configuration register value. The router remains in ROM monitor and does not boot the Cisco IOS software.

As long as the configuration value is 0x0, you must manually boot the operating system from the console. See the boot command in the "Command Descriptions" section in this appendix.

After the router reboots, it is in ROM monitor mode. The number in the prompt increments with each new line.

--------------------------------------------------------------------------------

TimeSaver Break (system interrupt) is always enabled for 60 seconds after the router reboots, regardless of whether it is set to on or off in the configuration register. During this 60-second window, you can break to the ROM monitor prompt by pressing the Break key.

--------------------------------------------------------------------------------

ROM Monitor Commands

Enter ? or help at the ROM monitor prompt to display a list of available commands and options, as follows:

rommon 1 > ?

alias set and display aliases command

boot boot up an external process

break set/show/clear the breakpoint

confreg configuration register utility

cont continue executing a downloaded image

context display the context of a loaded image

cookie display contents of cookie PROM in hex

dev list the device table

dir list files in file system

dis display instruction stream

dnld serial download a program module

frame print out a selected stack frame

help monitor builtin command help

history monitor command history

meminfo main memory information

repeat repeat a monitor command

reset system reset

set display the monitor variables

stack produce a stack trace

sync write monitor environment to NVRAM

sysret print out info from last system return

tftpdnld tftp image download

unalias unset an alias

unset unset a monitor variable

xmodem x/ymodem image download

Commands are case sensitive. You can halt any command by pressing the Break key on a terminal. If you are using a PC, most terminal emulation programs halt a command when you press the Ctrl and the Break keys at the same time. If you are using another type of terminal emulator or terminal emulation software, refer to the documentation for that product for information on how to send a Break command.

Command Descriptions

Table B-1 describes the most commonly used ROM monitor commands.

Table B-1 Most Commonly Used ROM Monitor Commands

Command Description

help or ?

Displays a summary of all available ROM monitor commands.

-?

Displays information about command syntax; for example:

rommon 16 > dis -?

usage : dis [addr] [length]

The output for this command is slightly different for the xmodem download command:

rommon 11 > xmodem -?

xmodem: illegal option -- ?

usage: xmodem [-cyrxu]

-c CRC-16

-y ymodem-batch protocol

-r copy image to dram for launch

-x do not launch on download completion

-u upgrade ROMMON, System will reboot after upgrade

reset or i

Resets and initializes the router, similar to a power up.

dev

Lists boot device identifications on the router; for example:

rommon 10> dev

Devices in device table:

id name

flash: flash

dir device:

Lists the files on the named device; for example, Flash files:

rommon 4 > dir flash:

File size Checksum File name

2835276 bytes (0x2b434c) 0x2073 c806-oy6-mz

boot commands For more information about the ROM monitor boot commands, refer to the Cisco IOS Configuration Guide and the Cisco IOS Command Reference.

b

Boots the first image in Flash memory.

b flash: [filename]

Attempts to boot the image directly from the first partition of Flash memory. If you do not enter a filename, this command will boot this first image in Flash.

Disaster Recovery with TFTP Download

The standard way to load new software on your router is using the copy tftp flash privileged EXEC command from the Cisco IOS software command-line interface (CLI). However, if the router is unable to boot the Cisco IOS software, you can load new software while in ROM monitor mode.

This section describes how to load a Cisco IOS software image from a remote TFTP server to the router Flash memory. Use the tftpdnld command only for disaster recovery because it erases all existing data in Flash memory before downloading a new software image to the router.

TFTP Download Command Variables

This section describes the system variables that can be set in ROM monitor mode and that are used during the TFTP download process. There are both required variables and optional variables.

--------------------------------------------------------------------------------

Note The commands described in this section are case sensitive and must be entered exactly as shown.

--------------------------------------------------------------------------------

Required Variables

These variables must be set with these commands before using the tftpdnld command:

Variable Command

IP address of the router.

IP_ADDRESS= ip_address

Subnet mask of the router.

IP_SUBNET_MASK= ip_address

IP address of the default gateway of the router.

DEFAULT_GATEWAY= ip_address

Variable Command

IP address of the TFTP server from which the software will be downloaded.

TFTP_SERVER= ip_address

The name of the file that will be downloaded to the router.

TFTP_FILE= filename

Optional Variables

These variables can be set with these commands before using the tftpdnld command:

Variable Command

Configures how the router displays file download progress.

0—No progress is displayed.

1—Exclamation points (!!!) are displayed to indicate file download progress. This is the default setting.

2—Detailed progress is displayed during the file download process; for example:

Initializing interface.

Interface link state up.

ARPing for 1.4.0.1

ARP reply for 1.4.0.1 received. MAC address 00:00:0c:07:ac:01

TFTP_VERBOSE= setting

Number of times the router attempts ARP and TFTP download. The default is 7.

TFTP_RETRY_COUNT= retry_times

Amount of time, in seconds, before the download process times out. The default is

2,400 seconds (40 minutes).

TFTP_TIMEOUT= time

Whether or not the router performs a checksum test on the downloaded image:

1—Checksum test is performed.

0—No checksum test is performed.

TFTP_CHECKSUM=setting

Using the TFTP Download Command

The steps described in this section should be performed while in ROM monitor mode.

--------------------------------------------------------------------------------

Step 1 Use the appropriate commands to enter all the required variables and any optional variables described earlier in this section.

Step 2 Enter the tftpdnld command as follows:

rommon 1 > tftpdnld -r

--------------------------------------------------------------------------------

Note The -r variable is optional. Entering this variable downloads and boots the new software but does not save the software to Flash memory. You can then use the image that is in Flash memory the next time you enter the reload command.

--------------------------------------------------------------------------------

You will see output similar to the following:

IP_ADDRESS: 1.3.6.7

IP_SUBNET_MASK: 255.255.0.0

DEFAULT_GATEWAY: 1.3.0.1

TFTP_SERVER: 223.255.254.254

TFTP_FILE: c806-sy-mz

Invoke this command for disaster recovery only.

WARNING: all existing data in all partitions on flash will be lost!

Do you wish to continue? y/n: [n]:

Step 3 If you are sure that you want to continue, enter y in response to the question in the output:

Do you wish to continue? y/n: [n]:y

The router begins to download the new file.

Enter Ctrl-C or Break to stop the transfer before the Flash memory is erased.

--------------------------------------------------------------------------------

Configuration Register

The virtual configuration register is in nonvolatile RAM (NVRAM) and has the same functionality as other Cisco routers. You can view or modify the virtual configuration register from either the ROM monitor or the operating system software. Within ROM monitor, you can change the configuration register by entering the register value in hexadecimal format, or by allowing the ROM monitor to prompt you for the setting of each bit.

Changing the Configuration Register Manually

To change the virtual configuration register from the ROM monitor manually, enter the command confreg followed by the new value of the register in hexadecimal, as shown in the following example:

rommon 1 > confreg 0x2101

You must reset or power cycle for new config to take effect

rommon 2 >

The value is always interpreted as hexadecimal. The new virtual configuration register value is written into NVRAM but does not take effect until you reset or reboot the router.

Changing the Configuration Register Using Prompts

Entering confreg without an argument displays the contents of the virtual configuration register and a prompt to alter the contents by describing the meaning of each bit.

In either case, the new virtual configuration register value is written into NVRAM but does not take effect until you reset or reboot the router.

The following display shows an example of entering the confreg command:

rommon 7> confreg

Configuration Summary

enabled are:

console baud: 9600

boot: the ROM Monitor

do you wish to change the configuration? y/n [n]: y

enable "diagnostic mode"? y/n [n]: y

enable "use net in IP bcast address"? y/n [n]:

enable "load rom after netboot fails"? y/n [n]:

enable "use all zero broadcast"? y/n [n]:

enable "break/abort has effect"? y/n [n]:

enable "ignore system config info"? y/n [n]:

change console baud rate? y/n [n]: y

enter rate: 0 = 9600, 1 = 4800, 2 = 1200, 3 = 2400 [0]: 0

change the boot characteristics? y/n [n]: y

enter to boot:

0 = ROM Monitor

1 = the boot helper image

2-15 = boot system

[0]: 0

Configuration Summary

enabled are:

diagnostic mode

console baud: 9600

boot: the ROM Monitor

do you wish to change the configuration? y/n [n]:

You must reset or power cycle for new config to take effect

Console Download

You can use console download, a ROM monitor function, to download over the router console port either a software image or a configuration file. After download, the file is either saved to the mini-Flash memory module or to main memory for execution (image files only).

Use console download when you do not have access to a Trivial File Transfer Protocol (TFTP) server.

--------------------------------------------------------------------------------

Note If you want to download a software image or a configuration file to the router over the console port, you must use the ROM monitor command.

--------------------------------------------------------------------------------

--------------------------------------------------------------------------------

Note If you are using a PC to download a Cisco IOS image over the router console port at 115,200 bps, ensure that the PC serial port is using a 16550 universal asynchronous transmitter/receiver (UART). If the PC serial port is not using a 16550 UART, we recommend using a speed of 38,400 or less when downloading a Cisco IOS image over the console port.

--------------------------------------------------------------------------------

Command Description

The following are the syntax and descriptions for the xmodem console download command:

xmodem [-cyrx] destination_file_name

c

Optional. Performs the download using 16-bit cyclic redundancy check (CRC-16) error checking to validate packets. Default is 8-bit CRC.

y

Optional. Sets the router to perform the download using Ymodem protocol. Default is Xmodem protocol. The protocols differ as follows:

Xmodem supports a 128-block transfer size. Ymodem supports a 1024-block transfer size.

Ymodem uses (CRC)-16 error checking to validate each packet. Depending on the device that the software is being downloaded from, this function might not be supported by Xmodem.

r

Optional. Image is loaded into DRAM for execution. Default is to load the image into Flash memory.

x

Optional. Image is loaded into DRAM without being executed.

destination_file_name

The name of the system image file or the system configuration file. In order for the router to recognize it, the name of the configuration file must be router_confg.

Follow these steps to run Xmodem:

--------------------------------------------------------------------------------

Step 1 Move the image file to the local drive where the Xmodem will execute.

Step 2 Enter the xmodem command.

--------------------------------------------------------------------------------

Error Reporting

Because the ROM monitor console download uses the console to perform the data transfer, error messages are only displayed on the console when the data transfer is terminated.

If an error does occur during a data transfer, the transfer is terminated, and an error message is displayed. If you have changed the baud rate from the default rate, the error message is followed by a message telling you to restore the terminal to the baud rate specified in the configuration register.

Debug Commands

Most ROM monitor debugging commands are functional only when Cisco IOS software has crashed or is halted. If you enter a debugging command and Cisco IOS crash information is not available, you see the following error message:

"xxx: kernel context state is invalid, can not proceed."

The following are ROM monitor debugging commands:

stack or k—produces a stack trace; for example:

rommon 6> stack

Stack trace:

PC = 0x801111b0

Frame 00: FP = 0x80005ea8 PC = 0x801111b0

Frame 01: FP = 0x80005eb4 PC = 0x80113694

Frame 02: FP = 0x80005f74 PC = 0x8010eb44

Frame 03: FP = 0x80005f9c PC = 0x80008118

Frame 04: FP = 0x80005fac PC = 0x80008064

Frame 05: FP = 0x80005fc4 PC = 0xfff03d70

context—displays processor context; for example:

rommon 7> context

CPU context of the most recent exception:

PC = 0x801111b0 MSR = 0x00009032 CR = 0x53000035 LR = 0x80113694

CTR = 0x801065e4 XER = 0xa0006d36 DAR = 0xffffffff DSISR = 0xffffffff

DEC = 0xffffffff TBU = 0xffffffff TBL = 0xffffffff IMMR = 0xffffffff

R0 = 0x00000000 R1 = 0x80005ea8 R2 = 0xffffffff R3 = 0x00000000

R4 = 0x8fab0d76 R5 = 0x80657d00 R6 = 0x80570000 R7 = 0x80570000

R8 = 0x00000000 R9 = 0x80570000 R10 = 0x0000954c R11 = 0x00000000

R12 = 0x00000080 R13 = 0xffffffff R14 = 0xffffffff R15 = 0xffffffff

R16 = 0xffffffff R17 = 0xffffffff R18 = 0xffffffff R19 = 0xffffffff

R20 = 0xffffffff R21 = 0xffffffff R22 = 0xffffffff R23 = 0xffffffff

R24 = 0xffffffff R25 = 0xffffffff R26 = 0xffffffff R27 = 0xffffffff

R28 = 0xffffffff R29 = 0xffffffff R30 = 0xffffffff R31 = 0xffffffff

frame—displays an individual stack frame.

sysret—displays return information from the last booted system image. This information includes the reason for terminating the image, a stack dump of up to eight frames, and, if an exception is involved, the address where the exception occurred; for example:

rommon 8> sysret

System Return Info:

count: 19, reason: user break

pc:0x801111b0, error address: 0x801111b0

Stack Trace:

FP: 0x80005ea8, PC: 0x801111b0

FP: 0x80005eb4, PC: 0x80113694

FP: 0x80005f74, PC: 0x8010eb44

FP: 0x80005f9c, PC: 0x80008118

FP: 0x80005fac, PC: 0x80008064

FP: 0x80005fc4, PC: 0xfff03d70

FP: 0x80005ffc, PC: 0x00000000

FP: 0x00000000, PC: 0x00000000

meminfo—displays size in bytes, starting address, available range of main memory, the starting point and size of packet memory, and size of NVRAM; for example:

rommon 9> meminfo

Main memory size: 40 MB.

Available main memory starts at 0x10000, size 40896KB

IO (packet) memory size: 5 percent of main memory.

NVRAM size: 32KB

Exiting the ROM Monitor

You must set the configuration register to a value from 0x2 to 0xF for the router to boot a Cisco IOS image from Flash memory upon startup or reloading.

The following example shows how to reset the configuration register and cause the router to boot a Cisco IOS image stored in Flash memory:

rommon 1 > confreg 0x2101

You must reset or power cycle for new config to take effect

rommon 2 >boot

The router will boot the Cisco IOS image in Flash memory. The configuration register will change to 0x2101 the next time the router is reset or power cycled.

© 1992-2005 Cisco Systems, Inc. All rights reserved. Terms and Conditions, Privacy Statement, Cookie Policy and Trademarks of Cisco Systems, Inc.

Leetelo y despues vamos viendo donde te quedas.

Salu2

Enlace al comentario
Compartir en otros sitios web

Invitado
Este tema está cerrado a nuevas respuestas.
 Share



×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.