Ir al contenido

Cambiar Firmware al Zyxel 660HW-D1 de Telefónica a OFICIAL


Publicaciones recomendadas

  • Respuestas 241
  • Created
  • Last Reply

Top Posters In This Topic

Buenas a todo el personal. Para Piolinso:

1º Agradecerte una vez más todo tu trabajo y esfuerzo, que sin tu ayuda, más de uno como yo estaría.....

2º A ver si pudieras "re-editar" otra vez el paso de Original a Telefónica e incluir lo de: SYS BAUD 5 , que si no ´más de uno estarán 30 minutos para poder actualizarlo. ¿No crees?.

Gracias de nuevo!!

Enlace al mensaje
Compartir en otros sitios web

x el_zari

jejeje de nada...me alegra saber que la info que posteo es de utilidad e interes para la gente :D

Respecto a lo del sys baud 5 tienes toda la razón, al postearlo en el otro hilo de comandos por telnet no tuve en cuenta el deber de incluirlo en el manual de este hilo, pero ya esta editado y añadida la info...

Un salu2 y gracias a tí por el apunte :wink:

Hola Piolinso.

Estoy usando con exito desde hace tiempo un cable para Nokia 3310 que se vende bajo la marca "Contact". No utiliza los 3.3V del router. Solo tres cables (GND, TxD, RxD).

Saludos

x Alray,

Pues Sip, el cable génerico (da igual la marca mientras que no sea original) para ese modelo de nokia hace ya un tiempo que se comprobó que era compatible con nuestro router...esto es lo que se indica en el hilo de cables compatibles http://www.adslayuda.com/foro-viewtopic-t-53480.html :

A continuación se muestra una lista de los cables que hasta día de hoy podemos decir que son compatibles.......continua........

Nokia 3310, 3330, 5510 y 3410 (Genérico) (No, Solo RX, TX Y GND) Probado por (lora3000)

De todas formas muchas gracias por la información... :wink:

P.D. Da gusto ver como hay gente que se involucra y aporta información/conocimientos/pruebas/vamos lo que sea que puedan proporcionar para ayudar a los demás..de verdad que muchas gracias a tod@s! :wink:

Salu2 a tod@s!

Enlace al mensaje
Compartir en otros sitios web

Buenas a todo el personal. Para Piolinso:

1º Agradecerte una vez más todo tu trabajo y esfuerzo, que sin tu ayuda, más de uno como yo estaría.....

2º A ver si pudieras "re-editar" otra vez el paso de Original a Telefónica e incluir lo de: SYS BAUD 5 , que si no ´más de uno estarán 30 minutos para poder actualizarlo. ¿No crees?.

Gracias de nuevo!!

Si el_zari, pero yo creo que es mas cómodo que el SYS BAUD 5, se use el comando ATBA5 directamente en el Tera, despues de calcular el password y cambiar este en Setup---->Serial Port--->115200, creo que es mas "comodillo", al menos así lo creo yo, ya que se hace todo del tirón y no hay que reconectar, es como lo hice yo y nada, todo OK.

:wink:

Enlace al mensaje
Compartir en otros sitios web

x currin

Ahí tengo que decir que discrepo :P , ya que pienso que es mas recomendable configurar previamente por telnet y comandos este aspecto al ser la única forma de que desde el principio conectemos con el teraterm a la máxima velocidad posible (115200bps)...el motivo, pues el que expuse en el principio del manual que viene a ser los problemas que dan algunos cables de comunicación de móvil (siemens sobre todo) a la hora de trabajar a la velocidad por defecto 9.600bps y que a veces no nos dejan ni siquiera calcular el pass ni subir la velocidad del teraterm con el otro comando que mencionas, por eso si lo configuramos previamente no daremos lugar a que nos suceda por lo menos ese problemilla que comento...

Un salu2 :wink:

Enlace al mensaje
Compartir en otros sitios web

En ese sentido, si es recomendable, para poder sortear esa limitación de algunos cables. Yo tengo dos cables, uno de Siemens y otro de Alcatel, no originales, pero ambos funcionan igual, eso si, son del mismo fabricante y los dos usan solo TX, RX GRND (autoalimentado por el puerto serie).

La verdad es que, para mi, un cable con esa limitación, no me daría mucha confianza, para llevar a cabo la operación, lo cual no quiere decir que no sea válido, solo que yo no metería mano y me buscaría otro que si me diera confianza 100%, es solo una cosa personal, dada la delicadeza de la operación. mal comparando, es como si un cirujano, se pone a operar con un bisturí oxidado ó sin desinfectar. Repito, para mi personalmente, no me parece adecuado, lo que no quiere decir que no valga.

:wink:

Enlace al mensaje
Compartir en otros sitios web

x currin

Pues en mi caso la mayoría de los cables que han pasado por mis manos hasta hoy han sido siemens (en total unos 7) tanto originales como genéricos y autoalimentados/no autoalimentados (además de algún circuitillo que me he hecho...)...y el ligero inconveniente es ese, que a 9600bps la mayoría muestran carácteres erróneos lo que pasa es que tengo que decir que con ninguno de ellos jamás he tenido ningún problema una vez subida la velocidad a 115200bps....por eso digo lo de aumentarla previamente...una vez subida la comentada velocidad los cables son fiables como los demás ni mas ni menos y como hay que subirla para no estar media hora subiendo el firm mejor hacerlo desde un principio y así de paso si tienes un cable de estos lo aprovechas que para eso es la idea del hilo de cables compatibles...

Esa comparación que has comentado no es ecuanime :P y te digo porque...porque esos bisturís que tú dices que están "oxidados" (cables siemens) habría que esterilizarlos mas meticulosamente (subirles la velocidad) para obtener el mismo resultado (a nivel de fiabilidad) que con otros bisturíes (distintos cables no siemens) pero que al final todos pasarían los controles sanitarios correspondientes si se hace todo como se debe (subiríamos la bootbase y el firmware sin problemas)

Un salu2 :wink:

Enlace al mensaje
Compartir en otros sitios web

Si,ya he dicho que mal comparando, asi como que a mi no me va el sistema y no me fio, aunque es sencillo, es delicado, lo cual no quiere decir que no funcione, pero mas vale prevenir que tener un pisapapeles, en vez de un router, bastante adrenalina se consume normalmente, temiendo el posible fallo, como para arriesgarse a sabiendas de que el cable tiene problemas con ciertas velocidades, menudo "subidón". Yo no digo que no valgan, que valen, si, pero para mi no. Con mis cables ya llevo 8 routers actualizados (2 HW-61 y 6 HW-D1), para familia y amiguetes y "pá mi" y como la seda.

Cambiando de tercio, me comentó el otro día un tecnico de timo, que van a retirar también este modelo, por que supuéstamente le sale caro y van a dar un modelo de Xavis (no se cual) y Comtrend 5361, para mi que es casualidad que al poco de descubrir el truco de la actualización, los retiren, como el HW-61, xD. Seguramente no tenga que ver, pero es una casualidad muy casual, xD.

Saludos :wink: .

Enlace al mensaje
Compartir en otros sitios web

Si,ya he dicho que mal comparando, asi como que a mi no me va el sistema y no me fio, aunque es sencillo, es delicado, lo cual no quiere decir que no funcione, pero mas vale prevenir que tener un pisapapeles, en vez de un router, bastante adrenalina se consume normalmente, temiendo el posible fallo, como para arriesgarse a sabiendas de que el cable tiene problemas con ciertas velocidades, menudo "subidón". Yo no digo que no valgan, que valen, si, pero para mi no. Con mis cables ya llevo 8 routers actualizados (2 HW-61 y 6 HW-D1), para familia y amiguetes y "pá mi" y como la seda.

El miedo en los huesos lo vas a tener siempre cuando estés actualizando cualquier firmware de cualquier aparato, eso es algo inevitable...y da igual que sea sencillo (mediante alguna utilidad y sin tener que abrir ningún aparato) que algo mas complicado (desmontando el cacharro y trasteando en su interior...)te paras a pensar y te empiezan a rondar cosillas como.....y si se va la luz en mitad del proceso :shock:....y si del sudor que me cae cortocircuito el router :shock::shock:...y si se cuelga el windows :evil: (para variar xD) y si, y si..y si....pero bueno con el tiempo vas perdiendo eso miedo y te dan ganas de seguir y seguir investigando y contra mas ganas menos miedo :twisted: ....yo quisiera insistir en que los cables siemens al subirlos de velocidad son igual de fiables que el resto y no quiero decir la cantidad de routers que he descapado con esos tipos de cable pero entre una cosa (actualizarlos yo mismo), otra (ceder cables a amigos) y otra mas (todos los compañeros de foro que ha actualizado sus routers con este tipo de cable) superan con creces esa cifra....

Cambiando de tercio, me comentó el otro día un tecnico de timo, que van a retirar también este modelo, por que supuéstamente le sale caro y van a dar un modelo de Xavis (no se cual) y Comtrend 5361, para mi que es casualidad que al poco de descubrir el truco de la actualización, los retiren, como el HW-61, xD. Seguramente no tenga que ver, pero es una casualidad muy casual, xD.

Yo no me fiaría un pelo de comentarios así y mucho menos si tenemos en cuenta que este modelo de router es el que están instalando actualmente (y desde hace un tiempo) con las instalaciones de imagenio (igual que pasó con el 61) por lo que yo me inclinaría a pensar que todavía le quedan bastantes meses mas de guerra por dar (si derrepente cambiaran de filososofía y bajarán el listón de calidad a mi entender sería un error y un paso atrás aunque en este sentido han cometido ya tantos que no sé..no sé... :cry: )...los xavis y comtrends desde un principio son la primera opción a la hora de "colocárselos" a los usuarios que no dispongan de imagenio por ser de peor calidad...y sinó solo tenemos que comprobar en el 1004 lo que hay que insistir para que te den un zyxel en vez de uno de esos...(aunque eso no quita que el comtrend de mucho juego en algunos aspectos....)

Un salu2 :wink:

Enlace al mensaje
Compartir en otros sitios web

Lo que está mas que claro piolinso, es que de no ser por aventureros como Parmenides, Telcontar, Ar03, civilis, ceporro y ahora tu , piolinso, sin olvidar todos los que han prestado su ayuda y colaboración, estariamos en la miseria del capado maniático y casi obsesivo de telefónica (no se si así le salen mas baratos ó algo...), el caso es como dice el anucio ese de la fabada"...abuela, esto esta de muerte...", ahora mismo no cambiaria mi 660HW-D1 por ningún comtrend, ni otros presuntos de categoría análoga. Va realmente bién.

Desde aquí, gracias a todos :):wink: .

"...Que contento toyyyyy..."

Saludotes.

Enlace al mensaje
Compartir en otros sitios web

Jejejeje ahí te doy toda la razón del mundo , nunca me cansaré de agradecer una y otra vez todo el trabajo, información, ayuda, soporte, pensamientos/ideas e incluso aliento que han aportado y aportan algún que otro compañero de foro..lo cierto es que sin ellos nunca hubiése llegado hasta aquí :idea::) ...aunque yo sí que cambiaría el zyxel por algún linksys que me deje meterle el tomato o el dd-wrt xD :P así que si en algún momento me cae uno en las manos me temo que el zyxel solamente realizaría las funciones de módem haciendo de bridge (que para eso el zyxel es bueno bueno) dejando las funciones de router/wi-fi al linksys...no sé porque pero se me está empezando a caer un poco la babilla..xD

Bajo mi punto de vista, la respuesta a que les sale mas barato a telefónica tener su firmware propio capado que el que tengan el firmware oficial incorporado es un SÍ rotundo...cuanto no sé..pero se ve que lo suficiente para que los routers vengan capados de serie en este sentido...

y ya que estamos hablando de caro y barato...respecto a ese comentario del técnico a que el zyxel les resulta mas caro lo cierto es que no se que decir porque no tengo cifras ni sé a que se refiere...pero me pregunto....caro si lo comparamos con los comtrends o xavis? (lo mas probable es que sea así pero cuanto..uno céntimos mas? xD) caro porque quieren forrarse un poco mas "supuestamente" bajando la calidad de los routers para imagenio? (La respuesta puede ser "supuestamente" también un sí y mas si nos imaginemos como piensan)...yo lo que veo caro de verdad es la mierd# de adsl que estoy pagando a día de hoy a telefónica:

1Mb - 39,90 Euros +IVA y sin posibilidad de tener 3Mb (el motivo sigue sin justificarse de forma clara y es poco menos que de locos lo que uno llega a oir como explicaciones)....eso sí que es CARO por no decir otra cosa :shock: y que es lo que puedo hacer? me voy a otro proveedor de servicios en el que pago mas o menos lo mismo por la misma mierd# y encima en bastantes casos revendido? (luego está el tema del servicio de atención al cliente...etc..etc...) :? y encima sin solución que vea yo posible a corto/medio plazo...aunque según parece no solo me pasa a mí..cuanta gente habrá todavía con 1mb pagándolo a precio de oro? (aunque tampoco los 3mb son para tirar cohetes a día de hoy) :cry: o gente a los que ni siquiera les llegue el adsl? (pa morirse :cry::evil: ).....buah...me voy a callar porque esto no tendría fin y encima parece que estoy desviando el hilo un poco demasiado del tema principal :oops: ....además que noto como se me están empezando a tensionar las venas del cuello leches xDD

Un Salu2 y de nada :wink:

Enlace al mensaje
Compartir en otros sitios web

Pués si, así estamos, yo desde luego soy feliz con mis 20 megas de Jazztel y de momento sin problemas, ni microcortes, ni nada. Problemas tienen todos con el sat y cac, cierto es que timo es la que menos, pero para eso se paga, estaría bueno, mi sincro actual es esta:

sincro%20D1.jpg

Me llené de megas y ahora mismo, si no fuera por el mega de subida, preferiria los 6, ya que los servers de internet, son una cataplasma y nunca van a tope, parece que están configurados, como mucho a 4 megas, salvo excepciones como rediris. La navegación es igual, todo carga igual y por ejemplo adslayuda, con 1 mega cargaba fatal y se eternizaba a veces y con 20 lo mismo, lo cual es problema del servidor que aloja el sitio, no la línea, en fin, esperemos tiempos mejores. Eso si, pago 10 eurillos menos y supuestmente tengo entre 17 y 20 veces mas y el emule no te fastidia el ancho de banda, que es un incordio, por lo demás na de na.

Esto es como la primera vez, se pasa uno pensando como será y poniendolo por las nubes y a la hora de la verdad, na :D:D:D:):cry:

Bueno que yo también me voy por las ramas xD

Saludos y calma :wink: .

Enlace al mensaje
Compartir en otros sitios web

x currin

Huy..huy...yo mas que ponerlo por las nubes...lo temo :( xD y es que de jazztel he leído tantas cosas de sus "HASTA 20 MB a ver si te enteras xD" Cosas buenas (como lo que comentas en tu caso particular)....y cosas malas como que si tengo un huevo de microcortes..que si no sincronizo ni a la mitad...que si me han dejado sin internet varios días o semanas y me siguen cobrando...que si me han dejado sin teléfono x días...que si tienen problemas con la migración..que si no me han dado todavía de baja y me siguen cobrando...que si atención al cliente es lamentable.....ejemplos...pues solo tienes que buscar un poco:

http://www.pixelydixel.com/2006/02/jazz ... eitor.html

http://www.bandaancha.st/analisis.php?anaid=1511

http://www.sahw.com/wp/archivos/2006/04 ... no-ni-adsl

Y muchos mas enlaces que podría poner :evil: ...de verdad que espero que nunca te pase nada de lo que se mencionan en esas webs y disfrutes de esos valores de sincronización que son poco menos que espectaculares :shock: (supongo que estarás cerquísima del dslam)...esto lo digo porque como empieces a tener algún problema de los que se hablan mas arriba, como no cambien las cosas me temo que vas a tener que agarrarte los machos por no decirte que seguro que tendría que calmarte yo a tí... :P

Yo puestos a elegir (en mis circunstancias personales, es decir en una zona que no creo que tenga cobertura adsl2+ en muucho tiempo :evil: ) creo que me llegaría a conformar con 4-6Mb de bajada y con 1Mb de subida no 320Kbps (mi línea tira por lo menos de sobra con 4mb...como lo sé pues al margen de los valores de ruido y atenuación que ya son indicativos lo sé porque hace un tiempo que solicité el try & buy de 4mb y sin problemas que estuve un mes...)...el precio que llegaría a pagar para no estar echando sapos y culebras y así no creer que me están "supuestamente" robando, pues supongo que sería bastante mas bajo de lo que estoy pagando ahora mismo por 1mb...ahh y todo esto complementado por un servicio de atención al cliente eficiente y eficaz....que pasa? soñar es gratis.... :P

P.D. En el caso de jazztel esto es lo que me cobran por 1 dichoso mb a día de hoy:

(*) Necesaria la marcación automática para disponer de ésta tarifa. Sin marcación automática la tarifa es de 37,95 €/mes. (eso es competencia mas que decente al mb que tengo con telefónica ehh?....hay que joderse...)

Yo mas que irme por las ramas creo que me he quedado colgado del árbol :lol:

Un salu2 y tranquilo que ya estoy mas calmado... :wink:

Enlace al mensaje
Compartir en otros sitios web

Huy..huy...yo mas que ponerlo por las nubes...lo temo Sad xD

:lol::lol::lol:

de jazztel he leído tantas cosas de sus "HASTA 20 MB a ver si te enteras xD" Cosas buenas (como lo que comentas en tu caso particular)....y cosas malas como que si tengo un huevo de microcortes..que si no sincronizo ni a la mitad...que si me han dejado sin internet varios días o semanas y me siguen cobrando...que si me han dejado sin teléfono x días...que si tienen problemas con la migración..que si no me han dado todavía de baja y me siguen cobrando...que si atención al cliente es lamentable.....ejemplos...pues solo tienes que buscar un poco:

http://www.pixelydixel.com/2006/02/jazz ... eitor.html

http://www.bandaancha.st/analisis.php?anaid=1511

http://www.sahw.com/wp/archivos/2006/04 ... no-ni-adsl

Muy cierto, pero también es cierto, que postean y escriben blogs solo los que tienen problemas, los que no, ni se molestan, solo rezan para que no les toque el marrón, valga yo de ejemplo.

Y muchos mas enlaces que podría poner Evil or Very Mad ...de verdad que espero que nunca te pase nada de lo que se mencionan en esas webs y disfrutes de esos valores de sincronización

Gracias, eso pido yo a diario en mis plegarias.

son poco menos que espectaculares Shocked (supongo que estarás cerquísima del dslam)...esto lo digo porque como empieces a tener algún problema de los que se hablan mas arriba, como no cambien las cosas me temo que vas a tener que agarrarte los machos por no decirte que seguro que tendría que calmarte yo a tí... Razz

Pes si, estoy bastante cerca, unos 300 m. y 400 y poco de bucle, pero dada la cercanía y mis valores de atenuación y ruido, debería tener los 20 completos, supongo que serán los empalmes chapuceros de la calle.

Ya tuve problemas de los comentados al principio y me llegaron a decir, "...hemos comprobado que el problema es de su aparato telefónico, que no marca bien los números, sobre todo el 3...", por no hablar de que me cruzaron la línea y me pusieron el número de otro, al final pedí portabilidad a timo y me di de baja, pero luego volví, no me resignaba a que fuesen tan incompetentes y hasta ahora, que llevo ya 9 meses, supongo que van aprendiendo de sus errores.

También tube Wanadoo 20 megas en la otra línea y eso si que era una peli de terror, de las que te hacen saltar del asiento, :evil: .

Si soñar es gratis, pero el ADSL no y el de timo menos y ahora que se llevan a perú o por ahí el sat mas, penita los teleoperadores de atento, xD, Cuanto mas tienen mas quieren, si por lo menos, rebundara en alguna mejora tecnica, como por ejemplo los pares de cobre, que están de pena..., pero no, todo "pá la saca".

:wink:

Enlace al mensaje
Compartir en otros sitios web

A la espera de que me llegue el cable, y para no cagarla, a ver si me podeis aclarar estos pasos:

Ahora procederemos a encender el router y entraremos en modo debug, para ello hay que pulsar una tecla mientras el router está en espera (nos aparecerán unos puntitos)

Que hay que tocar una tecla del teclado?

Ahora con el editor hex preferido tenéis que abrir el dump de vuestra bootbase y bajar hasta el final del archivo, con lo cual nos mostrará algo parecido a esto:

featurebitsparaeld1oficyw9.jpg

Llegados a este punto lo que tenemos que hacer es modificar los feature bits que se encuentran en la dirección off-set 3FD8 y 3FD9 por los que pertenecen al firmware oficial del zyxel 660HW-D1, de manera que los other feature bits quedarían tal y como se muestra en el recuadro rojo de la imágen superior

Es decir, los caracteres que salgan en el recuadro rojo hay que sustituirlos por 9A23, es asi?

Y esto es todo.

Salu2

Enlace al mensaje
Compartir en otros sitios web

A la espera de que me llegue el cable, y para no cagarla, a ver si me podeis aclarar estos pasos:

Que hay que tocar una tecla del teclado?

Exacto, es necesario teclear una tecla cualquiera cuando arranca el router ya que sinó el bootloader pasa de modo debug a arrancar de forma normal el firmware...

Ahora con el editor hex preferido tenéis que abrir el dump de vuestra bootbase y bajar hasta el final del archivo, con lo cual nos mostrará algo parecido a esto:

featurebitsparaeld1oficyw9.jpg

Llegados a este punto lo que tenemos que hacer es modificar los feature bits que se encuentran en la dirección off-set 3FD8 y 3FD9 por los que pertenecen al firmware oficial del zyxel 660HW-D1, de manera que los other feature bits quedarían tal y como se muestra en el recuadro rojo de la imágen superior

Es decir, los caracteres que salgan en el recuadro rojo hay que sustituirlos por 9A23, es asi?

Efectivamente, solamente hay que cambiar los datos que estén ese ese recuadro rojo por los que se indican ese esa imagen...una vez cambiados guardas el archivo y lo subes al router....

Tranquilo que si sigues todos los pasos del manual 1 por 1 la cosa saldrá bien....salvo catástrofe en forma de corte de corriente, etc :P

Un salu2 :wink:

Enlace al mensaje
Compartir en otros sitios web

Bueno pues ya he conseguido cargar el firm. Muchas gracias por el tutorial.

Lo unico tengo una duda. Al cambiar el firm, el router por defecto me sincroniza en modo ADSL2+.

Tengo entendido que para ADSL el mejor modo de sincronizacion es el t1.413. Pues bien, pongo ese modo por telnet y el router no sincroniza, solo sincroniza en adsl2+.

Tengo el DUO Adsl 3MB. Me habran configurado en la central ese unico modo para poder sincronizar?

Salu2

Enlace al mensaje
Compartir en otros sitios web

Ok el_zari, yo tengo dos líneas y tuve el Duo ADSL 3 megas y siempre sicronizó en T1413 con el router en multimode, a lo mejor ahora es ADSL2+ ó en algunas zonas lo es, lo único que comentaba lo de ponerlo en multimode,es por salir de dudas, pero bueno, yo nunca conseguí forzarlo a sincronixar en un modo concreto, no solo a este, si no a ningún modelo de ZyXEL, por eso digo lo del multimode, aunque creo que da igual, sincroniza en el modo que le llega y punto, al contrario que los Comtrend que si se pueden forzar marcando y desmarcando las casillas correspondientes.

Saludos.

Enlace al mensaje
Compartir en otros sitios web

Gracias por tu aclaración Currin. Por cierto, una cosa que te quería preguntar (que seguro que lo sabes) :) Desde hace unos días mi router Zyxel HW 660 D1 cuando lleva unas horas parado (3 o 4 o 2...depende) se me desconecta y tengo que apagarlo y encenderlo, porque no puedo ni navegar, ni hacerle telnet, ni por el navegador....Tengo el último firmware (original). ¿Sabes a qué puede ser debido?. Intentaré bajarle a la versión antrerior a ver que pasa, pero es rarísimo.

Saludos a todos...

Enlace al mensaje
Compartir en otros sitios web
Invitado
Este tema está cerrado a nuevas respuestas.
×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.