Ir al contenido
Conéctate para seguir esto  
1+

Desinstalar las X

Publicaciones recomendadas

Hola que tal?

El caso es que me pase a ubuntu 6.06. Y la verdad es que muy bien. Con unos pocos retoques, es un XP mas "fiable y estable". Lo pongo entre comillas, porque es cierto que aunque cualquier proceso es realmente matable, hace cosas un poco raras, por ejemplo, y es lo que me trae otra vez a este foro, que cuando arranco linux, las X tardan 10 min en arrancar, pero si arranco en modo de seguridad, y arranco desde ahi las X va normal.

Lo que queria hacer era desinstalar las X y ponerlas otra vez, pero si se os ocurre otra cosa... El caso es tampoco se como se hace para desinstalarlas.

Un saludo. Gracias anticipadas por las respuestas.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Las X son un servidor asi que podrías desinstalar todos os paquetes xserver, o bien sin desinstalarlos hacer que arranque en la consola y luego iniciarlo a mano, para ello fijate que en /etc/rc2.d hay un link a gdm, kdm, o xdm, en Ubuntu suele ser gdm, borralo y al arrancar linux directamente, no se inicia las X y te deja en el login de texto ( consola).

Veamos.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola que tal?

Bueno, hice lo que me comentabas de borrar el S13gdm. Arranque, pero cuando arranco las X en modo consola, me vuelve a tardar mucho. Lo que voy a hacer es copiar todo el arranque del modo seguro para el /rc2.d/, una solucion un poco bruta pero a ver si funciona...

De todas maneras me podriasis indicar como puedo desintalar unas X e instalar otras??. Gracias

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola que tal?

Pues es que toy mirando, arranco en modo seguro pero si pongo runlevel, me dice que desconocido... Ya solo se me ocurre desinstalar y volver a instalar a ver que ha pasado.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Todo servidor usa un archivo de configuración, que en este caso esta en /etc/X11/xorg.conf, por otra parte las X debes iniciarlas desde la consola con startx.

La demora debo suponer que se trata de un problema de configuración al no encontrar algo indicado en el archivo. Una opción sería renombrar este archivo xorg.conf y volver a generarlo con dpkg-reconfigure, creo que es el comando, que genera la configuración de cero nuevamente. Para renombrar usas el comando mv, mv --help, cualquier cosa.

Desinstalar y reinistalar el servidor no te sirve de mucho ya que el archivo de configuración suele quedarte igual. el link de /etc/rc2.d es un enlace a /et/init.d/gdm asi que puedes volver a crearlo como S13gdm.

Veamos.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola que tal?

Aun no he podido probar nada de lo queria ya estuve muy ocupado...(ya tengo las entradas para Heroes Del Silencio!!!!!)... pero a lo que me refiero de desinstalar las X es a otodos los archivos, ya no solo el de configuracion. Quiero borrarlo todo e instalar todo de nuevo, puede ser?

Gracias

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Puedes desinstalar lo que desees, es decir en el caso de las X, es un servidor y todas sus partes, es decir el servidor, drivers de video, mouse, etc. que suelen estar preparadas a parte.

En el caso de Ubuntu si desinstalas el servidor se debe desinstalar todo lo demás.

Las configuraciones suelen quedar asi que puedes renombrar o borrar el archivo /etc/X11/xorg.conf que es el que controla este tema.

Otra cosa que podrías ver es en /var/log/Xorg.0.log si aparece algo como que hay algo que no encuentra y no puede inicializar, a veces puede quedarse esperando hasta que lo encuentra.

O en /var/log/gdm.log, si existe donde te muestra los mensajes del gdm, el login gráfico. Que también podría ser.

Veamos.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

HOla que tal??

pues nada, todo sigue igual. El "pkg-reconfigure xserver-xorg" parece que lo dejo todo como estaba, y he mirado en el archivo /var/log/Xorg.0.log y al final si qeu aparece que no ecuentra un dispositivo, pero tengo entendido que no es sobre este tema.

VOy a intentar quitar las X probando con apt-get remove gdm y luegovolvier a cargarlas. a ver que pasa.

Un saludo a todos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola que tal?

Pues nada, no pasa nada. asi que voy a tirar por otro camino. Tengo un ubuntu instalando en la misma maquina y ese me va muy bien. ¿Puedo hacer de ese ubuntu instalado un cd de instalacion?.... He brujuleado un poco pero no vi nada, sabeis si se puede?

Gracias

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola que tal?

Encontre el problema: Iptables. Tenia una archivo tal que S20iptables en /etc/rc2.d/. Ahí tenia puesto mi firewall, que en si funcionaba muy bien, pero fue quitarlo de ahi, y todo volvio a la normalidad, no se me ocurre porque, pero ahora arranca normal.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Repasa a ver qué reglas de filtrado tienes puestas, si hay alguna que tenga que resolver nombres o algo que pueda retrasar el proceso de arranque. De todos modos, prueba también cambiar el orden de arranque: renombra el enlace al script de iptables a S99iptables para que se cargue lo último a ver si ya va mejor.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hoola que tal?

Pues lo del ponerle S99iptables, lo prove y nada, se queda parado. Lo de la revision de las reglas, no veo porque una regla de un firewall, que solo se leen cuando se sale internet, afecta al inicio de una secion de las X. De todas formas las he revisado y no veo nada especial, os dejo las reglas para ver si veis algo:

#!/bin/bash

iptables -F

iptables -X

iptables -Z

iptables -t nat -F

iptables -t mangle -F

#iptables -t filter -A INPUT -j ACCEPT

#Si estas construyendo tus reglas para iptables desde cero,

#necesitas también permitir llegar trafico ESTABLISHED y RELATED a

#traves de tu cortafuegos:

iptables -A INPUT -m state --state ESTABLISHED,RELATED -j ACCEPT

#filtro la salida para la web

iptables -t filter -A OUTPUT -p tcp --dport 80 -j ACCEPT

iptables -t filter -A OUTPUT -p udp --dport 53 -j ACCEPT

iptables -t filter -A OUTPUT -p tcp --dport 443 -j ACCEPT

#a ver si esto abre el gaim

iptables -t filter -A OUTPUT -p tcp --dport 1863 -j ACCEPT

#esto abre el emule

iptables -A INPUT -p tcp --dport 50000 -j ACCEPT

iptables -A INPUT -p udp --dport 50003 -j ACCEPT

iptables -A INPUT -p udp --dport 55000 -j ACCEPT

#esto se supone que habre el emule

iptables -A OUTPUT -p tcp --dport 50000 -j ACCEPT

iptables -A OUTPUT -p udp --dport 50003 -j ACCEPT

iptables -A OUTPUT -p udp --dport 55000 -j ACCEPT

#esto cuando hay router... creo

EMULEPORT=50000

EMULEUDP=55000

EMULEUDP2=`expr $EMULEPORT + 3`

EMULEHOST=192.168.0.2

iptables -t nat -A PREROUTING -i eth0 -p tcp --destination-port $EMULEPORT -j DNAT --to-destination $EMULEHOST:$EMULEPORT

iptables -t nat -A PREROUTING -i eth0 -p udp --destination-port $EMULEUDP -j DNAT --to-destination $EMULEHOST:$EMULEUDP

iptables -t nat -A PREROUTING -i eth0 -p udp --destination-port $EMULEUDP2 -j DNAT --to-destination $EMULEHOST:$EMULEUDP2

iptables -A FORWARD -i etho -o eth0 -d $EMULEHOST -m state --state ESTABLISHED,RELATED -j ACCEPT

iptables -A FORWARD -i eth0 -o eth0 -p tcp --dport $EMULEPORT -d $EMULEHOST -j ACCEPT

iptables -A FORWARD -i eth0 -o eth0 -p udp --dport $EMULEUDP -d $EMULEHOST -j ACCEPT

iptables -A FORWARD -i eth0 -o eth0 -p udp --dport $EMULEUDP2 -d $EMULEHOST -j ACCEPT

## esto dropa todo el resto

iptables -t filter -A INPUT -j DROP

#descomento esta a ver que pasa

iptables -t filter -A OUTPUT -j DROP

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Pues no sabria decirte por qué sucede; es bastante raro :P Las reglas que hay no tienen que resolver nombres ni nada, así que no se qué es lo que puede estar bloqueando. Puedes probar también con un script mas básico a ver si puedes aislar alguna regla en concreto... Poco se me ocurre.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola que tal?

mmmm, un escalofrío recorre mi cuerpo...., ubuntu se empieza a parecer a Windows... (y mas con la historia de que va haber drivers no nativos en la siguiente version)

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

iptables -t filter -A OUTPUT -j DROP <-- está cortando la salida de cualquier paquete de datos no especificado.

Debes comentarla.

básicamente quita esa y pon estas->

iptables --policy OUTPUT ACCEPT

iptables --append OUTPUT -j ACCEPT

O si quieres dejarla debes especificar primero que todas tus direcciones locales conocidas que deben tener acceso para iniciar conexiones.

La filosofía que un "usuario normal" ha de seguir es que de su máquina puede salir cualquier cosa o sea que OUTPUT -j ACCEPT siempre y la politica de OUTPUT abierta siempre.. y lo que entra, si que debes restringirlo abriendo solo lo que necesitas.

Si quieres que tráfico concreto no salga de tu máquina sería necesario que bloquearas lo concreto primero y luego dejaras abierto el resto.

Como digo, en INPUT por seguridad se suele hacer lo contrario.

En otros entornos más complejos de empresas, trabajo, producción la cosa puede cambiar.. claro.

Aqui tienes el mío, es un script de init.d. Tienes que tener los modulos necesarios cargados o no funcionará. Este lo uso en el curro. Meter tus entradas no te será dificil, creo que está bien organizado.

Como podrás apreciar la salida se ACEPTA siempre ya que yo no me quiero bloquear a mí mismo nada:

PATH=/usr/local/sbin:/usr/local/bin:/sbin:/bin:/usr/sbin:/usr/bin

# Where your iptables binary is found

IPT="/sbin/iptables"

LOAD="/sbin/modprobe"

test -f $IPT || exit 0

test -f $LOAD || exit 0

set -e

. /lib/lsb/init-functions

case "$1" in

start)

log_begin_msg "Loading Firewall."

printf "\n"

echo "FW Step1: Stablishing policies. Start of FW."

$IPT --policy INPUT DROP

$IPT --policy OUTPUT DROP

$IPT --policy FORWARD DROP

echo "FW Step2: Erasing Traces of Chains and Zeroing Counters."

$IPT -F

$IPT -Z

$IPT -X

echo "FW Step3: Loading Some Modules."

$LOAD ipt_LOG

#$LOAD iptable_nat

$LOAD nf_conntrack

$LOAD xt_limit

$LOAD xt_conntrack

$LOAD xt_state

echo "FW Step2: Defining New Chains."

$IPT --new entrada

$IPT --new logging

$IPT --new salida

$IPT --new limites

echo "FW Step5: Developing Chains. Logging Chain."

$IPT --append logging -j LOG --log-level info --log-prefix "iptables: "

$IPT --append logging -j ACCEPT

echo "FW Step5.1: Developing Chains. Limits Chain."

$IPT --append limites -j LOG --log-level warn --log-prefix "Paquete Sobre limite: "

$IPT --append limites -j DROP

echo "FW Step5.2: Developing Chains. Main Input Chain."

$IPT --append entrada --match state --state ESTABLISHED,RELATED -j ACCEPT

$IPT --append entrada --match state --state INVALID -j DROP

echo "FW Step5.2a: Developing Chains. Refining Input Chain."

# We allow our lookback interface. MOVED TO INPUT DUE TO NOT WORKING.

#$IPT --append entrada -i lo -p udp -s 127.0.0.1 -d 127.0.0.1 -j ACCEPT

#$IPT --append entrada -i lo -p tcp -s 127.0.0.1 -d 127.0.0.1 -j ACCEPT

# SYN Flood. Limit 1 connection per second.

$IPT --append entrada --proto tcp --syn --match limit --limit 1/s -j ACCEPT

# Port Scanner. Limit one packet per second.

$IPT --append entrada --proto tcp --tcp-flags SYN,ACK,FIN,RST RST --match limit \

--limit 1/s -j ACCEPT

# Ping Flood. Limit one echo request per second.

$IPT --append entrada --proto icmp --icmp-type echo-request --match limit \

--limit 1/s -j ACCEPT

# Windows? Samba? No Thanks, we prefer NFS. Comment if you use Samba.

$IPT --append entrada --match multiport --proto udp --dports 137,138,139 -j DROP

# Anything that does not meet our default limits goes to limites chain.

$IPT --append entrada --match limit -j limites

echo "FW Step5.3a: Developing Chains. Refining Input Chain. Enabling Services."

# These are examples of how to enable services in your laptop

# If you want to enable any, edit accordingly or uncomment.

# As you can see one is accepted and the other example shows

# who you should do if you want to log a service before accepting

#

$IPT --append entrada --proto tcp --destination-port 22 -j ACCEPT

#$IPT --append entrada --proto tcp --destination-port 80 -j logging

# ... etc.

echo "FW Step6: Dropping Other Inputs not defined."

$IPT --append entrada -j DROP

echo "FW Step7: Stablishing Output Rules."

$IPT --append salida -j ACCEPT

echo "FW Step8: Appending chains to Policies. End of FW."

# We allow our lookback interface

$IPT --append INPUT --in-interface lo -j ACCEPT

$IPT --append INPUT --in-interface eth+ -j entrada

$IPT --append INPUT --in-interface ath+ -j entrada

$IPT --append OUTPUT -j salida

;;

stop)

log_begin_msg "Firewall Stoped!!"

$IPT --policy INPUT ACCEPT

$IPT --policy OUTPUT ACCEPT

$IPT --policy FORWARD ACCEPT

$IPT -F

$IPT -Z

$IPT -X

log_end_msg $?

;;

status)

log_begin_msg "Iptables State"

printf " \r "

$IPT -L

log_end_msg $?

;;

*)

N=/etc/init.d/${0##*/}

echo "Usage $N {start|stop|status}" >&2

exit 1

;;

esac

exit 0

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Seguramente lo que comenta ezra.r pueda ser la causa del problema. No porque esté mal filtrar el tráfico en OUTPUT (cada uno con sus necesidades :P), sinó porque estás bloqueando el tráfico en todas las interfaces de red, incluida la interfaz de loopback (que es la que se usa para el tráfico en la propia máquina).

Las conexiones al servidor X se hacen por el puerto 6000 y en el caso de conexiones locales, a través del interfaz de loopback. Añade estas líneas como las primeras líneas de filtrado en tu script para permitir el tráfico en loopback a ver si funciona:

iptables -A INPUT -i lo -j ACCEPT

iptables -A OUTPUT -o lo -j ACCEPT

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola que tal?

Pues le habeis dado en el clavo, era eso. Al final opte por añadir las lineas que Nacx recomendaba : iptables -A INPUT -i lo -j ACCEPT

iptables -A OUTPUT -o lo -j ACCEPT

al principio de mi escript y ya esta, arranco normal, pero bloqueando todo lo que no pido que salga....

Gracias a todos, y retiro lo dicho sobre el parecido en XP y ubuntu...

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola que tal?

Pues le habeis dado en el clavo, era eso. Al final opte por añadir las lineas que Nacx recomendaba : iptables -A INPUT -i lo -j ACCEPT

iptables -A OUTPUT -o lo -j ACCEPT

al principio de mi escript y ya esta, arranco normal, pero bloqueando todo lo que no pido que salga....

Gracias a todos, y retiro lo dicho sobre el parecido en XP y ubuntu...

jajaja, si, porque se parece como la velocidad al tocino. Otra cosa es que no se conozca bien lo que hay por debajo en un unix/linux.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado
Este tema está cerrado a nuevas respuestas.
Conéctate para seguir esto  

×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.