Ir al contenido
Conéctate para seguir esto  
juaniniargentona

ayuda proxy squid

Publicaciones recomendadas

Hola a todos,

en la empresa donde estoy trabajando tengo un servidor proxy linux (debian) con squid montado. llevaba más de 2 meses funcionando correctamente, pero antes de ayer, empezo a fallar la conexión a internet, más concretamente las conexiones (http), ya que lo demás messenger, skype, etc funcionaba a la perfección.

Entonces decidi por borrar el contenido de algunos logs en /var/log/squid, ya que tenian mucha informacion de paginas, también paré squid y lo volví a poner (start/restart) y redireccioné las entradas del puerto 80 hacia el 3128 (squid), de la siguiente forma:

iptables -t nat -A PREROUTING -i eth0 -p tcp --dport 80 -j REDIRECT --to-port 3128

Pero continua igual, es decir como si el redireccionamiento no funcionase, squid si que se ejecuta ya que lo he visto.

Alguien le ha ocurrido lo mismo? sabe alguien alguna manera de arreglarlo?

He probado de reiniciarlo, cambiar puertos, y nada.

Muchas gracias y espero su ayuda.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Si lo único que has borrado son los logs del squid suena a problema de puertos ya que si te funciona messenger, skype y demás se sobreentiendo que problema de conexión no es.

Dices que has redireccionado el puerto 80 al 3128, cuando cuando pides una página web, tu navegador realiza una conexión al puerto 80 del servidor web, y si este número de puerto no se supiera de antemano o estuviera bloqueado no podrías recibir la página. Yo volvería al puerto anterior o al 8080. Si antes te funcionaba por qué cambiaste el puerto? Una vez cambiado, has modificado el puerto en las opciones del proxy de tu navegador?

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

hola, gracias por responder,

pero no he cambiado el puerto, siempre he trabajado con el mismo, el 3128 que es que viene por defecto en squid.

Un día por la mañana a primera hora de golpe y parrazo dejo navegar por la paginas y ahora lo tengo desactivado lo que es squid.

gracias

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Cuando arrancas el squid, lo hace bien o no puede?? a mi me pasó hace poco que también petó uno de los squid y era porque el disco duro estaba hasta las trancas porque se guardaban los logs y no se borraban. Lo único que hice fue borrarlos y ahora estoy más atento. Si quieres puedes pegar el contenido de squid.conf para pegarle un vistazo.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola,

Pues cuando arranco squid, parece que lo hace bien, no me da ningun mensaje de error.

A mi me paso algo parecido una vez, pero lo resolvi borrando los logs, como has dicho, pero esta vez he hecho lo mismo, pero sigue sin funcionar....

a continuación te dejo el squid.conf:

# NETWORK OPTIONS

# -----------------------------------------------------------------------------

http_port 3128

icp_port 3130

cache_mem 8 MB

cache_swap_low 90

cache_swap_high 95

maximum_object_size 4096 KB

cache_dir ufs /var/spool/squid 100 16 256

cache_access_log /var/log/squid/access.log

cache_log /var/log/squid/cache.log

cache_store_log /var/log/squid/store.log

emulate_httpd_log on

client_netmask 255.255.255.0

dns_nameservers 192.168.1.21 213.172.33.34 212.0.97.81 194.224.52.4 80.58.0.33 80.58.32.97 213.172.33.35 212.7.33.3 212.7.33.4

hosts_file /etc/hosts

acl all src 0.0.0.0/0.0.0.0

acl manager proto cache_object

acl localhost src 127.0.0.1/255.255.255.255i

redirect_program /usr/local/bin/SquidClamAV_Redirector.py -c /etc/squid/SquidClamAV_Redirector.conf

redirect_children 5

redirector_access deny localhost

http_reply_access allow all

acl lared src 192.168.1.0/255.255.255.0

http_access allow manager localhost

http_access deny manager

http_access allow purge localhost

http_access deny !Safe_ports

http_access deny CONNECT !SSL_ports

# INSERT YOUR OWN RULE(S) HERE TO ALLOW ACCESS FROM YOUR CLIENTS

http_access allow localhost

http_access allow lared

http_access deny all

http_reply_access allow all

icp_access allow all

# HTTPD-ACCELERATOR OPTIONS

# -----------------------------------------------------------------------------

httpd_accel_port 80

httpd_accel_host virtual

httpd_accel_with_proxy on

httpd_accel_uses_host_header on

Por cierto el unico log que no he borrado ha sido el cache.log, pero los demás si...

-rw-r----- 1 proxy proxy 0 2007-04-12 10:18 access.log.1

-rw-r----- 1 proxy proxy 20 2007-04-13 06:25 access.log.2.gz

-rw-r----- 1 proxy proxy 278003 2007-04-12 13:44 cache.log.1

-rw-r----- 1 proxy proxy 5660 2007-04-13 06:25 cache.log.2.gz

-rw-r--r-- 1 root root 0 2007-04-17 06:25 SquidClamAV_redirector.log

-rw-r----- 1 root adm 165 2007-03-25 06:35 SquidClamAV_redirector.log.0

-rw-r--r-- 1 root root 0 2007-04-16 06:25 SquidClamAV_redirector.log.1

-rw-r--r-- 1 root root 28148 2007-03-25 06:22 SquidClamAV_redirector.log.2

-rw-r--r-- 1 root root 20 2007-04-17 06:25 SquidClamAV_redirector.log.2.gz

-rw-r----- 1 proxy proxy 0 2007-04-12 10:18 store.log.1

-rw-r----- 1 proxy proxy 20 2007-04-13 06:25 store.log.2.gz

muchas gracias

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

No veo nada anormal en tu log quitando tu cache_mem 8 MB que la veo un poco escasa para tu maximum_object_size 4096 KB pero tampoco sé qué máquina tienes y eso sólo te afectaría al rendimiento de tu proxy pero nunca te dejaría el squid frito.

Yo probaría a quedar la ruta /var/log/squid libre de archivos (puedes mover todos tus logs a otra carpeta en otra ruta) para el servicio squid y reiniciarlo. Por si acaso pégale un vistazo a top, du y df por si vieras algo raro.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado
Este tema está cerrado a nuevas respuestas.
Conéctate para seguir esto  

×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.