Ir al contenido
Conéctate para seguir esto  
MANOLOMP

Touchpad

Publicaciones recomendadas

Hola, sigo con mi historia con el touchpad. Con ubuntu dapper fue muy facil solucionarlo, pero despues de algun que otro problemilla con la actualizacion hice una instalacion nueva, el caso es que en el /etc/X11/Xorg.conf no esta la seccion correspondiente al touchpad, que era:

Section "InputDevice"

Identifier "Synaptics Touchpad"

Driver "synaptics"

Option "SendCoreEvents" "true"

Option "Device" "/dev/psaux"

Option "Protocol" "auto-dev"

Option "HorizScrollDelta" "0"

EndSection

El touchpad funciona pero instalo KSynaptics para intentar desactivarlo al escribir al ejecutarlo me da un error:

Shared memory is not accessible Please add the option "SHMConfig "on" into the touchpad section of /etcX11/xorg.conf" Logicamente al no existir la seccion del touchpad no puedo añadir dicha opcion, tengo instalado el paquete xserver-xorg-input.synaptics y el touchpad funciona bien. Que pasaria si añadiera la seccion del touchpad con la opcion antes descrita, podria ejecutar ksynaptics y desactivarlo? o quizas deberia hacer algo mas.

Por cierto en algun foro he leido que en vez de on habria que poner true

Saludos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Quisiera desactivarlo definitivamente, o al menos al teclear (siempre uso raton usb).

Con ubuntu 5.10 fue facil, tan solo cambie "mice" por "mouse0", en el xorg.conf, pero desde dapper no me ha funcionado, de modo que pense en ksynaptics, pero me da ese error, ademas de que la seccion del touchpad no esta, por eso pense en ponerla yo, pero no me queria arriesgar.

Ahora lo he cambiado por "mouse1" y de momento el touchpad no funciona y el raton si

Estuve mirando en google y enconte algo acerca de syndaemon, pero solo encontre soluciones para gnome y ahora estoy usando kubuntu.

Saludos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Gracias pedro1961, eso es lo que yo habia visto (en otros foros y algun howto), el problema es que yo no tengo la seccion del touchpad en el xorg.conf, de modo que no podia añadir la opcion SHMConfig "on" en dicha seccion, por eso consultaba si la podia crear yo editandolo.

Ahora esta desactivado a perpetuidad como comente antes, lo cual es perfecto porque siempre uso un raton usb.

Saludos

Edito: hoy el raton no funciona y el touchpad sí, de modo que he vuelto a poner "mice" en vez de mouse1 y vuelven a funcionar los dos, creo que intentaré editar el xorg.conf y añdire esa entrada.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Lo habia pensado, de momento he añadido la sección, he provado a poner SHMConfig "true" en vez de "on" pues en algun sitio aconsejaban esa otra opcion, pero tanto ksynaptics como syndaemon me da un error parecido:

Can't access shared memory area. SHMConfig disabled?

¿Y si intentase la solucion "bestia": desinstalar el driver?

Saludos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Exito :)

Primero desinstale e instale de nuevo el xserver-xorg-input-synaptics y despues hice lo que me aconsejaste pedro 1961, con esto consegui que se crease la seccion correspondiente al touchpad en el /etc/X11/xorg.conf, añadi la linea SHMConfig con el valor "on", reinicie (CTRL+ALT+backspace) y en la consola escribi synclient -l, ya no obtuve el error, entonces instale ksynaptics y con esto puedo desactivar el touchpad mientras escribo o desactivarlo-activarlo totalmente pulsando la combinacion de teclas ALT+CTRL+P y tengo un icono en el systray que me indica el estado del touchpad :) :)

Gracias

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado
Este tema está cerrado a nuevas respuestas.
Conéctate para seguir esto  

×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.