Ir al contenido
Conéctate para seguir esto  
juaniniargentona

Problema con MRtg y SNMP en debian 4Etch

Publicaciones recomendadas

Hola a todos tengo un servidor montado con una distribución Debian 4 Etch, Me he dispuesto a monitorizar las interfaces de dicho servidor que trabaja como router utilizando la herramienta MRTG (ya que lo instalé una vez en otro servidor debian sarge y me funcionó a la primera).

Bueno he procedido a la instalacion de snmp, snmpd, mrtg

#apt-get install snmp snmpd mrtg mrtg-contrib mrtgutils.

he configurado el archivo de snmpd.conf:

# sec.name source community

com2sec local 127.0.0.1/32 alg

com2sec miredlocal 192.168.1.0/24 alg

recommunity alg

# sec.model sec.name

group MyRWGroup v1 local

group MyRWGroup v2c lcoal

group MyRWGroup usm local

group MyROGroup v1 miredlocal

group MyROGroup v2c miredlocal

group MyROGroup usm miredlocal

# Third, create a view for us to let the groups have rights to:

# incl/excl subtree mask

view all included .1 80

view system included .iso.org.dod.internet.mgmt.mib-2.system

# Finally, grant the 2 groups access to the 1 view with different

# write permissions:

# context sec.model sec.level match read write notif

#access MyROSystem "" any noauth exact system none none

access MyROGroup "" any noauth exact all none none

access MyRWGroup "" any noauth exact all all all

# -----------------------------------------------------------------------------

A la hora de utilizar la opción de cfgmaker para que me genere el archivo mrtg.cfg

proxy-server#cfgmaker alg@192.168.1.201 o cfgmaker alg@localhost

me aparece el siguiente error:

SNMP Error:

no response received

SNMPv1_Session (remote host: "192.168.1.201" [192.168.1.201].161)

community: "alg"

request ID: 520123017

PDU bufsize: 8000 bytes

timeout: 2s

retries: 5

backoff: 1)

at /usr/share/perl5/SNMP_util.pm line 627

SNMPWALK Problem for 1.3.6.1.2.1.1 on alg@192.168.1.201::::::v4only

at /usr/bin/cfgmaker line 921

WARNING: Skipping alg@192.168.1.201: as no info could be retrieved

cuando escribo solo proxy-server#mrtg me aparece este error:

-----------------------------------------------------------------------

ERROR: Mrtg will most likely not work properly when the environment

variable LANG is set to UTF-8. Please run mrtg in an environment

where this is not the case. Try the following command to start:

env LANG=C /usr/bin/mrtg

-----------------------------------------------------------------------

Alguien sabe a que se debe esto??

He reiniciado 20000 veces snmpd

proxy-server#/etc/init.d/snmpd restart

proxy-server#/etc/init.d/snmpd reload

pero sigue igual

les agradecedira su ayuda.

Muchas gracias y hasta pronto

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado Guillenet

Simplemente escribe:

env LANG=C /usr/bin/mrtg

En la consola y ya funciona. Ojo que has puesto lcoal en vez de LOCAL en las primeras líneas.

Un saludo,

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado
Este tema está cerrado a nuevas respuestas.
Conéctate para seguir esto  

×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.