Ir al contenido
Conéctate para seguir esto  
Endemoniado

Problemas de conexion con OpenSuSe

Publicaciones recomendadas

Hola

Soy un nuevo usuario de Linux y estoy iniciandome con la distro OpenSuSe 10.3

Mi proveedor de internet es Orange, con un router Inventel (Livebox-E650).

Tengo un portatil Toshiba y las tarjetas que trae incorporadas son:

-Intel PRO/Wireless 3945ABG Networl Connection

-Toshiba America Info PRO/100 VE Network Connection

En un principio instale la distro, desde el DVD de instalación sin actualizar via online porque no me reconocia en un principio durante la instalacion la red inalambrica y tras finalizar la instalacion, sin tocar nada de la config,la conexion a internet iba bien sin problemas, via inalambrica introduciendo mi clave de cifrado wep.

Por otros motivos procedi a instalar de nuevo la distro y en esta ocasion, ademas de instalar desde el DVD, procedi a actualizar online la instalacion, conectando el portatil por cable al router. Reconocio la conexion sin problemas y actualizó todo lo necesario.

El problema viene despues. No consigo conectar por via inalambria a ninguna red. Mi conexion tiene cifrado wep, pero aunque ponga la clave correcta no accede. De hecho, una vez que creo la conexion y pongo la clave wep, cuando le doy a conectar me la pide de nuevo, pero no la clave wep si no la wpa, sin darme la opcion de cambiar el tipo de cifrado.

Por otro lado, si me conecto por cable al router, el portatil tiene conexion, pero tarde o temprano esta se cae y he de reiniciar el router para poder continuar con la conexion. Podria pensar que es cosa del router, pero si reinicio y cambio a Windows (sin resetear el router) la conexion va perfectamente (si reinicio y arranco en linux de nuevo sigo sin conexion).

Me podeis dar una pista de por donde empiezo a trastear a ver si doy con la solucion?

Gracias

PD: soy totalmente nuevo en Linux de modo que no se si sere capaz de interpretar correctamente lo que me podais decir... :oops:

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

OpenSuse tiene una forma muy particular de hacer las cosas.

Fijate que el instalar la primera ves, todo se configuró partiendo del wifi, mientras que la segunda ves se configuró desde la ethernet. Probá desconfigurar cualquier conexión por la tarjeta de red y luego configurar el wifi, o deshabilitar la de red para que solo trabaje la wifi.

Lo aconsejable suele ser deshabilitar la ethernet y solo trabajar via wireless. Sobre todo si has puesto lo de recibir las ips desde el servidor dhcp. En este caso el sistema suele buscar donde salir y si supone que debe hacerlo desde la placa de red, al no haber nada, te deja sin conexión.

Cuando eso pase, en ves de reiniciar el router, pones en consola:

sudo ifconfig eth0 down

sudo ifconfig eth1 down

sudo dhcp eth1

donde eth0 es tu placa de red cableada y eth1 la wifi, primero desconfiguro todo y luego pido los datos al router a traves de eth1. Fijate las interfaces para tu caso las placas Intel suelen ser asi.

Veamos.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

OK. A ver si tengo un rato y pruebo a hacer eso. La verdad es que si que seria lo mas recomendable, quedarme con la opcion del wireless y desactivar el cable.

En cuanto me pueda poner un ratin cuento como me ha ido.

Muchas gracias ;)

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

El asunto es que opensuse tiene una forma bastante particular de hacer las cosas, lo que hace que no sea tan flexible en algunos aspectos. Primero desconfiguras las dos interfaces, la wifi y el cable, luego configuras solo la wifi para que solo tome esa. En distros como archlinux o ubuntu, por ejemplo, lo que haces es dar de baja el cable y luego configurar el wifi. En Opensuse debes hacerlo desde la configuración del sistema (yast2). En comandos sería:

ifdown eth0

ifdown eth1

iwconfig eth1 mode maneged

iwconfig eth1 ESSID "la que sea"

ifconfig eth1 eth1

route add default gw dev eth1

Primero descargo las interfaces, la eth0 de cable y la eth1 la wifi, luego configuro los parámetros wifi, como el modo de la tarjeta y el ESSID, luego le asigno ip, después configuro el router a través del wifi. Estos sería en comandos, pero en suse el tema se maneja desde yast2.

Veamos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

A ver...voy a YaST, dispositivos de red, tarjeta de red y en "opciones globales", selecciono en "metodo de configuracion de la red" el "metodo tradicional con ifup". De este modo desactivo el Knetwormanager (o eso creo). Terminar.

Hago lo anterior porque si abro un terminal en modo superusuario para ejcutar los comandos que me dijiste en el post anterior, me dice:

ifdown eth0

Network interface is managed from NetworkManager

NetworkManager cannot be advised to take down an interface.

Set up another interface instead.

Desactivando el Knetworkmanager, al ejecutar el comando ifdown eth0 lo hace correctamente y me lanza este mensaje:
ifdown eth0

    eth0      device: Intel Corporation PRO/100 VE Network Connection (rev 02)

Pero cuando ejecuto ifdown eth1 me dice:
ifdown eth1

    eth1      no such interface

Interface not available and no configuration found.

Dado que via terminal parece que no puedo hacerlo, voy al YaST de nuevo.

En configuracion de red, selecciono el controlador wifi, Intel PRO/Wireless 3945ABG Network Connection, selecciono configurar y le asigno mi dirección IP y la mascara de subred; pulso en siguiente y selecciono "Modo de Operacion Gestionado", Identificador de red (ESSID) Livebox-E650, "modo de autenticacion" Clave compartida WEP, "tipo de entrada clave" Contraseña; introduzco la clave WEP y pulso en siguiente y terminar.

Reinicio el PC.

Pues haciendo todo eso no tengo conexion...

No se si hago algo mal o si tengo que hacer alguna otra cosa...

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Por eso lo de que el suse hace las cosas bastante especiales. El networkmanager sirve para gestionar la red de manera gráfica pero se supone que en cualquier linux se pueden usar los dos métodos, en suse usa directamente el por defecto.

Antes de configurar la wifi desactiva cualquier configuración de la cableada, porque sino el sistema suele seguir saliendo a través de la cableada, la eth1 era optativa, podría ser wlan0, ath0, etc, fijate en tu caso suele ser útil el comando iwconfig en consola, ese te indica la interfaz, pero ya que usas "el método yast", usa el networkmanager.

La configuración wifi que has hecho es la correcta, el problema es la cableada que al estar configurada, el sistema le dá prioridad, entonces el sistema busca por el lado incorrecto. Una opción para ver que pasa es el ping, de consola pones:

ping

y ves por donde intenta salir, si el sistema no sabe por donde, te indica la intefaz que usa, sino te indicará que esta consultado, se sale con Ctrl+C.

Veamos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

OK. Mañana pruebo esas opciones en cuanto tenga un ratin ;)

De todos modos, si desactivo el knetworkmanager...no podria hacer el resto en modo terminal con los comandos que tu habias posteado?

Saludos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

BUeno, he tenido un ratin antes de ir a la cama y he intentado, tras desactivar el knetworkmanager, hacer esto en la consola:

portatil:~ # ifdown eth0

    eth0      device: Intel Corporation PRO/100 VE Network Connection (rev 02)

portatil:~ # ifdown eth1

    eth1      no such interface

Interface not available and no configuration found.

portatil:~ # ifdown wlan0

    wlan0     device: Intel Corporation PRO/Wireless 3945ABG Network Connection (rev 02)

portatil:~ # iwconfig wlan0 mode managed

portatil:~ # iwconfig wlan0 ESSID 192.168.1.159

portatil:~ # ifconfig wlan0 <192.168.1.159> dev wlan0

-bash: 192.168.1.159: No such file or directory

portatil:~ # ifconfig wlan0 192.168.1.159 dev wlan0

dev: Unknown host

ifconfig: `--help' gives usage information.

portatil:~ #

Parece que tenias razon y que lo correspondiente a la wifi era wlan0 y no eth1, pero sigue sin funcionar la cosa. No se por que dice eso de dev: Unknown host

PD: esta linea: portatil:~ # ifconfig wlan0 192.168.1.159 dev wlan0, es porque no tenia claro si la direccion IP tenia que ponerla entre <> o no

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

La teoría dice que si evitas el uso del networkmanager debería poder permitirte trabajar con los comandos en consola, de hecho el networkmanager es una interfaz gráfica para no meter mano a los comandos, sobre los mismos te indica algunos detalles:

portatil:~ # iwconfig wlan0 mode managed

aca definiste el modo de trabajo de la placa al ser un cliente de un router, podría ser también ad-hoc o master si lo permitiera el driver.

portatil:~ # iwconfig wlan0 ESSID 192.168.1.159

aca definiste el nombre de la red ESSID como 192.168.1.159, en este lugar va el nombre de red, por ejemplo iwconfig wlan0 ESSID red_de_casa

portatil:~ # ifconfig wlan0 <192.168.1.159> dev wlan0

-bash: 192.168.1.159: No such file or directory

el asunto acá es que al definir la ip debes hacerlo sin los signos <>, además que le estas indicando el dispositivo que ya esta indicado la línea correcta era:

ifconfig wlan0 192.168.1.159 up

portatil:~ # ifconfig wlan0 192.168.1.159 dev wlan0

dev: Unknown host

aqui el dev esta de más, luego de la ip puedes ingresar el nemask o máscara de subred luego levantas la red con up, la línea debería ser algo como:

ifconfig wlan0 192.168.1.159 up

Luego de definir a la interfaz agregas por donde sale y los dns, primero por donde sale o la gateway o puerta de enlace:

route add default gw 192.168.1.1 dev wlan0

luego editas el /etc/resolv.conf que define los servidores dns para poder navegar, si no dice nada el tema sería asi:

kedit /etc/resolv.conf

y en el archivo:

nameserver 200.51.212.7

nameserver 200.51.211.7

las ips son de los servidores de tu isp. Los que puse son los de telefónica de argentina. Todo esto debes poder hacerlo como has hecho en la otra instalación mediante el networkmanager del yast2. Que básicamente crea un script que suele andar en /etc/network/interfaces, en debian que se encara de indicar todo lo ingresado por consola al sistema para configurar el wlan0, todo esto como root.

Veamos.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola

Abro un nuevo terminal en modo root y meto los comandos tal y como los has modificado y todo parece que va bien. La consola no lanza ningun mensaje de error.

Luego voy a editar el resolv.conf pero no estoy seguro de que sea necesario. Esto es lo que contiene:

### BEGIN INFO

#

# Modified_by:  dhcpcd

# Backup:       /etc/resolv.conf.saved.by.dhcpcd.eth0

# Process:      dhcpcd

# Process_id:   3498

# Script:       /sbin/modify_resolvconf

# Saveto:       

# Info:         This is a temporary resolv.conf created by service dhcpcd.

#               The previous file has been saved and will be restored later.

#               

#               If you don't like your resolv.conf to be changed, you

#               can set MODIFY_{RESOLV,NAMED}_CONF_DYNAMICALLY=no. This

#               variables are placed in /etc/sysconfig/network/config.

#               

#               You can also configure service dhcpcd not to modify it.

#               

#               If you don't like dhcpcd to change your nameserver

#               settings

#               then either set DHCLIENT_MODIFY_RESOLV_CONF=no

#               in /etc/sysconfig/network/dhcp, or

#               set MODIFY_RESOLV_CONF_DYNAMICALLY=no in

#               /etc/sysconfig/network/config or (manually) use dhcpcd

#               with -R.  If you only want to keep your searchlist, set

#               DHCLIENT_KEEP_SEARCHLIST=yes in /etc/sysconfig/network/dhcp or

#               (manually) use the -K option.

#

### END INFO







nameserver 192.168.1.1

El nameserver es mi DNS y no estoy seguro de que sea necesario cambiarlo por los teoricos de Orange España (62.36.225.150 y 62.37.228.20).

Por otro lado, no lo entiendo pero la conexion ahora funciona con el cable conectado (a pesar de haber puesto lo de eth0 down y eso) y si lo desconecto no funciona, lo cual viene a deir que el wifi no marcha...

PD: da gusto las explicaciones a los comandos. De ese modo ademas de solucionar los problema puedo ver por que ;)

Gracias

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Al resolv.conf no lo toques, es asunto es que al asignarte Orange la ip, te asigna las direcciones de los dns, esto queda en el router que es el encargado de redireccionar las peticiones del router a los dns del isp.

El tema de tener dos interfaces configuradas, es asi: al tener dos formas de salir a internet, tu pc necesita que se le indiques cual debe usar, es decir podes tener configuradas con ip cada interfaz, la de cable y la wifi pero lo importante es el comando route que se encarga de definir por donde salen las cosas a Inet, cuando desconectas el cable, aunque tengas las dos interfaces configuradas, el sistema va ha buscar salir por el cable y te va ha indicar que no hay conexión, eso es porque la salida esta definida por eth0 y hay que buscar que se defina por wlan0, una opción sería ver si en networkmanager hay alguna opción para definir que interfaz usar, sino debes ver, primero que indica el comando route y luego si esta indicado desactivarlo y luego habilitar el wifi, sería:

route

para ver que hay, debe salirte algo como:

javier@javier:~$ route

Tabla de rutas IP del núcleo

Destino Puerta de Enlace Genmask Banderas Metrica Ref Uso Interfaz

192.168.100.0 * 255.255.255.0 U 0 0 0 eth0

link-local * 255.255.0.0 U 1000 0 0 eth0

default 192.168.100.1 0.0.0.0 UG 100 0 0 eth0

javier@javier:~$

lo importante es lo que figura en negrita, es decir esta definido el gateway por el eth0, para desactivarlo debes hacer:

route del gw 192.168.1.1 dev eth0

aqui no me acuerdo si necesitas el dev eth0, creo que no va, sino:

route flush

esta no siempre funciona, pero básicamente borra todo lo que hay en route, luego defines la nueva ruta:

route add default gw 192.168.1.1 dev wlan0

es muy importante la opción dev ya que indica por donde sale a internet, luego vuelves a hacer el route y ves que dice.

Veamos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Pues esto es lo que me dice cuando pongo "route" en el terminal:

 portatil:~ # route

Kernel IP routing table

Destination     Gateway         Genmask         Flags Metric Ref    Use Iface

192.168.1.0     *               255.255.255.0   U     0      0        0 wlan0

link-local      *               255.255.0.0     U     0      0        0 wlan0

loopback        *               255.0.0.0       U     0      0        0 lo


Entiendo que la opcion del cable esta desactivada y que por defecto deberia intentar acceder via wifi...

PD: todo esto lo estoy haciendo en modo consola/terminal y con el knetworkmanager desactivado.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Bueno, dado que no era capaz de dar con el problema, pese a la magnifica ayuda que me has prestado por aqui, y sabiendo que la primera vez que instale el Opensuse 10.3 sin actualizar via online durantge la instalacion, la cosa marcho bien, he decidio volver a probar por ahi.

He reinstalado la distro y tras arrancar con knetworkmanager...la cosa no iba bien :P

Procedi a desactivarlo para volver a comenzar con todo el proceso de configuracion via terminal de este hilo, pero tras activarse el kinternet como gestor de la conexion parece que ahora todo va bien.

Se conecta via wifi, parece que sin problemas y ahora mismo estoy actualizando la distro.

Te mantendre informado de si todo va bien ;)

Gracias

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Sobre el route de arriba, debería aparecerte la ip del router en la columna que dice Gateway.

Sobre la reinstalación, si haces un route verías la tabla correcta ya que el tema sale por donde debe salir.

Veamos. :)

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola

A pesar de que tngo algunos problemillas, al menos con el Kinternet gestionando la conexion tengo internet.

El problema (y no se por que..) es que a veces se desconecta de la red (o al iniciar el PC) y he de ordenar al Kinternet que conecte a la red adecuada y cada vez que lo hace he de meter de nuevo la clave wep, a pesar de que la tiene guardada.

Sigo trasteando pero ni en la config del Kinternet ni en la opcion de configurarlo via YaSt doy con la solucion...

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Lo de la clave wep puede ser un tema seguridad de suse, sobre las desconexiones, fijate de ponerle ip manual, es decir que no use el dhcp, porque suele tener un tiempo de renovación de la ip. En las configuraciones de pppoe había una opción, usando el yast, que decía de un tiempo de inactividad de la conexión, la idea es desconectarte si no estas usándola, es decir usando el teclado o navegando usando el mouse. Todas estas opciones "a lo suse" pueden ser configuradas a través del yast que hace todo el trabajo, en esta utilidad deben estar todas las opciones de pedir wep cada ves que reinicias o el tiempo de renovación de la ip.

Veamos.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado

A ver. Seleeciono, en YaST, la tarjeta de red, le doy a configurar y en direccion tengo marcado "IP Dinamica DHCP". Desmarco esa opcion y selecciono "Direccion IP estatica aasignada", metiendo mi IP y mi mascara de subred.

Siguiente, siguiente, terminar. Haciendo eso no solo no se conecta a ninguna red, si no que ni siquiera puedo hacer busquedas manuales ni pedir que se conecte. O_O

Estos poltergeist solo me ocurrena mi? :P

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Cuando decir tarjeta de red, no es la cableada sino la wifi, no? antes de los siguiente, fijate que te dice porque en esos siguiente seguro te faltó algo. Recuerda que al indicar ip manual además de la ip, mascara de red, debes indicar gateway o puerta de enlace para que sepa por donde salir a Internet. Sino el sistema configura la ip del wifi, pero no por donde sale.

El dhcp suele asignar, ip, mascara de red, gateway o puerta de enlace, y editar el /etc/resolv.conf para indicar los dns. En la conexión con asignación manual todo estos datos debes indicarlo. Si haces esta asignación debe modificar también el router para que no asigne ips, o poner una ip que no este en el rango de ips que configura, sino modificalo a asignación por dhcp y fijate en la opción de desconexión por no uso de la conexión. Suse es el único que conozco tiene eso.....

Veamos.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

EL problema es que no tengo en donde poner el gateway! Solo tengo la opcion de introducir los datos para la IP y para la mascara de subred (en la primera pantalla de configuracion de la tarjeta de red); en la segunda pantalla de configuracion tengo para poner el modo de operacion (gestionado, Ad-hoc o Maestro), el identificador de red (ESSID), el modo de autenticacion , el tipo de entrada de clave y la clave y a partir de ahi la opcion de terminar...

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado
Este tema está cerrado a nuevas respuestas.
Conéctate para seguir esto  



×

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.