Ir al contenido
MrREIVAX2

Router huawei no abre puertos

Publicaciones recomendadas

Hola a todos/as, soy nuevo en este sitio

Os cuento...

Tengo un router Huawei Echolife HG8245U Fibra óptica, el tema esta que me he domotizado mi casa y quiero controlar todo remotamente desde "cualquier parte del mundo"

me he creado un servidor con ESP8266 controlado con  HTML  con IP fija, con la red interna wifi me funciona perfectamente pero no remotamente conociendo la IP publica del router

he configurado el router Huawei desde el menú Forwar Rules redireccionando la petición remota de la IP publica a la IP del dispositivo servidor NO funciona

he configurado el router Huawei con la opción DMZ (zona desmilitarizada) NO funciona

he configurado el router Huawei con el firewall del mismo router NO funciona

he configurado el router Huawei con el firewall y el Forwar Rules NO funciona

me registre en la pagina NO-IP para hacer de enlace con el router y servidor remotamente NO funciona

desde CMD hago ping a la IP publica y NO recibo paquetes, NO funciona

Me cree un Telegram-Bot y curiosamente si que me abre un puerto ,el 433, y funciona perfecto, con telegram-Bot puedo abrir el puerto que quiera, que curioso verdad ??

Que estoy haciendo mal ?

Cabria la posibilidad que el soft del router estuviera cerrado de fabrica para los usuarios

alguien me podría indicar si hay otra forma para abrir los puertos

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

¿Con que compañía tienes internet?

¿Has comprobado que la IP pública que ves mirando en la configuración del router es la misma que cuando usas uno de esos enlaces que te dicen cual es tu IP?

 

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola winkel, desde hace poco más de 1 año voy con una empresa Provincial (que se va extendiendo) que se llama emagina pero utiliza Movistar

La IP la tengo siempre fija , supongo que lo que pago para el servicio internet debo pagar un "plus" que debe incluir que me mantiene la IP fija ,por mucho que apague o reseté el router siempre es la misma185.107.1XX . XXX

la IP esta comprobada por varias páginas web y todas me dan la misa IP

Muestro un par de capturas de la ultima configuración realizada en el router huawei, y digo la ultima configuración porque he realizado  muchas combinaciones en la configuración para ver si alguna funcionaba, y.... nada :(

también dejo una foto del dispositivo ESP8266 12-E WiFi que utilizo como servidor con HTML con IP fija para hacer el control domotico Scada o HMI, para la gente que no sepa que es

foto 1.jpg

 

 

foto 4.jpg

 

foto 3.jpg

foto 2.jpg

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

No pongas nada en External Source IP para que puedas acceder desde cualquier sitio.

Por cierto tengo pendiente empezar a meterme con bichos como ese desde que me regalaron uno pero nunca me decido.

Cuando pruebes a hacer un acceso desde el exterior no lo hagas desde la propia LAN, hazlo con un móvil usando datos por ejemplo.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Hola winkel

en la External Sourcer IP, en una de las muchas combinaciones no pongo nada y tampoco funciona

las pruebas las hago siempre desde el móvil sin conectarme a la red wifi interna

pero no hay manera de acceder remotamente

estoy llegando a la conclusión de que el soft estuviera cerrado de fabrica

veo que al final tendré que ir directamente a la empresa y que me ayuden o me abran el soft

Pongo una captura de pantalla del servidor HTML sencillo que tengo actualmente funcionando vía wifi dentro del esp8266 en mi casa 

Y si quereis ver mi primer proyecto en una parte de mi casa con un Wemos D1 wifi (no tan poderoso como el esp) aqui os dejo el link del video

 


los "bichos" estos que comenta usted, si empieza, son muy viciosos, mucha gente se agobia al ver la programación en código libre, pero cundo le tienes el truco.....ya esta

Yo vengo del mundo del autómata plc industrial y empece con el mítico arduino, e ido probando muchos modelos y actualmente para pasar mi tiempo libre estoy viciado con esp8266, esp32, etc..

Te da muchísima libertad para hacer lo imaginable( repetidores wifi, geolocalizador gps, alarmas vía telegram email, control de vivienda o lo que uno quiera por medio de telegram, WhatsApp, html, servidores y todo a un precio muy bajo, yo los compro actualmente a 1,50 euros la unidad y un par de horas de programación y montaje :)

foto a.jpg

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

Otra opción es poner 0.0.0.0 en external source.

¿Por que no pruebas con puerto externo 8080 que redirija a 80 interno?

 

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

 

Para que lo sepa , agradezco muchísimo su ayuda y su paciencia conmigo, es de agradecer :)
el 0.0.0.0 en external source el mismo router no me lo acepta

el 8080 externo con 80 interno tampoco funciona

he realizado, varias veces, un netstat -b como administrador (con el servidor operativo) para saber las IP que me trabajan internamente y sus puertos al igual que las IP y sus puertas externas, y, por algún motivo desconocido externamente el router no admite la IP externa, motivo por el cual cuando en el navegador ingreso la IP externa me dice que no encuentra nada

lo curioso del caso, es que, si hago un test de velocidad, (speedtest.net) incluso me sale la IP publica fija al lado izquierdo del reloj

con google home mini, IFTTT,(que también lo tengo en funcionamiento) también he realizado pruebas, y bien se conectan al router y entran al servidor, claro esta que se conectan con token y por medio de SSH o telnet, pero bueno, es un puerto igual

sinceramente estoy en un punto que no sé por donde ir o investigar, ya que llevo bastantes días de ensayo y error

si alguien tiene alguna idea nueva para probar, estoy abierto a todo

foto B.jpg

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

en external source pon 0.0.0.0 255.0.0.0 el puerto de escucha cámbialo a 8080 a no ser que puedas confirmar que el router no usa la 80 como la propia para configuración web remota algunos cambian si se configura en los puertos pero no, si se hace en la dmz.

también tienes que verificar que en las webs en las que pueden mirar las ip que te indique que no estas pasando por ningún tipo de proxy 

 

 

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

hola vaxx

He verificado lo del proxy y no hay proxy  de por medio

he realizado varias combinaciones con 0.0.0.0 255.0.0.0 tal como me ha comentado y en todas el router no me lo acepta

me sale un cartel de advertencia de invalid 

foto 9b.jpg

foto 9a.jpg

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado MrReivax2

Hola a todos/as de nuevo

es simplemente para comentar que, después de investigar mucho y hacer muchas pruebas encontré el motivo (NO PROBLEMA)

el motivo por el cual no puedo conectarme remotamente a mi servidor interno de mi casa

el motivo es relativamente sencillo y no sé hasta que punto se puede solucionar,

mi operadora, al igual que otras operadoras, aplica el sistema CGNAT en las IP publica

Es decir... hoy en dia las IPV4 están agotadas y una alternativa para alargar la vida de las IP es el "nuevo" sistema CGNAT que consiste en que una operadora con una sola IP puede dar servicio a varios clientes sin que el propio cliente lo sepa

es decir una IP publica "falsa"

Cualquier cliente que hoy en día no pueda conectarse remotamente teniendo su router bien configurado y habiendo verificado su ip publica en alguna página web, no es problema o error de configuración. Simplemente es su operadora que le aplica la CGNAT

para saber si vuestra operadora os aplica la CGNAT es muy fácil  (una vez lo sabes, claro esta :)   )

entrar en CMD

teclear        tracer IP PUBLICA

return

si sale 1 sola línea de verificación NO tenéis CGNAT

si sale más de 1 línea tenéis aplicado el CGNAT

solución a este problema.....hablar con vuestra operadora a ver que respuesta os da :) :)

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado MrReivax2

Perdón, rectifico

tracert   

 

 

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web

el cgnat es un sistema como los proxys transparentes que se usaban antes por eso te dije que te asegurases de no pasar por un proxy 

lo del cgnat normalmente llamando a la operadora y explicando que necesitas acceso remoto para gestiones internas suelen sacarte del cgnat

 

 

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado MrReivax2

Hola vaxx

Tienes razón en tu comentario, pero quien se iba a imaginar que a uno le aplican un cgnat ??

Hasta que descubrí que mi operadora me aplicaba el cgnat, desconocía por completo que tenia un proxy de por medio, nadie me informo, ninguna operadora te comenta nada cuando te das de alta en un servicio de internet, lo descubres cuando te hace falta

en mi casa, yo tengo un router y nada más y no tengo ningún proxy, y en ningún momento imagine que aguas para afuera pasaría por un proxy externo a mi casa y por una IP PUBLICA "falsa"

me extraño un poco, cuando, después de los comentarios arriba descritos, mande unos 8 correos electrónicos a mi operadora y nadie me respondió, luego hice un par de llamadas y me dieron "largas" pasando de una sección a otra sin darme respuestas claras

investigando más a fondo, he descubierto que, particularmente, mi operadora no soporta las IPV6 por eso aplica la cgnat en las IPV4

el motivo de que, mi operadora, al igual que otras muchas operadoras (no todas) no trabajen con IPV6 es por el simple echo de que no pueden con la infraestructura y la complejidad de dar IPV6 para los clientes, por eso no me responden a los correos y me dan "largas" por teléfono

ahora solo me queda presentarme físicamente a ver hasta donde puedo llegar

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado Raul Cat

Muchísimas gracias por tu investigación, MrReivax2. Me estaba volviendo loco con este tema. Al final deduje que algo tenía que ver mi comañía (también emagina). Mañana mismo les llamo a ver que se puede hacer. Tu les llamaste? Te lo solucionaron? Se que algunas te lo eliminan si pagas algo. Esta no lo se.

Compartir este mensaje


Enlace al mensaje
Compartir en otros sitios web
Invitado
Responder a este tema...

×   Pegar como texto enriquecido.   Restaurar formato

  Only 75 emoji are allowed.

×   Tu enlace se ha incrustado automáticamente..   Mostrar como un enlace en su lugar

×   Se ha restaurado el contenido anterior.   Limpiar editor

×   No se pueden pegar imágenes directamente. Carga o inserta imágenes desde la URL.


×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.