Ir al contenido

Gentoo no me reconoce mi wireless


Publicaciones recomendadas

Hola,

Tras decidirme con volver a la carga con linux de nuevo, esta vez con Gentoo, hacer las particiones y todo eso, cuando voy a comprobar la conexión [iwconfig eth0] me dice que no hay ningun dispositivo (no such nosequé) wireless. Con windows me reconoce la targeta ethernet wireless D-link Air Plus XtremeG+ DWL-G520, que se me configura automaticamente (en win). Pues el problema esta ahí, ahora viene la pregunta que os quiero hacer... Me supongo que si hago un net-setup eth0 podria ayudar a que me pillara la targeta (¿no?) pero cuando hago esto me pide varios campos que desconozco en su mayoría:

Me pide:

- El SSID, que lo he mirado en la config del router y me pone que es "3com"

- Si utiliza encriptación

- WEP key, si es ASCII o hexagesimal

- WEP Key en si.

Bueno, pues a ver si puedo conseguir estos parametros para probar a ver si me consigue reconocer la wireless, si no se pueden mirar o si alguien sabe alguna otra manera que me diga que puedo hacer para que me pille la ethernet....

PD: Mi router es un 3com wireless 11g, y mi ISP es ya.com.

PD2: Soy bastante novato, asi que puedo haberme equivocado en alguna de mis "hipotesis".

Gracias

Saludos

Enlace al mensaje
Compartir en otros sitios web

Hola, squier. A mi me pasa algo parecido a ti, lo único es que mi tarjeta de red es USB (la tuya creo que es PCI, no?) Yo puse un post hace tiempo http://www.adslayuda.com/foro-viewtopic-t-35054.html para ver si lo conseguia solucionar, pero hasta ahora no lo he conseguido. De todas maneras mira a ver si lo consigues con los consejos que me dieron a mi. Suerte!!

Si te funciona dilo.

Salu2

Enlace al mensaje
Compartir en otros sitios web

Bueno, lo que pasa es que yo no puedo hacer nada, porque la instalación si no tienes conexión no se puede acabar... o mejor dicho comenzar...

Ahora lo que yo pregunto es como aconseguir los parametros esos que pregunto, donde los puedo mirar.... Si no tiraré la toalla con linux, estoy harto ya de siempre estar con el mismo problema; si ya es difícil la instalación con la config de una wireless....

Saludos

Enlace al mensaje
Compartir en otros sitios web

erm... pero .... ermmm.... xD

¿Tienes el modulo del driver de tu adaptador wireless cargado? Es que ... precisamente Gentoo... no detecta nada !! xD lo tienes que cargar tu todo. Posiblemente no haya soporte para tu adaptador wireless en el cd de instalacion, haz una instalacion offline como la que explican en el foro de instalacion de http://www.gnuinos.org y despues descarga el driver desde algun sitio y te lo grabas en un cd para ponerlo en ese PC.

Por que no pruebas con otra distro como Mandrake o SuSe ??

Un saludo.

Enlace al mensaje
Compartir en otros sitios web

Hola,

Si, eso despues de preguntar por ahi ya lo "descubrí" lo que pasa es que de todas maneras mas adelante lo necesitaré, asi que tampoco iva a quitarlo...

De todas maneras no sé el modulo de mi targeta y lo de la instalación offline que hay en gnuinos es de una versión un poco antigua, y además por el chat de gnuinos me han dicho que es muy liosa...

Antes de probar con gentoo utilize MDK 10.0 y tampoco me la reconoció, por eso lo abandoné...

Saludos

Enlace al mensaje
Compartir en otros sitios web

Vamos por partes.

Linux te reconoce la tarjeta ethernet?

Si no te la reconoce, eso es lo primero que tienes que conseguir. Una vez Linux ya te reconozca la tarjeta entonces ya podras configurar la red.

En la dirección

http://wiki.adslayuda.com/linux/index.php/Drivers/Ndiswrapper

te dice como tienes que hacer para configurar el driver de windows (que supongo que tendrás) de tu tarjeta ethernet para que Linux te la reconozca. Una vez tienes hecho esto (si todo va bien, yo no lo conseguí :cry: ) entonces ya podras configurar el acceso a internet.

De todas maneras, por defecto (si no has cambiado nada) en el ADSL de ya.com

SSID: 3com

Sin encriptación.

Como no usa encriptación por defecto no te pedirá el tipo de WEP

Animo y que tengas suerte, yo lo deje por imposible porque Linux no se lleva muy bien con las tarjetas de red USB. Una pena, vamos

Salu2

Enlace al mensaje
Compartir en otros sitios web

Am, se me olvidaba. Si la tarjeta de red es wireless tienes que cambiar eth0 por wlan0.

Prueba con iwconfig wlan0 a ver si ahi va a estar el problema

Mi tarjeta de red es wireless y es eth ;)


Gentrinoo root # iwconfig

lo        no wireless extensions.


eth0      IEEE 802.11g  ESSID:"overpeer"

          Mode:Managed  Frequency:2.437 GHz  Access Point: 00:0F:66:45:DE:A8

          Bit Rate=54 Mb/s   Tx-Power=20 dBm

          RTS thr:off   Fragment thr:off

          Encryption key:DD69-7CD6-1A43-2E3D-983F-B0FE-81   Security mode:open

          Power Management:off

          Link Quality=100/100  Signal level=-27 dBm  Noise level=-85 dBm

          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0

          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

Un saludo.

Enlace al mensaje
Compartir en otros sitios web

Antes de probar con gentoo utilize MDK 10.0 y tampoco me la reconoció, por eso lo abandoné...

mmm hombre, como consejo, te recomiendo estar una distro menos laboriosa, en Gentoo hay que cargar los módulos uno mismo y si no están, buscarlos y cargarlos.

De todas maneras, normalmente casi todas las distros soportan lo mismo, teniendo los mismos kernel, lo que se suelen diferenciar es en el modo de detectar el hardware.

Yo intentaría buscar el módulo , tendría instalada una distro y aprendería a usar ese módulo. Luego instala Gentoo, o consigue los cd enteros aunque no tengan lo últimisimo.

Enlace al mensaje
Compartir en otros sitios web

Mi tarjeta de red es wireless y es eth

squier ya dijo que habia intentado configurarla usando iwconfig eth y no le habia funcionado, por eso le he dicho que probara a hacerlo de la otra manera, ya que algunas solo las puedes configurar con wlan. Si el problema no lo solucionas de una manera prueba de otra, a veces los errores están en los lugares mas tontos

Trata de dar soluciones alternativas en vez de cuestionar las dadas. Aqui estamos todos para ayudar :lol:

Venga, un saludo

Enlace al mensaje
Compartir en otros sitios web

por eso le he dicho que probara a hacerlo de la otra manera

Si la tarjeta de red es wireless tienes que cambiar eth0 por wlan0

No,has dicho que si la tarjeta es wireless implica cambiar a wlan0 y eso no es asi.

Trata de dar soluciones alternativas en vez de cuestionar las dadas. Aqui estamos todos para ayudar

Claro, imaginate que esto lo lee otra persona con otro problema, al leer que siempre hay que poner wlan0 pues lo hará y no es asi.

De todas formas, yo pienso que tiene que buscar el módulo de su tarjeta red o si está soportado, si no por mucho que ponga y configure no le va a funcionar, con poner su nombre de tarjeta en google y la palabra linux al lado, en 5 minutos lo sabe.

Si ya sabe que hay un módulo y lo tiene cargado, que empiece a trastear con las configuraciones..

Saludos.

Enlace al mensaje
Compartir en otros sitios web
Invitado
Este tema está cerrado a nuevas respuestas.
×
×
  • Crear nuevo...

Información importante

Términos de Uso Política de privacidad Hemos colocado cookies en su dispositivo para ayudar a mejorar este sitio web. Puedes ajustar la configuración de tus cookies ; de lo contrario, asumiremos que quieres continuar.